TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Turbocad 2019 Runs Slow if Left Open
Read 932 times
January 19, 2020, 06:17:32 AM
Hello -
I am running TurboCad 2019 Pro on a new desktop computer with Windows 10 pro.

TC slows down when left open for long -  sometimes to the point of being nearly inoperable.
Closing the problem and reopening usually fixes the problem.
I can sort of live with the problem - but it is an annoyance.
Does anyone have any ideas as to what might be going on?
thanks....

Logged


* June 28, 2020, 07:08:54 PM
#1
Hello, have you managed to resolve this issue? I have the same problem and no one is able to solve it for me.

I’ve updated the software too.

I’m like you, i should have stayed with my previous version which ran faster. i didn’t buy the 2020 version because i truly believe I didn’t get value from 2019 and I don’t want to risk another flop.

Logged


* Today at 03:12:56 AM
#2
I'm having the same problem on Windows 10. It's only on WIndows 10 regardless of hardware, I can run on WIndows 7 with no issues whatsoever. In fact it's so bad on one drawing I can barely edit it!

There seems to be no resolution at all anywhere

Logged


Today at 04:27:15 AM
#3
I'm having the same problem on Windows 10. It's only on WIndows 10 regardless of hardware, I can run on WIndows 7 with no issues whatsoever. In fact it's so bad on one drawing I can barely edit it!

There seems to be no resolution at all anywhere

So the problem continues if you save the file, close TurboCAD, reboot your computer, restart TurboCAD and re-open the file?

If so, then make all the Layers visible (and unlocked), select all, copy and paste to a new document (Wireframe display mode for both files) to see if that helps.  See if there is a substantial reduction in file size, too.


Jeff

Logged
TC Pro Platinum 2020, 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* Today at 05:03:41 AM
#4
Houseplan, and Coastline.   More info please.

If Jeff's advice doesn't cure the problem.

Are you talking, 2019 Deluxe, pro, or Platinum.  are you using the computer between leaving TC open but unused, and starting again. Or are you just leaving the computer unattended.  Are you leaving it in wireframe or render mode.  32bit or 64 bit.  how much memory (windows 10 can be power hungry). what file size (uncompressed).  If left unattended, could an antivirus be kicking in (scanning) and upsetting things. There are probably more questions, but that will do for now.  A proper test may require a sample file but not yet.

Logged


Today at 05:25:00 AM
#5
I seem to remember this problem occurred on my pc with both 2018 & 2019pp. I did check the beta board for this problem but no solution was found there. Since this is an older problem Im not sure if that it is solvable, but I do remember that windows updates can contribute to the problem.

My main pc is a 2015 Lenovo, my notebook is a 2019 Dell build, Ive sometimes had issues with TurboPDF working then not on both my machines straight after a windows update and at other times after an update borh Turbocad versions would slow down.

This may shed some light on the whys and hows etc, can you provide feedback using the task manager and see whats occurring?




Logged
Daz
TCW V21, 2015-2020 PP, Animation Lab V5.2 & Redsdk enabled, LightWorks rendering mostly. Ender 3 3D printer.