TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Reset Perspective To Normal
Read 2062 times
* November 21, 2019, 06:04:13 AM
Hi All,

When I installed Redsdk the perspective got messed up. I went into View>Camera>Properties and checked Perspective View Box (because it was unchecked). Now I have zoom and panning problems. Zoom has been set to zoom all the way out on the object when I hit out button once and zoom in button does not have enough steps. Additionally panning with cursors has become a problem because each cursor button press moves left right up or down in large increments which makes it impossible to use. Other view features are too slow to use while designing.

How do I fix turbocad manually to make the zoom and pan behave like when the perspective box is unchecked without having to look at a disproportionate model? Older versions of TC did not have this problem when REDSDK was installed.

Logged
TurboCad Platinum Pro 19,20,21, 2019/REDSDK


* November 21, 2019, 06:41:41 AM
#1
Wasn't this answered in the topic: Re: is there a way to fix perspective in TC? ?

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* November 21, 2019, 07:09:22 AM
#2
Hi John,

I added some more detail. This is quite a weird thing for just unchecking a box to make models look correct. I have some things to try but its still not yet resolved.

Logged
TurboCad Platinum Pro 19,20,21, 2019/REDSDK


November 21, 2019, 01:10:07 PM
#3
How do I fix turbocad manually to make the zoom and pan behave like when the perspective box is unchecked without having to look at a disproportionate model? Older versions of TC did not have this problem when REDSDK was installed.

Have you tried adjusting the View Angle below the Perspective View radio button?  Smaller numbers will reduce apparent distortion.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* November 22, 2019, 05:51:57 AM
#4
How do I fix turbocad manually to make the zoom and pan behave like when the perspective box is unchecked without having to look at a disproportionate model? Older versions of TC did not have this problem when REDSDK was installed.

Have you tried adjusting the View Angle below the Perspective View radio button?  Smaller numbers will reduce apparent distortion.


Jeff

Hi Jeff,

I put the view angle at the minimum and maximum and it did not adjust the view... TC did not prompt me to restart to apply this setting and I haven't yet tried restarting to see if it applies it on next open.

Logged
TurboCad Platinum Pro 19,20,21, 2019/REDSDK


* November 22, 2019, 10:57:19 AM
#5
How do I fix turbocad manually to make the zoom and pan behave like when the perspective box is unchecked without having to look at a disproportionate model? Older versions of TC did not have this problem when REDSDK was installed.

Have you tried adjusting the View Angle below the Perspective View radio button?  Smaller numbers will reduce apparent distortion.


Jeff

Hi Jeff,

I put the view angle at the minimum and maximum and it did not adjust the view... TC did not prompt me to restart to apply this setting and I haven't yet tried restarting to see if it applies it on next open.

If "Perspective view" is enabled, then changing the "View Angle" should take effect immediately in the open drawing.

Henry H

Logged


* November 22, 2019, 12:25:48 PM
#6
How do I fix turbocad manually to make the zoom and pan behave like when the perspective box is unchecked without having to look at a disproportionate model? Older versions of TC did not have this problem when REDSDK was installed.

Have you tried adjusting the View Angle below the Perspective View radio button?  Smaller numbers will reduce apparent distortion.


Jeff

Hi Jeff,

I put the view angle at the minimum and maximum and it did not adjust the view... TC did not prompt me to restart to apply this setting and I haven't yet tried restarting to see if it applies it on next open.

If "Perspective view" is enabled, then changing the "View Angle" should take effect immediately in the open drawing.

Henry H

Hi Henry,

Yes it does work that way. With perspective view checked it does apply it instantly in drawing and the angle slider does not do anything when perspective view is not checked.

Here is part two of the problem. When I check the perspective box and set the angle to something that looks right the model looks normal again however there are functions that become messed up from checking the box.

Zoom with the +/- magnifier glass button becomes unuseable. check out attached images of the levels of zoom that I took screen shots of. Zoom 1 is far, Zoom 2 is a large step in, and zoom 3 is a super large step in. In addition to this arrow key steps are huge making it impossible to locate the screen on an exact part of the model. This camera orientation and position problem does not occur when perspective view is unchecked.

Other features for moving around the model are too slow for me to use in design and I have been using this method for moving around the model and targeting areas to make adjustments for a very long time.

The other thing that is strange about the zoom with magnifier two steps in equals only one step back. so going in you go from 1 to 2 to 3 but going out you go from 3 to 1.

Logged
TurboCad Platinum Pro 19,20,21, 2019/REDSDK


November 22, 2019, 12:45:08 PM
#7
...
The other thing that is strange about the zoom with magnifier two steps in equals only one step back. so going in you go from 1 to 2 to 3 but going out you go from 3 to 1.

For what it's worth:  My version-21 behaves pretty much the same way when in Perspective View.

The higher my Zoom Factor setting in Option/Preferences the more pronounced this occurrence is.  It seems to be is the multiple of my Zoom Factor setting.
« Last Edit: November 22, 2019, 12:48:13 PM by Alvin Gregorio »

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 22, 2019, 03:35:31 PM
#8
This is what I see with Alvin's drawing. When I switch on Perspective, I need to use "ViewToDrawingCenter" or "ViewToInFrontGraphic" to get the view to ‘spin’ in place when using the Dynamic Examine tool.
I don't rely on the Plus/Minus Zoom keys while in Perspective, but use the Dynamic tools to move around a drawing.
Dynamic Examine = Hold & drag the mouse wheel
Dynamic Roll = Hold wheel + Shift
Dynamic Zoom = Hold wheel + Ctrl
Dynamic Pan = Hold wheel + Shift + Ctrl

See YouTube movie: MicheliDE Perspective problem
No sound. I show the settings and go from 'no perspective' to 'perspective', then bounce around with Dynamic Tools (which move in real-time).
My 2-bits.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


November 24, 2019, 04:54:48 AM
#9
MicheliDE

As John and others have said use the proper "Dynamic" camera tools if viewing in perspective. I associate the zoom tool (Non Dynamic) for use in 2D and Isometric views that are not using perspective camera distortion.

That said, looking at the screen shots and reading your last post with the comment "When I check the perspective box and set the angle to something that looks right the model looks normal again" you are trying to get the perspective to look isometric. Dimensioning the workplane square seems to give me that impression with the values being very close to Isometric (see attached).

This would explain your problem using the Zoom tool as the behaviour in 2D and Isometric views do not suffer from "two steps in equals only one step back".


Logged
Daz…

V2019 Plat 64bit, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.


* November 25, 2019, 10:34:16 AM
#10
This is what I see with Alvin's drawing. When I switch on Perspective, I need to use "ViewToDrawingCenter" or "ViewToInFrontGraphic" to get the view to ‘spin’ in place when using the Dynamic Examine tool.
I don't rely on the Plus/Minus Zoom keys while in Perspective, but use the Dynamic tools to move around a drawing.
Dynamic Examine = Hold & drag the mouse wheel
Dynamic Roll = Hold wheel + Shift
Dynamic Zoom = Hold wheel + Ctrl
Dynamic Pan = Hold wheel + Shift + Ctrl

See YouTube movie: MicheliDE Perspective problem
No sound. I show the settings and go from 'no perspective' to 'perspective', then bounce around with Dynamic Tools (which move in real-time).
My 2-bits.

Hi John,

I find that the dynamic zoom is too slow for me because I do not have a mouse. I am using a laptop with a mouse pad that only has a center button no scroll wheel. I mouse over the magnifier + or - while clicking the button to zoom and hold the center button while making movements on the pad with both hands. This is much faster for me without a scroll wheel and why I can't quickly use dynamic pan and zoom. The Zoom with magnifier button works fine when perspective view is unchecked but looses three steps in and 6 outward when perspective view is checked. I'm fine without using a mouse but would like to use perspective view without a mouse instead of having to leave perspective view unchecked because the zoom changes. Why wouldn't the zoom in and out steps be the same between perspective view checked and not checked?

The text problem that I was having seems to have corrected itself after pasting into a new drawing. I'm still not sure what was causing this.

Logged
TurboCad Platinum Pro 19,20,21, 2019/REDSDK


* November 25, 2019, 10:48:54 AM
#11
MicheliDE

As John and others have said use the proper "Dynamic" camera tools if viewing in perspective. I associate the zoom tool (Non Dynamic) for use in 2D and Isometric views that are not using perspective camera distortion.

That said, looking at the screen shots and reading your last post with the comment "When I check the perspective box and set the angle to something that looks right the model looks normal again" you are trying to get the perspective to look isometric. Dimensioning the workplane square seems to give me that impression with the values being very close to Isometric (see attached).

This would explain your problem using the Zoom tool as the behaviour in 2D and Isometric views do not suffer from "two steps in equals only one step back".

Hi Darrel,

With Perspective view unchecked the model looks strange to me because in some views it looks trapezoidal in an inversely perspective way . With perspective view checked it looks fine(more normal) to me but I can't use perspective view because turbocad does not have enough steps with the magnifier button (and different steps in and out) and this causes a problem with my method of zooming with the magnifier buttons on my laptop. It is strange how the stepping has changed even though I have changed no other settings between checking and unchecking the perspective view box.

Logged
TurboCad Platinum Pro 19,20,21, 2019/REDSDK


November 25, 2019, 11:16:57 AM
#12
... It is strange how the stepping has changed even though I have changed no other settings between checking and unchecking the perspective view box.

Have you tried changing your Zoom Factor in Advanced Preferences down to something closer to 1?  Such as 1.1 or 1.2... or even closer to the minimum of 1.01  (I use 1.2).  For me, it makes the effect you are describing less so.
« Last Edit: November 25, 2019, 11:33:42 AM by Alvin Gregorio »

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 27, 2019, 05:07:58 AM
#13
... It is strange how the stepping has changed even though I have changed no other settings between checking and unchecking the perspective view box.

Have you tried changing your Zoom Factor in Advanced Preferences down to something closer to 1?  Such as 1.1 or 1.2... or even closer to the minimum of 1.01  (I use 1.2).  For me, it makes the effect you are describing less so.

Hi Alvin,

Yes that helped it also seems to have refined the cursor panning as well just by changing that one setting. I still think it is weird that standard behavior of zoom with magnifier and pan with cursor is not the same between perspective view being checked and unchecked but at least adjusting the zoom factor in advanced settings makes them the same. Thanks for the help.

Logged
TurboCad Platinum Pro 19,20,21, 2019/REDSDK


November 27, 2019, 06:56:38 AM
#14
Have you tried changing your Zoom Factor in Advanced Preferences down to something closer to 1?  Such as 1.1 or 1.2... or even closer to the minimum of 1.01  (I use 1.2).  For me, it makes the effect you are describing less so.

Hi Alvin,

Yes that helped it also seems to have refined the cursor panning as well just by changing that one setting. I still think it is weird that standard behavior of zoom with magnifier and pan with cursor is not the same between perspective view being checked and unchecked but at least adjusting the zoom factor in advanced settings makes them the same. Thanks for the help.

If you have a numerical keyboard on your laptop, have you considered using the + and - keys on the numerical keyboard for zooming.
It seems like with all you have going on with your hands/fingers-- not using a mouse (I don't know how you do it; more patience than me)-- using those keys might be handy for you and worth the effort for you to adopt the new habit.

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)