TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

TC 2019 Platinum Trail
Read 1355 times
* July 11, 2019, 11:40:58 AM
I'm running now for a week TC 2019 Platinum Trail ,and wen I draw more as 30 min. ,TC 2019 start slowing down ,wen I use Select or Plane by Facet.
Tried everything ,restarting but after certain time TC 2019 hangs again.
Had a look  if TC 2019 use more CPU or RAM ,but they are not higher.
Any  idea's what slows TC 2019 down?

Logged


July 11, 2019, 12:23:20 PM
#1
Under the View pull-down menu, select Selection Info; it should open a palette on the right side of your TurboCAD editing window.

Select All and see if the objects you have created are ACIS Solids or something else.  If the latter, then ACIS History is on and each of your parts are being created from a list of everything you've done up to now.  Every time you make a change, TurboCAD is re-creating each object from scratch before placing it on the screen.  That can be time-consuming.

You can select individual objects and use the Format / Explode command to simplify them.

You can also find the ACIS settings under the Options pull-down menu and deactivate ACIS History.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* July 11, 2019, 08:40:41 PM
#2
Jeff, Thank you for your help,have still problems with slowing down,soon when the Tc 2019 Trail run out ,I uninstall TC 2019.
Cheers CADmium

Logged


July 12, 2019, 04:08:53 AM
#3
I just remembered another cause of slowing down.

If you have paper spaces using Quality or Advanced mode renders (or complex objects in Draft mode), every change you make will require that each Viewport be re-calculated & re-rendered.  Select every Viewport, go into Properties (the <Ctrl> F hot key is the easiest way to get there) and change the setting to "Rendering for print only" in the Viewport tab of the popup.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1