TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Will this animate?
Read 4222 times
September 24, 2012, 01:47:25 PM

As a precaution, I have just reinstalled AnimationLab v5 with TC 19.43.2.

So, any ideas why this file will not animate the actor, as shown over the Key Frames 0-17?

Have I missed something?

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.476) 64-bit


* September 24, 2012, 07:07:07 PM
#1
Tim, I got it to animate by enabling the parameter size in the changing parameters dialog of the key frame properties. The stick rotates as it appears to get wider. How did you rotate it?. Did you want the stick to scale larger? Below is an animated gif.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


September 25, 2012, 03:06:27 PM
#2
Hi Dean,

thanks for the reply - I should have been more specific.

Frames 0-17 were animated by moving the trammel, from the start position, a shown in the attachment, to the finishing position that should be shown in the file.  The Key Frame editor appears to record this movement, but, will not animate it.  For instance, using the replay buttons does nothing.  Similarly, when running the scenario.  It appears that the Key Frame editor has not recorded this movement, for whatever reason.

I wondered if you had found the same.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.476) 64-bit


* September 26, 2012, 01:56:58 AM
#3
Hi Tim

The file acts as you descibed, it just seems like it didn't record the start position - don't know why unless the first keyframe was accidentally selected when recording the second keyframe, I just reset the position of the object and re-recorded the start keyframe and it worked ok,

Logged


September 26, 2012, 07:07:29 AM
#4

Thanks for trying Andy.

I cannot get anything to work, with this simple illustration, using this file.  Could you post the one you have found to work and I will do a file comparison.  It might be that there is something amiss with my TC installation, although with what I am currently doing, all appears to be well.  It's a puzzle.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.476) 64-bit


* September 26, 2012, 08:06:27 AM
#5
Tim,  :)did ya try what I said. Enable the “size” parameter in the keyframe properties. It rotates and scales(strange). Something is corrupt with that file. Can’t say what > most likely the way it was created but I wouldn’t waste any time on it, just draw/create another one.Let it go 8)

I don't think the parameters assigned in anilab are stored with the drawing they are saved with the plugin so you have to enable the anilab parameters.The parameters saved in the anilab palette are saved with the drawing.
« Last Edit: September 26, 2012, 08:11:44 AM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


* September 26, 2012, 10:40:24 AM
#6
Dean, - are you using 32 bit or 64 bit ?

Tim, - I've attached the file, but not sure if it will be helpful, there may be some difference with 32 bit and the 64 bit version I'm using hense why I'm asking Dean if he has 32 or 64, the reason I'm wondering this, is that both your original file and latest one are larger than the ones saved on my machine,  if I open your file and use save-as without altering anything, the file goes from 472Kb down to 103Kb.

Sorry I've no idea what setting could be causing that, it needs checking by someone using 32 bit to see if its the program or some other setting.

Andy

Logged


September 26, 2012, 11:46:51 AM
#7
Quote
if I open your file and use save-as without altering anything, the file goes from 472Kb down to 103Kb.

Andy, thanks for file.

Could you possibly save the same file with Compression unchecked and Full Precision checked, and re-attach?

All things being equal, files should open in 32/64-bit.

Thanks.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.476) 64-bit


September 26, 2012, 12:26:54 PM
#8
Tim,  :)did ya try what I said. Enable the “size” parameter in the keyframe properties. It rotates and scales(strange). Something is corrupt with that file. Can’t say what > most likely the way it was created but I wouldn’t waste any time on it, just draw/create another one.Let it go 8)

I don't think the parameters assigned in anilab are stored with the drawing they are saved with the plugin so you have to enable the anilab parameters.The parameters saved in the anilab palette are saved with the drawing.

Dean,

in a roundabout way, you have resolved this problem . . . .  yeeha!  Sorry, I don't usually react this way.  :-[

I read the help files for Animation Lab some years ago, and there was a nagging suspicion in my fuddled brain cell that I should do so again.  After trying your suggestion, something hit me . . . ouch!

Well, what-do-you-know, there it was again - a little gem of information, which saves so many hassles, that it should be imprinted on every animators mind . . . . DO NOT have anything selected under Manipulation, and, running as shown, for other settings, should see you through the worst! in the see below

"Let it go" sorry, I don't understand that phrase!

Many thanks for lighting the fuse of discovery.  ;)

Regards Tim
« Last Edit: September 26, 2012, 12:32:48 PM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.476) 64-bit


* September 26, 2012, 12:38:28 PM
#9
Tim

Glad you got it figured out, and thanks for the 'compression' setting thing, don't think I've looked at that setting for years and completely forgot it existed, I assume you don't need the file posting.

Andy

Logged


September 26, 2012, 12:50:09 PM
#10

"I assume you don't need the file posting" - affirmative.

Andy

Thanks Andy,

I think I should quit while I'm winning . . .

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.476) 64-bit