TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

v19 disappearing viewports (Day 1 of testing v19)
Read 1384 times
* August 17, 2012, 04:49:02 AM
Hello all,

My faithful custom buit laptop which ran v12 Pro has finally died.  It has been replaced with a 64bit off the shelf hp workstation with 8G of RAM.  My v12 Pro would not open multiple files or accept Xrefs on the new machine so I am trialling v19 Pro.

I typically produce 8 to 20 drawings per project and have worked successfully with a single model space and a single paper space (containing all drawings for a project) for years with v12.  My title block is simply drawn in model space and array copied to the paper space.  Everything is 1:1 in the model space.  I run two monitors, one for each space.

The first signs of a problem appeared today when I noticed that zooming in and out with the mouse wheel was VERY laggy in paper space and super smooth in model space.

I later noticed that my title blocks had become distorted in the paper space (they shrunk vertically to about 80% of the original size). When I dragged one title block away, it reappeared with the correct proportion.

Soon after that, the title blocks disappeared from view altogether, but the viewports are still there and everything pdfs perfectly.

The model space looks fine except my north pointer, which is dealt with much like the title blocks, appears as an octagon, rather than a circle in model space, does not appear at all in paper space and prints perfectly to pdf.

It seems like all of these problems are related.  Any clues would be appreciated.
« Last Edit: August 18, 2012, 09:16:59 PM by tcgreg »

Logged
TurboCAD Pro Platinum 2018 64 bit


* August 17, 2012, 04:56:52 AM
#1
Try turning off Redsdk and using GDI instead... and see if that cures your problem. You will find this under Options / Native Draw.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* August 17, 2012, 05:15:01 AM
#2
Thanks Greg,

I will try that now.  I did notice a warning message upon opening the file last ime:

TurboCAD Warning
Aero theme is not supported by TurboCAD while working in REdsdk mode.
If this theme is currently used, it will be tuned off.

Do you want to continue.

Logged
TurboCAD Pro Platinum 2018 64 bit


* August 17, 2012, 05:20:44 AM
#3
Just a white screen now in the TurboCAD window that is switching between doing something and "(Not Responding)"

Logged
TurboCAD Pro Platinum 2018 64 bit


* August 17, 2012, 05:23:40 AM
#4
Post the drawing if you can... might help.

The symptoms you described, I too have had with Redsdk on... but it sounds as though you may have bigger problems than that.

Switching from Redsdk to GDI shouldn't cause any problems.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* August 17, 2012, 05:39:11 AM
#5
OK Thanks Greg that helped.

I don't understand why though as I only have simple 2D line drawings with a few shaded polylines.

I restarted after switching to GDI.  Switching to paper space took a long time as in "I was sure I clicked that tab" and then I heard a whole heap of activity on the HDD.

After that though it zooms significantly better in paper space.

Closed and opened up again and no substantial HDD activity.

Zoom delay is about 1sec.

Need to check permission to post the drawing by could PM it to you.

Many thanks, Greg

Logged
TurboCAD Pro Platinum 2018 64 bit