TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Questions on Using Wall Tool to Butt Different Sized Walls Together
Read 2479 times
* August 05, 2012, 10:50:00 AM

I have begun using the wall tool to build floor plans. I am having difficulty getting the wall to begin and end at a specific location. An example of this is when I have two different wall sizes meet at a 90 degree angle. I find the second wall will attach to the first wall at the center line or opposite edge. I essentially want to butt the second wall to the first wall.  Reading forum posts suggests that there was no way to control this behavior in older version of TurboCAD (e.g. V 16). Is this still the case for version 19?

Thank you for any assistance.


TurboCAD Professional V19 Platinum


TurboCAD Professional V19.1 x64

* August 05, 2012, 01:34:20 PM
Try selecting the two walls you wish to join. Left click on the 1st wall then shift left click on the 2nd wall then go to the wall properties page (under wall) and check “auto clean up” if there is a check mark already in the box make sure it’s black and not gray by un-checking and then checking it, hit ok.

"What do I know, I'm still learning"..
Windows 7 64 bit HP TurboCad Platinum >2020- 2019-2018-2017-21-20-19 and 18.Using only LightWorks (no Redsdk plugin installed), Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,

* August 05, 2012, 01:46:19 PM
I find that turning off "Autocleanup" with give you flat wall ends, but it depends on "Alignment" of the other wall as to whether it protrudes into it or not. I think most people end up turning on Autocleanup and accepting the mitered fit. A big downside of the Wall tool.

One thing that I notice that may work is a 3-Component wall with very thin outer components (drywall); such as the cinder block wall below that has a drywall interior. The adjacent wall doesn't protrude into the whole wall, just a percentage of the outer component.

John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit

* August 05, 2012, 08:14:03 PM
John and Dean,

Thank you for your reply. After experimenting today, I did find some the behavior of the wall tool to be a bit odd. Knowing to turn off the Autocleanup option was key. It worked differently depending on the characteristics of the walls I was joining. (size, components, etc...) It seems (sometimes) to be a bit trial and error. Thank you for that information.



TurboCAD Professional V19.1 x64

* August 06, 2012, 04:40:56 AM
Hello Kate,

an important point to know when using the wall tool is the direction a wall is going. If you try to koin walls that go into different directions or were created using different base lines then you might end up with problems. Going counterclockwise with all walls usually helps a lot.


P.S.: Is "359" in some way connected to 1701? :p


* August 06, 2012, 07:44:31 AM
Hi Michael,

Thank you for reminding me that wall direction does matter and it does affect behavior.  I experimented extensively with walls going every which direction, and I found the best rendering outcome when I draw the walls for a room in a consistent (say, counterclockwise) direction.  Auxiliary walls (like for a closet) had the best rendering outcome when I turned Autocleanup off and drew the wall close to, but not quite touching the adjoining wall. I then snugged the auxiliary wall to the adjoining wall and found the auxiliary wall did not jump to the opposite side of the adjoining wall, thus eliminating the strange miter.

Perhaps I should learn to live with the strange wall tool behavior, and not be too particular on how the wall joins look. That would make TurboCAD life a bit easier

Thank you again for your response.


PS:  HA!!  You are very astute! W359 is the name of the company I work with. The founder got the name from an old Outer Limits episode, and the star featured prominently with 1701.


TurboCAD Professional V19.1 x64

* August 06, 2012, 10:17:25 AM
Hi Kate,

hah, now I get it. I think that´s a real bug or not-so-well-thoughtout feature.

Yes, you are right, it would help a great deal if the base line and the selected settings for the axis would be the same.

I just tried it and I get a very clean joint when I position a wall against another wall with the autocleanup off, no need to position the endpoint a bit away from the other wall. I am sure you already tried to switch the acu off after drawing the walls, which I usually do since I sometimes change my mind about wall materials ;)