TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


TCC lathe giving double X value
Read 10220 times
* December 14, 2011, 07:10:38 AM
I have Turbocam V. 2.5 and I have been trying the Lathe G-Code generator.  The problem I have is that the X value in the G code is double what it should be.  I check the points in the X-Z checker and they are correct.

Is there some setting to stop this?  How can I get good lathe G-Code?

Thanks

Logged


* December 14, 2011, 08:49:41 AM
#1
can you post a copy of the G code in txt. format or copy it and paste in forum thread and the version of Tc your using?Maybe someone can give a better answer.

Logged
Even a mistake may turn out to be the one thing necessary to a worthwhile achievement Henry Ford
If I have ever made any valuable discoveries it has been owing more to patient attention than to any other talent Isaac Newton
I have not failed Ive just found 10,000 ways that won't work Thomas Edison


* December 14, 2011, 09:16:17 AM
#2
I am using TC v. 10.1.  This came with the CAM program when I purchased it.

Logged


* December 14, 2011, 09:19:10 AM
#3
Attached is the TC file.

Logged


* December 14, 2011, 09:25:05 AM
#4
I tried pasting the TC file into this message but it didn't work.

How do you attach files here?

I figured it out.  Attached is the file.
« Last Edit: December 14, 2011, 09:41:53 AM by Toolmaker »

Logged


* December 14, 2011, 09:31:16 AM
#5
Click on Additional Options under neath the message box.


EDIT:If your filepath is correct there should be a copy in of Gcode in the g-code programs folder in Tc cad program folder
« Last Edit: December 14, 2011, 09:40:29 AM by wd »

Logged
Even a mistake may turn out to be the one thing necessary to a worthwhile achievement Henry Ford
If I have ever made any valuable discoveries it has been owing more to patient attention than to any other talent Isaac Newton
I have not failed Ive just found 10,000 ways that won't work Thomas Edison


December 14, 2011, 09:43:13 AM
#6
I have Turbocam V. 2.5 and I have been trying the Lathe G-Code generator.  The problem I have is that the X value in the G code is double what it should be.  I check the points in the X-Z checker and they are correct.

Is there some setting to stop this?  How can I get good lathe G-Code?

Thanks

Does this always happen or is this your first attempt? If the value is exactly double, then I think you may have something setup incorrectly in your machine setup. I am not familiar with the lathe portion of the CNC module, but I will look into it to see if I can be of help.

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||


* December 14, 2011, 10:02:32 AM
#7
It always happens.  I have tried a number of lathe functions and it occurs all the time.  The Z axis is good.

I have used the TCC mill functions and they work good.

Attached is a G code file.
« Last Edit: December 14, 2011, 10:10:51 AM by Toolmaker »

Logged


December 14, 2011, 10:57:28 AM
#8
are the X values in the file double or is your machine controller multiplying the input it is recieving?

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||


* December 14, 2011, 12:10:12 PM
#9
The X values in the G-code written by the TCC program is double what it should be.

It's as if it were printing the diameter rather than the radius.

Logged


December 16, 2011, 09:44:20 PM
#10
you know , I came across a post at cnczone.com from someone having the exact same problem, but there had not been a solution posted.

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||


* December 17, 2011, 01:26:14 PM
#11
I looked on the CNCzone and couldn't find an answer. 
I thought I had found the answer.  In the machine setup you can set the Y reference point to the edge of the part.

I did that and the G-code looked better it was referencing everything to the edge of the part.

The step in was set to .03 per step.  I even checked the cutter path step down on the screen and it was .03.  I didn't check the step down in the G code.  It stepped down .087 per path and when I ran it, it cut right through the side of the wooden bowel.

Everything looks fine on the simulation but the G-code is not coming out correctly.
After I cut it I checked the G-Code and it was .087 step.


Logged


December 18, 2011, 09:43:39 PM
#12
toolmaker
i'm not the cnc person in our outfit but i do know there is
an emergency stop switch on the cnc table to prevent that kind of thing
sorry about your bowl
i'd fix that problem and test with scrap material before starting in again
happy holidays

Logged
Turbocad Deluxe 16


December 20, 2011, 06:24:10 AM
#13
Click on Additional Options under neath the message box.


EDIT:If your filepath is correct there should be a copy in of Gcode in the g-code programs folder in Tc cad program folder

WD, have you run into a situation like this before? Do you think you could post your lathe post processor so it could be compared to what toolmaker is using?

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||


December 20, 2011, 06:28:30 AM
#14
toolmaker, are you using Mach3 controller? If so it would have been supplied with LazyCAM. You may could try that & see what you get

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||


* December 20, 2011, 03:59:49 PM
#15
The controler program I am using is MAXNC.  I don't have a program to check the g-code before I run it.

I have been playing with the TCC program all day and it still gives me double the X number from what it should be.

I have been changing the reference points for the drawing and the cnc.

NO LUCK.

Logged


December 20, 2011, 11:03:23 PM
#16
toolmaker
KCAM & Mach3 both have a trial version
don't know how much time it would take
to get to same point where you're at
with KCAM & Mach3
see if problem is between Turbocad CAM & MaxNC
Happy Holidays

Logged
Turbocad Deluxe 16


December 21, 2011, 05:41:06 AM
#17
The controler program I am using is MAXNC.  I don't have a program to check the g-code before I run it.

I have been playing with the TCC program all day and it still gives me double the X number from what it should be.

I have been changing the reference points for the drawing and the cnc.

NO LUCK.

Here is a trial of a really good simulator, CutViewer, from GRZ Software, the makers of MeshCAM
http://www.grzsoftware.com/cutviewer.php

Another, http://www.cncsimulator.com/
« Last Edit: December 21, 2011, 05:44:01 AM by kmartin »

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||


December 21, 2011, 09:32:09 AM
#18
On all the CNC lathes I have set up the X is in Dia.

Logged


December 21, 2011, 01:09:06 PM
#19
can you attache Turbocad .TCW drawing please?
what 10.1 version turbocad product are you using
Designer, Deluxe or Pro?
happy holidays

Logged
Turbocad Deluxe 16


* December 23, 2011, 09:22:23 AM
#20
I have never programmed a CNC lathe before.  I need to look at this again perhaps the G-code output is correct if it is the diameter of the part.

The controller I am using is for a CNC milling machine.  I was running it on the X and Z axis.

The controller on a CNC lathe could be looking for a Diameter on the X.

Thanks for the other information on the G-code readers.

Logged


* December 23, 2011, 04:23:45 PM
#21
I cut my first program from TCC that worked.  I changed the setup on the X axis of the MAXNC controller so that it steps half of the G-code output. 

It worked!

The problem was with my MaxNC controller not the TCC G-code.

Attached is a picture of the sample I just cut.

Thanks everyone for your Help.

Logged


December 23, 2011, 05:09:08 PM
#22
good for you. Merry Christmas.

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||