TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Dimensioning Circles in Paper Space
Read 4405 times
* June 30, 2009, 09:54:55 AM
I'm having troubles dimensioning circles (well, actually through holes) created in TC 16 Deluxe.  I built a solid, and subtracted a cylinder which gives me a TC surface.  Because the surface is not a true circle anymore, I added a circle to the top so I could find its center (with snaps for later building) and to hopefully dimension it. 
However, in paper space, neither the diameter dimension nor the radius dimension will pick up the circle.  Any suggestions?

[attachment deleted by admin]

Logged
Cameron Blair


* June 30, 2009, 10:19:37 AM
#1
Do you have any Snaps running? To get a Diameter/Radius Dimension, use "No Snap". TurboCAD selects the Circle and reads its properties to generate a dimension.

John R.

« Last Edit: June 30, 2009, 10:24:36 AM by John R »

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* June 30, 2009, 10:27:04 AM
#2
No Snaps doesn't seems to help.  It seems it can't find the circle in paper space and beeps when you try to click on it.

Logged
Cameron Blair


* June 30, 2009, 11:07:58 AM
#3
Your best bet is to zoom in to where you can see the circle and then try the No Snap. I find that when I'm at "Zoom Extents", clicking just outside the hole works, but you'll get better results if you can see and select the circle.

John R.


Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* June 30, 2009, 11:09:09 AM
#4
No Snaps doesn't seems to help.  It seems it can't find the circle in paper space and beeps when you try to click on it.

Works for me in your drawing. Have you tried to zoom in close?

Henry H

Logged


* June 30, 2009, 11:20:44 AM
#5
No Snaps doesn't seems to help.  It seems it can't find the circle in paper space and beeps when you try to click on it.

Works for me in your drawing. Have you tried to zoom in close?

Henry H

Even zooming in close does nothing.  Very odd that you can get it to work.

Logged
Cameron Blair


* June 30, 2009, 11:57:20 AM
#6
Even zooming in close does nothing.  Very odd that you can get it to work.

I finally got a chance to do this in Deluxe and I believe it's a Workplane problem. I couldn't dimension it either.

Go back to Modelspace, select the two circles, then use "Plane by World" in the PopUp menu, then "Format / Place on Workplane". Return to Paperspace and see if you can dimension the circles now.

John R.


Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* June 30, 2009, 12:08:12 PM
#7
I finally got a chance to do this in Deluxe and I believe it's a Workplane problem. I couldn't dimension it either.

Go back to Modelspace, select the two circles, then use "Plane by World" in the PopUp menu, then "Format / Place on Workplane". Return to Paperspace and see if you can dimension the circles now.

John R.



That works.
If you don't mind, could you explain what you think was happening and what happened when I did that.  From my understanding, do you think the circles weren't exactly on the same plane as the top surface or do they have to be on the world plane to dimension in paper space?  Just trying to grasp how to correct this problem if it comes up again.  What if I wanted to dimension a hole that wasn't going through the world plane?  Do I just have to make sure the circles are on the plane that the view looks into?

Logged
Cameron Blair


* June 30, 2009, 01:09:10 PM
#8
Since I couldn't dimension it Paperspace, I decided to try dimensioning in Modelspace. That's when I saw that the dimension came out upside-down. Once it was righted, then it worked.

I really can't say for sure as I've haven't experimented with this problem until now. I tried a Cube with extruded circles, subtracted. Some were on the World Plane and others on the Front plane. I couldn't dimension the circles on the Front plane viewport. I tried the same scenario in V16 Pro and I could dimension the holes in the Front view viewport. I'd like to think that this is a BUG, but it might also be As Designed, since this is Deluxe.

Submit a Ticket at IMSI Support. They could tell you whether it's a BUG or not.

John R.


Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* June 30, 2009, 03:58:15 PM
#9
See movie about why your dimensions are backwards.
I'm in agreement with John and think that the dims should work in paper space but for reason are not.
I should also mention that this would be a great use case for utilizing the drafting palette available in Platinum and the Mechanical Editions.

For more on workplane I did also create a basic movie here.

http://forums.turbocad.com/index.php/topic,451.msg2608.html#msg2608

[attachment deleted by admin]
« Last Edit: June 30, 2009, 05:11:57 PM by Dave Taylor »

Logged


* July 01, 2009, 05:01:10 AM
#10
Sent the question over to support to see what they say.  Thanks for your help everyone.

I guess there are ways to get around this problem, as I've found multiple ways to get around the Deluxe version's little quirks.  I could draw a circle in PS from the center of the circle I wanted to dimension and snap it's quad, and then just change the Dimension Scale to correspond with the viewport scale and then turn off that layer in the vieport.

We'll see if this Deluxe version will work out since I'm basically just playing around with it for my boss to see if its worth it to upgrade.

Logged
Cameron Blair