TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Display Problem tied to Layers
Read 1576 times
June 14, 2009, 05:21:10 PM
In the attached TC15Pro file, I have a problem with the display of the transformer model on Layer 3FS-5.  During its creation, some components were on Layer 0. 

Now that I have moved all the components to Layer 3FS-5, I cannot see the material in Draft or Quality mode if I turn the display of Layer 0 off.

When I first started creating this file to upload (by deleting the other layers), turning off Layer 0 would make components on Layer 3FS-5 disappear.  Usually, selecting and Exploding once would fix that problem, but not this time.

Two questions: How do I fix this problem without redrawing all the components?  Has this problem been fixed in V16?


Jeff


[attachment deleted by admin]

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* June 14, 2009, 09:43:02 PM
#1
One thing that is recommended is to never turn off Layer_0. All the Lights are on Layer_0, so turning off that layer, turns off the Lights and the objects turn black. It doesn't happen all the time in your drawing. If Layer_0 is already off, it will render, but turning Layer_0 on/off, it now renders black.

I also found that the pins within two Groups are on Layer_0, while the Groups are on Layer 3FS-5. I'm not sure if that makes a difference or not. No need to Explode the Group, just expand it (Selection Info) and select one of the ACIS Solid sub-listing. Layer_0 needs to ON to see the properties.

One way around this is to create a Lights layer, make all the lights visible, move them to this Lights layer, then make them invisible again. Now you can turn off Layer_0 without affecting the lights, but you may run into other problems while working with Layer_0 turned off.

John R.

« Last Edit: June 14, 2009, 09:46:08 PM by John R »

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


June 14, 2009, 10:23:20 PM
#2
That explains what I saw in the uploaded file, so it is not really a bug, then.

However, it does not explain why objects are tied to multiple layers so that turning either layer off causes the object to disappear until the object is exploded once, at which time its display is controlled only by one layer.

I just noticed that, when I select Lofting, Layer 0 becomes the work layer, regardless of which layer was in effect when I invoked the function.

However, if I re-select the desired work layer, I can continue working on that layer, so the automatic switch to Layer 0 seems to be a bug which exacerbate (if not outright causes) the problem described in the second paragraph.

Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1