TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

extruded circle appears as a polygon!
Read 656 times
December 06, 2019, 09:23:32 AM
This topic appears all over the help material but I cannot find where or how to use he faceter slider or the acis,(what ever that is... Hope someone can help a returning newbie.

Thanks, best wishes, JimB

Logged
Using TurboCAD 2019 Deluxe 64 bit since Dec 2019

Best is the enemy of good enough

Barrs Law Of Recursive Futility

If you are smart enough to use one of these...
   ,,, you can probably manage without one!


* December 06, 2019, 09:38:49 AM
#1
What Version/Edition are you using? Your signature says Version 16 Deluxe, but in another topic you mentioned moving to TurboCAD 2019. Was that 2019 Platinum or Deluxe? Platinum has ACIS. Deluxe does not; it uses facets when extruding circles/arcs (usually 14 segments, but can go up to 90).

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


December 06, 2019, 11:18:21 AM
#2
Thanks John R
I am using 2019 Deluxe 54 bit
I notice my message has a signature indicating I started using TCad in 2010, TRUE, but I stopped at the end of a project designing Telescope mountings after about a year or so, I returned on 22 Dec this year. I have forgotten 90% or more!

Re the polygon extrusion from circle... Is there a solution for this in the Deluxe implementation? 

Thanks again, JimB

Logged
Using TurboCAD 2019 Deluxe 64 bit since Dec 2019

Best is the enemy of good enough

Barrs Law Of Recursive Futility

If you are smart enough to use one of these...
   ,,, you can probably manage without one!


December 06, 2019, 12:34:15 PM
#3
Thanks John R
I am using 2019 Deluxe 54 bit
I notice my message has a signature indicating I started using TCad in 2010, TRUE, but I stopped at the end of a project designing Telescope mountings after about a year or so, I returned on 22 Dec this year. I have forgotten 90% or more!

Re the polygon extrusion from circle... Is there a solution for this in the Deluxe implementation? 

Thanks again, JimB

Hi JimB,

welcome back. 
I think you're a bit ahead of us on this JimB.
I know it's a bit of a sauce, but could you wait until we ketchup with you?   ;D

Sorry, I couldn't resist. 

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro (1909) 64-bit


* December 06, 2019, 12:46:02 PM
#4
Thanks John R
I am using 2019 Deluxe 54 bit
I notice my message has a signature indicating I started using TCad in 2010, TRUE, but I stopped at the end of a project designing Telescope mountings after about a year or so, I returned on 22 Dec this year. I have forgotten 90% or more!

Re the polygon extrusion from circle... Is there a solution for this in the Deluxe implementation? 

Thanks again, JimB

Double-click the extrusion to open its Properties page; go to "TC Surface Options"; increase the "Number of approximation lines." Try the "Smooth" option if you wish, but I for one do not like it.

Henry H

Logged


December 06, 2019, 01:09:07 PM
#5
Murray said to set the Approximation Lines and Segments at a multiple of 4.  Something to do with math and quadrants and algorithm and code and stuff.
So I now set mine to 88.  I do so in Deluxe after activating a 3D Tool that will produce a curve(s), but before actually inserting/creating the object. That way it is pre-set for the next use.

We set it in the Properties window; one of the last pages.
Search the Help Documentation for "approximation"; that should lead you to the TC Surface Objects page where this stuff is covered.

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 06, 2019, 02:59:32 PM
#6
I have my TC Surface Options set to 60 for any of the 3D tools. You could use the Polygon tool set to 360 instead of a circle. This will look smooth when extruded and rendered.

I'm assuming you have "RedSDK" enabled in "Options / Native Draw". If you switch to GDI, that can Extrude a Circle without showing "Form Building Edges", but the circular edges are somewhat clunky (depending on the Approximation Lines amount).

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* December 06, 2019, 03:14:04 PM
#7
See A "Tool Vise" in TurboCAD Deluxe 2018, where I used somewhat unconventional methods to smooth out the curves.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


December 06, 2019, 03:41:37 PM
#8
In a Deluxe edition, I would recommend (but I'm not 100% certain this works 100% consistently):

Via the TcExplorer Palette, change the Drawing_Defaults "Number of..."  (three properties) to 88, for future drawings.

In TcExplorer Palette, go to Settings/Built-in(Current)/Drawing_Defaults.  Click on the "Property" heading, to sort that column per alphabetical.  Scroll down to find them. Then change the their "14" Value to 88.  Just click out of each cell to "save" the entry.

You might have to close out of TurboCAD and re-Start it to see the changes take effect.
And you probably will not see the effect if starting a New Drawing from a Template or Opening an existing Drawing.
« Last Edit: December 06, 2019, 09:05:15 PM by Alvin Gregorio »

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


December 06, 2019, 08:45:51 PM
#9
...You could use the Polygon tool set to 360 instead of a circle. This will look smooth when extruded and rendered.
...

The problem I have with this method is:  Though it looks good in Plan View-- or whatever view is the top or bottom of the "cylinder"-- in other views there's 360 lines, in Wireframe and Hidden Line visual styles.

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


December 10, 2019, 05:05:55 AM
#10
Oh dear!! definitely loosing it....
I'm now getting confused by the postbox, Heyho.

Anyway, all your help IS working
I AM creating a texfile of command structures and hint as they arise which may/should reduce my calls for help.

Still confused by use of snaps, not reliable; workplane is also being a battle/
On the enclosed file, the cone on the left was created on the xz plane of a box (I know I could have done it with the base of the cone in the existing work plane, but that would have made the base line invisible,  anyway, I tried to transpose the cone to the workplane and it shoot off to somewhere else.
 This was probably caused by me putting the the box on the worldpane

Sill having trouble defining the workplane

HOW do I put the workplane ON the worldplane

Is there a glossary of commands that shows the command structure showing all parameters etc Like DOS pascal7, Cannot remember the authors but it was the one to use back in the 90's

As I said, I may be replying to the wrong post ,but I reckon you will still throw me a line to crawl up

Best whishes, Jim

Logged
Using TurboCAD 2019 Deluxe 64 bit since Dec 2019

Best is the enemy of good enough

Barrs Law Of Recursive Futility

If you are smart enough to use one of these...
   ,,, you can probably manage without one!


December 10, 2019, 06:30:15 AM
#11
Oh dear!! definitely loosing it....

Best whishes, Jim

Reminder Jim:  Please update your signature, if you are in fact using version 2019 Deluxe edition.

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 10, 2019, 09:46:31 AM
#12
"HOW do I put the workplane ON the worldplane"

Press Ctrl+Alt+W.

Henry H

Logged


December 10, 2019, 10:52:55 AM
#13
"HOW do I put the workplane ON the worldplane"

Press Ctrl+Alt+W.

Henry H
Thanks Henry, I had it in my notes as Shft-ALT-W ....

Logged
Using TurboCAD 2019 Deluxe 64 bit since Dec 2019

Best is the enemy of good enough

Barrs Law Of Recursive Futility

If you are smart enough to use one of these...
   ,,, you can probably manage without one!