TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Turbocad 2019 Render Problem
Read 1041 times
* September 11, 2019, 08:24:22 AM
Hi All,

This is my current system configurations

Windows 10 64 Bit
Turbocad 2019 Platinum 64-Bit Build 37.4
NVidia P3200 Driver 436.30 Quadro

I'm having some issues with rendering. When I render an object using the standard realistic render Turbocad is using the GPU to render and uses a percentage of processing power to do so and I can rotate the object around without issues. As soon as I stop moving the rendered object and turbocad proceeds to do a finer render it starts using CPU instead of GPU and this is freezing the program until it finishes. The CPU takes much longer and uses much more power than the GPU to render.

In the NVIDIA Control Panel I have assigned turbocad to use the High Performance Video Processor. This did not help. Is there a profile that I could try to fix this problem?

Why is this occurring?


Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 11, 2019, 10:26:21 AM
#1
Also Tried 431.86 found slightly different but overall same problem.

Logged
TurboCad Platinum Pro 19,20,21, 2019


September 11, 2019, 12:39:25 PM
#2
The allocation of CPU/GPU depends on the rendering mode you have chosen.  Quality is more likely (almost always, in my experience) to use the CPU while Advanced is more likely to use the GPU.

If you are using RedSDK, you can get more GPU rendering.  Also, when moving/rotating/etc., the display will always use Draft mode until you stop, then it will re-render.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* September 13, 2019, 06:11:33 AM
#3
I wish I could be using REDSDK. It is not supported for my card with windows 10.

So it turns out that I am having an interaction between the video drivers, the thunder bolt driver and my dock which the two external monitors are connected to. Thunderbolt should be able to push 40GB/s but there is still a slow down. using thunderbolt may also be what is using up CPU rather than GPU when sending information through the port.

There is no longer an external display port connection on modern dell laptops and so we shall see if they can fix this as it seems to be driver problem.

Logged
TurboCad Platinum Pro 19,20,21, 2019


September 13, 2019, 10:59:40 AM
#4
I wish I could be using REDSDK. It is not supported for my card with windows 10.

Redway claims that their drivers work with all video cards from NVidia, ATI and Intel, but omits AMD.

Which GPU are you using?  And how do you know?


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* September 13, 2019, 01:49:59 PM
#5
Ive got a 1 year old Dell laptop and it works ok, there is one small glitch with objects selected and when rotated they dont show any rotation until you finish movement with the mouse.

Can't remember if it was ok before the last Dell update, but rendering is ok.

Has a Nvidia 1050 graphics card and its an Inspiron I15. Maybe try the onboard Intel graphics card and retest 1st. That way you can eliminate the gpu.

Logged
Daz
TCW V21, 2015-2019 PP, Animation Lab V5.2 & Redsdk enabled, LightWorks rendering mostly.


* September 19, 2019, 05:22:00 AM
#6
I wish I could be using REDSDK. It is not supported for my card with windows 10.

Redway claims that their drivers work with all video cards from NVidia, ATI and Intel, but omits AMD.

Which GPU are you using?  And how do you know?


Jeff

Hi Jeff,

It is a P3200 card built into a laptop.

In the NVIDIA driver configuration I see that I can configure by selecting redway for the program. On my previous laptop I had option for REDSDK in turbocad to config the driver. Has this been removed from newer turbocad and is it only managed by the NVIDIA drivers now?

Where would I go to select the Advanced Render option instead of the Quality Render option?

Regards,
Dean

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 19, 2019, 05:23:57 AM
#7
Ive got a 1 year old Dell laptop and it works ok, there is one small glitch with objects selected and when rotated they dont show any rotation until you finish movement with the mouse.

Can't remember if it was ok before the last Dell update, but rendering is ok.

Has a Nvidia 1050 graphics card and its an Inspiron I15. Maybe try the onboard Intel graphics card and retest 1st. That way you can eliminate the gpu.

Hi Darryl,

At the moment Dell is asking me to do a Dell Command Update where the program reinstalls all the drivers in order from a downloaded library. I am going to see if this fixed my issue.

Regards,
Dean

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 19, 2019, 06:09:11 AM
#8
Did you buy the RedSDK plugin ??

There is a difference between v 21 and v 2019 as now RedSDK is a plugin.
If you have it, have you been to Options/ Native Draw and checked for RedSDK instead of GDI + Flicker free.

Also if you have RedSDK activated, remember to goto Advanced in Native Draw and check basically all the box there.
If RedSDK is active then rigthclick on a "Tea cup" and set it to use RedSDK render, then you can do that for Advanced render aswell, and you can use LW in some renders if you want

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* September 19, 2019, 06:55:29 AM
#9
Did you buy the RedSDK plugin ??

There is a difference between v 21 and v 2019 as now RedSDK is a plugin.
If you have it, have you been to Options/ Native Draw and checked for RedSDK instead of GDI + Flicker free.

Also if you have RedSDK activated, remember to goto Advanced in Native Draw and check basically all the box there.
If RedSDK is active then rigthclick on a "Tea cup" and set it to use RedSDK render, then you can do that for Advanced render aswell, and you can use LW in some renders if you want

Torfinn

Hi Torfinn,

That is very interesting. I do not have REDSDK on my new computer and haven't downloaded the plugin because For my particular graphics card P3200 (Laptop version), and windows 10 64 bits REDWAY 3D says that it is an operating system proprietary graphics driver.

http://www.downloads.redway3d.com/downloads/public/documentation/bk_ba_gpu_chipset_reference.html

And so there is no download and I cannot enable it.

The NVIDIA Control Panel does have the REDWAY 3D setting and I can apply it to be used with turbocad however this does not fix the high CPU usage (and no GPU usage) during the final render. During Moving an object it splits the render between CPU and GPU and it does so fast. Both of these get heavily bogged down by changing windows background.

And so for this reason it appears that I cannot download or configure a fix.

Regards,
Dean

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 19, 2019, 06:58:08 AM
#10
Torfin looks like he is using redsdk see reply #3.
// Edit disregard.

Im not sure about command update, I presume it has a roll back option though.

What about lightworks is it installed?

Try the Integrated graphics card instead, eg: Intel.
« Last Edit: September 19, 2019, 07:01:25 AM by Darryl W »

Logged
Daz
TCW V21, 2015-2019 PP, Animation Lab V5.2 & Redsdk enabled, LightWorks rendering mostly.


* September 19, 2019, 07:32:04 AM
#11
Torfin looks like he is using redsdk see reply #3.
// Edit disregard.

Im not sure about command update, I presume it has a roll back option though.

What about lightworks is it installed?

Try the Integrated graphics card instead, eg: Intel.

Hi Darryl,

Yes lightworks is installed. You would think a new computer could handle it well.

Command update and rollback did not solve my issue this issue has occurred from from Day 1 of new computer.

I tried toggling to Integrated graphics and applied the setting and restarted the program (just in case) With TC allocated to use High performance NVIDIA driver VS Integrated graphics driver the performance and the processing load is exactly the same. It is like the NVIDIA control panel is not doing anything at all to optimize the performance of the video processor for the program.

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 19, 2019, 07:48:53 AM
#12


Hi Torfinn,

That is very interesting. I do not have REDSDK on my new computer and haven't downloaded the plugin because For my particular graphics card P3200 (Laptop version), and windows 10 64 bits REDWAY 3D says that it is an operating system proprietary graphics driver.

http://www.downloads.redway3d.com/downloads/public/documentation/bk_ba_gpu_chipset_reference.html

And so there is no download and I cannot enable it.

The NVIDIA Control Panel does have the REDWAY 3D setting and I can apply it to be used with turbocad however this does not fix the high CPU usage (and no GPU usage) during the final render. During Moving an object it splits the render between CPU and GPU and it does so fast. Both of these get heavily bogged down by changing windows background.

And so for this reason it appears that I cannot download or configure a fix.

Regards,
Dean
[/quote]

There are many sh… card on laptop's, they work good on Office stuff, but not on CAD

I did take a look at the Turbocad site and there are no trial for RedSDK, so i asked support :), they say there is 30 days Money back guarantee on RedSDK Plugin, so maybe talk a bit more with them and then order one for test on your pc ??
But be sure you can get your Money back first, before buy.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* September 19, 2019, 12:35:11 PM
#13
Thanks. I sent redway an email.

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 20, 2019, 05:36:59 AM
#14
so I sent redway an email and they responded with

Dear Mr,

This seem to be a CPU related issue that you have as it occurs during a software image rendering. So the GPU is probably not involved. Please report the issue to TurboCAD as they probably can propose you a way to release a bit of CPU resources during the processing.

Regards,

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 20, 2019, 06:23:44 AM
#15
I have my NVIDIA drivers set to "application controlled" for turbocad. It is strange how turbocad is choosing to use the standard render while I move a rendered the object around as using the GPU while when it does the final render (this could be the light works part of it) it is using the CPU and freezing the program until it fully renders.

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 20, 2019, 08:20:55 AM
#16
As far as i know it have "allways" been like this, in Q render it will turn over to Draft if you move ojects, and then re-render in Q when the Object stand still, that is As Designed
It's not recommended to move stuff when render in Q or A

In RedSDK we have options to force it to use GPU in A render, but dont think there are similar options in LW.
I'm not a render guy :)

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* September 20, 2019, 09:59:24 AM
#17
As far as i know it have "allways" been like this, in Q render it will turn over to Draft if you move ojects, and then re-render in Q when the Object stand still, that is As Designed
It's not recommended to move stuff when render in Q or A

In RedSDK we have options to force it to use GPU in A render, but dont think there are similar options in LW.
I'm not a render guy :)

Torfinn

Hi Torfinn,

I think my old computer did this as well until I tweaked the NVIDIA drivers to stop it from using the highest render settings that the video card has. At the moment with NVIDIA drivers set to applications controlled via the REDWAY profile provided by NVIDIA, turbocad quality renders with CPU and it takes a XEON E-2186M CPU 44 seconds to render an object that is using 2126.0MB of application memory. It goes from 13.4% CPU to 100% CPU during that time and the application is completely locked up during that time.

To me I understand why Turbocad would tell the NVIDIA driver to use the best resolutions possible to quality render however why would it tell the CPU to render it and not the GPU when the GPU can handle huge bandwidths of image rendering.

Also why would it intentionally lock itself up without a prompt to reduce the lag time with the default settings. LOL.


Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 20, 2019, 11:05:15 AM
#18
Hello Dean.  I've been following along, just for learning's sake.  I'm not a techie guy nor a render guy either.

Just for clarification:
Are you willing to accept that TurboCAD is not good at moving the current view while Rendering is taking place or has already taken place?  Particularly so with Quality (and Advanced?) Rendered?
Or is that exactly what you are trying to achieve?


I know I was surprised-- and disappointed-- by this when I first started using CAD-- TurboCAD-- almost 2 decades ago.  I've accepted it as a limitation in TurboCAD's base architecture.  I recently was exposed to and used another 3D program, PoolStudio, that had absolutely no lag when moving around a rendered, real-life-realistic, scene.  I attribute that to the base program architecture being different.
[Disclamer:  I'm not a techie-guy ;) :P]
« Last Edit: September 20, 2019, 11:12:50 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


September 20, 2019, 12:02:55 PM
#19
... why would it tell the CPU to render it and not the GPU when the GPU can handle huge bandwidths of image rendering.

In the Gallery a couple years back, there was experimentation by several people for a scene posted by Majo (Pabellon Barcelona, here: https://forums.turbocad.com/index.php/topic,19148.msg136965.html and another with a race care (I didn't find it in my initial search).

There are significant differences in the results of CPU and GPU renderings.  The 'newishness' of the RedSDK render engine is one excuse; I expect there are others.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* September 23, 2019, 06:04:39 AM
#20
Hello Dean.  I've been following along, just for learning's sake.  I'm not a techie guy nor a render guy either.

Just for clarification:
Are you willing to accept that TurboCAD is not good at moving the current view while Rendering is taking place or has already taken place?  Particularly so with Quality (and Advanced?) Rendered?
Or is that exactly what you are trying to achieve?


I know I was surprised-- and disappointed-- by this when I first started using CAD-- TurboCAD-- almost 2 decades ago.  I've accepted it as a limitation in TurboCAD's base architecture.  I recently was exposed to and used another 3D program, PoolStudio, that had absolutely no lag when moving around a rendered, real-life-realistic, scene.  I attribute that to the base program architecture being different.
[Disclamer:  I'm not a techie-guy ;) :P]

Hi Alvin,

In my case turbocad is find with moving the rendered object and does so with GPU but when I stop moving the object turbocad performs a "final" quality render and freezes for 44 seconds until it finishes rendering for a 2GB file. This isn't a good solution because I frequently render a move rendered objects to examine them. I'd like it not to do the quality render using CPU(Main processor) because the GPU(Video processor) would be so much better and faster at it. Turbocad uses GPU for moving an object but CPU for final render and that is what locks up the program.


Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 23, 2019, 06:22:09 AM
#21
... why would it tell the CPU to render it and not the GPU when the GPU can handle huge bandwidths of image rendering.

In the Gallery a couple years back, there was experimentation by several people for a scene posted by Majo (Pabellon Barcelona, here: https://forums.turbocad.com/index.php/topic,19148.msg136965.html and another with a race care (I didn't find it in my initial search).

There are significant differences in the results of CPU and GPU renderings.  The 'newishness' of the RedSDK render engine is one excuse; I expect there are others.


Jeff

Hi Jeff,

Thanks for the link that is a nice scene. Turbocad can definitely make good renderings but this is not practical during the design portion and so I don't know why the default is the maximum quality and CPU and not GPU used especially when GPU could do the rendering faster. Redsdk is not supported for my video card and so I cannot speed up CPU rendering like I did with my old system. I have a 10 year old system that runs the same speed as the new one because of this problem! LOL.

I'm also not using this for scene rendering. I am using it for making aluminum parts and so an exact shadow representation is not necessary for most things. It makes sense that an architectural user would like the exact shadow and that is the only way to do that however it is impractical during design to to wait so long for a quality render.

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 23, 2019, 08:53:12 AM
#22
Use a "Draft" render mode.

Henry H

Logged


September 23, 2019, 12:03:05 PM
#23
I'm also not using this for scene rendering. I am using it for making aluminum parts and so an exact shadow representation is not necessary for most things. It makes sense that an architectural user would like the exact shadow and that is the only way to do that however it is impractical during design to to wait so long for a quality render.

When I work on metal parts for fabrication, I am almost always using Hidden Line (RedSDK provides fast, smooth depictions), with some occasional Draft renders (also pretty fast).


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* September 24, 2019, 05:14:08 AM
#24
Use a "Draft" render mode.

Henry H

Hi Henry,

Yes draft render works much better for while designing. Thanks.

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 27, 2019, 07:42:37 AM
#25
Another interesting slow down that I have seen in draft mode is when it initially renders in draft mode it takes 15 seconds, and also uses only 15% cpu to do this before releasing the information to the Video Card to move the object.

The result is that everytime I apply a fillet while in draft mode I have to wait 15 seconds in between. My 10 year old computer did not have this lag.

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 27, 2019, 10:50:20 AM
#26
Turbocad is only Hyper Threading for Quality Render and Not Draft Render! Why would it do this?

Logged
TurboCad Platinum Pro 19,20,21, 2019


* September 27, 2019, 02:40:33 PM
#27
Turbocad is only Hyper Threading for Quality Render and Not Draft Render! Why would it do this?

Who knows? It's always been thus.

BTW, there are several "Draft" render choices, some faster than others. Try them all.

Henry H

Logged


* September 27, 2019, 03:46:59 PM
#28
Another interesting slow down that I have seen in draft mode is when it initially renders in draft mode it takes 15 seconds, and also uses only 15% cpu to do this before releasing the information to the Video Card to move the object.

The result is that everytime I apply a fillet while in draft mode I have to wait 15 seconds in between. My 10 year old computer did not have this lag.

See attached video > recorded in version 2019 64 bit with ACIS @ 100 in a perspective view

There's an Advanced render style  (RealTime Shader) It might take you down another rabbit hole  ;D
You get shadows and some reflections.
> The performance depends on your display adapter, meaning it might not work for you using all of its features.
I'm using an 8 year old low end Nivida display adapter and it works ok, kinda fun working with it

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


* September 27, 2019, 07:51:31 PM
#29
Two more tips for faster rendering:

1. In Options>ACIS, set Faceter Quality to 60 or less;

2. Turn off all Lights except for one Headlight and one Ambient light. That will provide plenty of illumination, but you may have to fiddle with their Properties for a while.

Henry H

Logged


* October 01, 2019, 06:34:29 AM
#30
Turbocad is only Hyper Threading for Quality Render and Not Draft Render! Why would it do this?

Who knows? It's always been thus.

BTW, there are several "Draft" render choices, some faster than others. Try them all.

Henry H

Hi Henry,

Of the options on the toolbar button with the coffee cup I see six render options.
What I have been calling draft thus far has been the "create a shaded image of a 3D wire frame". When I try the "regenerate a wire frame with hidden lines suppressed" my computer actually performs worse because after the lines are hidden and I try to move the model the model disappears while I move it. There is also the "create wire image" which now performs better with the redsdk that I recieved from turbocad (however large cursors are not better than ones marked with XYZ on axis). There is also the "create realistically shaded image from 3D wire frame" which is much slower but not as slow as the "create realistically shaded image from 3D wire frame with design style".

Turbocad is checking into if not using more than one CPU core for "draft render" is normal.

Are the other options for draft render located in the render manager? There are a lot of options how do I choose and know which options can be applied to the "create a shaded image of a 3D wireframe" render button?




Logged
TurboCad Platinum Pro 19,20,21, 2019


* October 01, 2019, 06:38:03 AM
#31
Another interesting slow down that I have seen in draft mode is when it initially renders in draft mode it takes 15 seconds, and also uses only 15% cpu to do this before releasing the information to the Video Card to move the object.

The result is that everytime I apply a fillet while in draft mode I have to wait 15 seconds in between. My 10 year old computer did not have this lag.

See attached video > recorded in version 2019 64 bit with ACIS @ 100 in a perspective view

There's an Advanced render style  (RealTime Shader) It might take you down another rabbit hole  ;D
You get shadows and some reflections.
> The performance depends on your display adapter, meaning it might not work for you using all of its features.
I'm using an 8 year old low end Nivida display adapter and it works ok, kinda fun working with it

Hi Dean,

I am finding that my new computer works the same as my 10 year old computer as far as rendering speed. It is kind of troubling that this would be the case because my old computer is very slow.

Logged
TurboCad Platinum Pro 19,20,21, 2019


* October 01, 2019, 06:44:30 AM
#32
Two more tips for faster rendering:

1. In Options>ACIS, set Faceter Quality to 60 or less;

2. Turn off all Lights except for one Headlight and one Ambient light. That will provide plenty of illumination, but you may have to fiddle with their Properties for a while.

Henry H

Hi Henry,

setting the Faceter quality to 60 does improve the speed from 12 to 3 seconds. The trouble with doing that in some designs is that I have to work with threads and some of the time lower faceter generates artifacts.

At least with that setting I can turn all the layers on in my model without serious lag. With all layers turned on I am now at 12 seconds with draft render instead of 12 seconds for one layer.


Logged
TurboCad Platinum Pro 19,20,21, 2019


* October 01, 2019, 10:50:53 AM
#33
Turbocad is only Hyper Threading for Quality Render and Not Draft Render! Why would it do this?

Who knows? It's always been thus.

BTW, there are several "Draft" render choices, some faster than others. Try them all.

Henry H

Hi Henry,

Of the options on the toolbar button with the coffee cup I see six render options.
What I have been calling draft thus far has been the "create a shaded image of a 3D wire frame". When I try the "regenerate a wire frame with hidden lines suppressed" my computer actually performs worse because after the lines are hidden and I try to move the model the model disappears while I move it. There is also the "create wire image" which now performs better with the redsdk that I recieved from turbocad (however large cursors are not better than ones marked with XYZ on axis). There is also the "create realistically shaded image from 3D wire frame" which is much slower but not as slow as the "create realistically shaded image from 3D wire frame with design style".

Turbocad is checking into if not using more than one CPU core for "draft render" is normal.

Are the other options for draft render located in the render manager? There are a lot of options how do I choose and know which options can be applied to the "create a shaded image of a 3D wireframe" render button?

Right-click on one of the coffee cups to open a dialog in which you can see the various render options and apply the one you'd like to use.

Henry H

Logged


* October 01, 2019, 11:06:59 AM
#34
Two more tips for faster rendering:

1. In Options>ACIS, set Faceter Quality to 60 or less;

2. Turn off all Lights except for one Headlight and one Ambient light. That will provide plenty of illumination, but you may have to fiddle with their Properties for a while.

Henry H

Hi Henry,

setting the Faceter quality to 60 does improve the speed from 12 to 3 seconds. The trouble with doing that in some designs is that I have to work with threads and some of the time lower faceter generates artifacts.

At least with that setting I can turn all the layers on in my model without serious lag. With all layers turned on I am now at 12 seconds with draft render instead of 12 seconds for one layer.

Depending upon which TCad version you're running, it may be possible to modify the render quality of one or more selected entities. Right-click after selecting to open the Local Menu, select "Properties," and see if the dialogs shown in the attached screenshot are available.

Henry H

Logged


* October 11, 2019, 08:28:45 AM
#35
Turbocad is only Hyper Threading for Quality Render and Not Draft Render! Why would it do this?

Who knows? It's always been thus.

BTW, there are several "Draft" render choices, some faster than others. Try them all.

Henry H

Hi Henry,

Of the options on the toolbar button with the coffee cup I see six render options.
What I have been calling draft thus far has been the "create a shaded image of a 3D wire frame". When I try the "regenerate a wire frame with hidden lines suppressed" my computer actually performs worse because after the lines are hidden and I try to move the model the model disappears while I move it. There is also the "create wire image" which now performs better with the redsdk that I recieved from turbocad (however large cursors are not better than ones marked with XYZ on axis). There is also the "create realistically shaded image from 3D wire frame" which is much slower but not as slow as the "create realistically shaded image from 3D wire frame with design style".

Turbocad is checking into if not using more than one CPU core for "draft render" is normal.

Are the other options for draft render located in the render manager? There are a lot of options how do I choose and know which options can be applied to the "create a shaded image of a 3D wireframe" render button?

Right-click on one of the coffee cups to open a dialog in which you can see the various render options and apply the one you'd like to use.

Henry H

Hi Henry,

That is interesting it opens a window called camera properties and gives rendering type options to render with Open GL, Lightworks, Or Redsdk (if you have it). That is much simpler then going to the render manager and the orange gear. I have my NVIDIA control software set on "let the application decide" and so this is much easier then tweaking the NVIDIA control ap.

It appears that on my computer draft render speed for the same object is as follows:

Fastest
Redsdk, Redsdk Draft 1.8 seconds
Lightworks Flat 25.88 seconds
Lightworks Smooth Open GL 27.76 seconds
Open GL 39.64 seconds
Slowest

It is really kind of dumb that installing redsdk didn't default the redsdk draft render as the default when it was installed.

This definitely will speed up my design and rendering process and allows me to better assign my rendering default types.

Thanks!

Logged
TurboCad Platinum Pro 19,20,21, 2019