TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


"Invalid Operation. Entity Coordinate System"
Read 2436 times
* August 07, 2019, 02:26:07 PM
Once in awhile I suspect I hit a wrong key or command and won't be able to trim objects anymore. With that problem I get the TC Warning:  "Invalid operation. Entity coordinate system is not the current coordinate system". Have no idea what this means in relation to not being able to trim any objects. Please advise, thanks!

Logged


August 07, 2019, 03:41:52 PM
#1
Ensure that both the Cutting Edge Object and the Object you desire to Trim are on the same WorkPlane.  (I wanted to type "Workplane"; but after experimenting a bit, I found-- in version-20PP-- that they can be on different "Workplanes" [Coordinate Systems], but have to be on the same plane.)

If this is a 2D Drawing:
  • Make all your Layers Visible and Unlocked
  • Select All
  • While all is selected, invoke the "Workplane by World" command
  • While all is still selected, invoke the "Place on Workplane" command

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 21, 2019, 11:40:44 AM
#2
Sorry I am late in thanking Alvin for his help, but it worked fine and has helped with some other similar problems. I'm not sure how some portions of the 2D drawing got on a different workplane. I know I didn't intentionally do it. But TC from time to time has some strange problems associated with it. Thanks again Alvin for your help!!

Logged


* May 05, 2020, 02:57:09 PM
#3
I too would like to thank Gregorio as his suggestion also got me out of a fix. I concur that the TCad seems to have a gremlin that I, like you, have no idea as to what I did to move 2D entities to work planes etc. has happened twice, on different actions.

Thanks again Alvin. Cheers.

Logged


* May 05, 2020, 03:20:31 PM
#4
Most of the times it happens because you are in 3D mode when draw 2D objects, simple as that.
In newer versions of TC there are in selector properties a box to check for Safe ucs mode, that will solve the issue as well.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


May 05, 2020, 05:40:24 PM
#5
I too would like to thank Gregorio as his suggestion also got me out of a fix. I concur that the TCad seems to have a gremlin that I, like you, have no idea as to what I did to move 2D entities to work planes etc. has happened twice, on different actions.

Thanks again Alvin. Cheers.

See this post in the Tips and Tricks board.

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* May 05, 2020, 06:03:03 PM
#6
I too would like to thank Gregorio as his suggestion also got me out of a fix. I concur that the TCad seems to have a gremlin that I, like you, have no idea as to what I did to move 2D entities to work planes etc. has happened twice, on different actions.

Thanks again Alvin. Cheers.

The problem usually occurs with a 2D object that has been moved--even if its Z position has not changed.

Henry H

Logged