TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Facet Locked Material
Read 1170 times
July 24, 2019, 07:17:11 PM
Is anyone having issues with having facet lock materials applied to imported SAT or STEP files such as the attached. This is from McMaster-Carr and If I apply a material it states that there are materials overriding it on the facets. Is this an affect of the new filters for SAT and/or STEP that allowed for the import/export of materials. If this is the case, this is really bad news as one has to release the facet material for every imported part if they want to apply materials in the same manner. Same thing on the bearing that is attached.

I also opened Darryl's hull section to have a look at it. It too came in with all parts having facet locked materials. I have a tried a complete reinstall of build 34.1 twice with the same results.


* July 24, 2019, 07:36:50 PM
#1
I'm having the same problem Don after the last TC update. Fiddle with changing it too much and the file corrupts.

Logged
John Kampen




Win 10 - 2018 Pro Platinum
Win 10 - 2019 Pro Platinum


July 24, 2019, 08:22:00 PM
#2
I'm having the same problem Don after the last TC update. Fiddle with changing it too much and the file corrupts.

Thanks for the confirmation John. I have been selecting 1 facet with the facet editing tool then pressing Ctrl + A to select all facets. Then selecting Set None, from the right mouse click local menu on the materials palette. Material application after that works as it should for me.
« Last Edit: July 26, 2019, 08:39:17 AM by Don Cheke »

Logged


* July 24, 2019, 08:39:32 PM
#3
Ahh now I understand why Im getting errors in V21 not behaving correctly. I saved a 2018pp file back to V21 to fix an acis error and I couldnt get it to release fom draft render. Also maybe  explains errors that Dean & John had with 1 of my files.

Logged
Daz
TCW V21, 2015-2019 PP, Animation Lab V5.2 & Redsdk enabled, LightWorks rendering mostly.


* July 25, 2019, 05:07:22 PM
#4
John Kampen what did you do to corrupt your file?

Logged
Daz
TCW V21, 2015-2019 PP, Animation Lab V5.2 & Redsdk enabled, LightWorks rendering mostly.


* July 25, 2019, 05:21:27 PM
#5
It has always been like this, as far back as I can remember.

A facet material overrides the object material. I mean,  ;D if a material is applied to a sphere via its properties and a material has been applied to the same sphere via the facet edit tool the facet material overrides the object material. There's usually a warning and this is one of many reasons I like to keep ALL warnings active.
Sometimes it's not that easy to remove the facet material. Turbo can run a muck real easy and take you down the material management rabbit hole  ;D
« Last Edit: July 25, 2019, 05:23:53 PM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


July 25, 2019, 06:08:05 PM
#6
It has always been like this, as far back as I can remember.

A facet material overrides the object material. I mean,  ;D if a material is applied to a sphere via its properties and a material has been applied to the same sphere via the facet edit tool the facet material overrides the object material. There's usually a warning and this is one of many reasons I like to keep ALL warnings active.
Sometimes it's not that easy to remove the facet material. Turbo can run a muck real easy and take you down the material management rabbit hole  ;D

I agree with what you are saying about the material override of the facet material, but what is new is specific to this latest version with how SAT and STEP files come in if they have had a material (as color) added to them via the provider. I consider this as a bug, because the programmers specifically changed how the file are dealt with when imported (the ability to have their materials come along).
« Last Edit: July 26, 2019, 08:38:54 AM by Don Cheke »

Logged


* July 26, 2019, 06:57:16 AM
#7
It has always been like this, as far back as I can remember.

A facet material overrides the object material. I mean,  ;D if a material is applied to a sphere via its properties and a material has been applied to the same sphere via the facet edit tool the facet material overrides the object material. There's usually a warning and this is one of many reasons I like to keep ALL warnings active.
Sometimes it's not that easy to remove the facet material. Turbo can run a muck real easy and take you down the material management rabbit hole  ;D

I agree with what you are saying about the material override of the facet material, but what is new is specific to this latest version with how SAT and STEP files come in if they have had a material (as color) added to them via the provider. I consider this as a bug, because the programmers specifically changed how the file are dealt with when imported (the ability to have their materials come along). It is typical - make a change and break it at the same time.

Don, I get what you're saying now and agree, it's different.
I didn't have any problems though working the materials, it's similar to working with Skp files.
Did you try deleting the material from the RM?

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


July 26, 2019, 07:40:00 AM
#8
Did you try deleting the material from the RM?

I didn't try deleting the material in the RM and I will, but that would be an extra step that I wouldn't want to have to do. If it is a new function of the program, there should be an import option to ignore materials, or something like that. Same for SKP if that is how it is now working and there is no such option. I haven't looked at SKP files for a very long time, so don't know what is there.