TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Memory Management
Read 996 times
* July 19, 2019, 01:11:04 AM
Hi,
I have a problem with one TCCad file, it's very slow, for example I want to make cotation of drawing in a paper space, I need to wait some 8 seconds for make an other cote.
Somebody can give me a good configuration of TCCad for solve this problem
Thank

PC Configuration
Nom du système d’exploitation   Microsoft Windows 10 Professionnel
Version   10.0.18362 Numéro 18362
Autre description du système d’exploitation   Non disponible
Fabricant du système d’exploitation   Microsoft Corporation
Ordinateur   PC-ALES2
Fabricant   Micro-Star International Co., Ltd.
Modèle   MS-7A94
Type   PC à base de x64
Référence (SKU) du système   Default string
Processeur   Intel(R) Core(TM) i9-7900X CPU @ 3.30GHz, 3312 MHz, 10 cœur(s), 20 processeur(s) logique(s)
Version du BIOS/Date   American Megatrends Inc. 1.A0, 05/12/2018
Version SMBIOS   2.8
Version du contrôleur embarqué   255.255
Mode BIOS   UEFI
Fabricant de la carte de base   Micro-Star International Co., Ltd.
Produit de la carte de base   X299 RAIDER (MS-7A94)
Version de la carte de base   1.0
Configuration de PCR 7   Liaison impossible
Répertoire Windows   C:\WINDOWS
Répertoire système   C:\WINDOWS\system32
Périphérique de démarrage   \Device\HarddiskVolume2
Option régionale   France
Couche d’abstraction matérielle   Version = "10.0.18362.145"
Mémoire physique (RAM) installée   64,0 Go
Mémoire physique totale   63,7 Go
Mémoire physique disponible   48,4 Go
Mémoire virtuelle totale   73,2 Go
Mémoire virtuelle disponible   54,9 Go
Espace pour le fichier d’échange   9,50 Go
Fichier d’échange   C:\pagefile.sys


Logged


July 19, 2019, 01:44:33 AM
#1
I have a problem with one TCCad file, it's very slow, for example I want to make cotation of drawing in a paper space, I need to wait some 8 seconds for make an other cote.
Somebody can give me a good configuration of TCCad for solve this problem

You do not say which render setting you have for your Paper space; is it Wireframe, Hidden Line, Draft mode, Quality or Advanced?  Which render engine are you using (LightWorks, RedSDK, OpenGL)?

If you have ACIS History active, that will slow rendering as the list of modifications will be performed each time you change the render (with exceptions such as changing the viewpoint).  You can view this by selecting an object while the Selection Info palette is visible.  If each object has two or more objects or operations being performed on it, then use the Explode command to simplify it to an ACIS Solid.  You can turn ACIS History off in the ACIS menu item under the Options drop-down menu.

This next option should only be done on a copy of your file, but you could get faster results if you select all the ACIS Solid objects and Explode them to TC Surfaces.  You will not be able to return to the same Solid model if you have curved facets, which is why you should work with a copy.  I create almost everything in ACIS Solid modelling mode because TurboCAD has the most tools in this section (compared to TC Surface and SMesh).

Some render modes can use the GPU instead of the CPU.  This can speed results, but I have seen it produce slightly different results (little things like the shadow darkness, the apparent texture of a facet, light reflections, etc.).

Finally, you may want to consider simplifying your object.  Speaking from experience, I have placed way too much detail (on the sub-millimeter range) in objects that will be seen from an apparent distance of half a meter.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1