TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Snap/select problem
Read 1522 times
* July 04, 2019, 02:34:48 AM
I can't snap to anything in the attached. I can't select by clicking either. If I use the selection box, I can, but this is no use for drawing. I have restarted the PC, and have tried deleting and restoring the objects.
Any ideas?

Logged


* July 04, 2019, 06:37:34 AM
#1
I tested your file and everytime i try'd to change view it crashed TC, then open i v 2019 and TC Block any viewchange, not possible to zoom extents etc etc.
So back in v 20 and open New drawing, and used Extract from, check on everything and still no joy, then turned on all layers and use a selection window around visible as i believe there is some "spacedust" very far away, ctrl + c, open a New drawing and ctrl + v and now the drawing behave.

If i use ctrl + a in your drawing there was 215 objects, now in new drawing there is 211 objects.
v 2019 give warnings about some circles, so maybe that is the "spacedust", but it was so far away that i dont even get a selectionwindow around it when using ctrl + a in original drawing

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* July 04, 2019, 07:09:43 AM
#2
Thanks Torfinn, I did the same and it's working.  :D

Logged


July 05, 2019, 01:42:54 AM
#3
I tested your file and everytime i try'd to change view it crashed TC, then open i v 2019 and TC Block any viewchange, not possible to zoom extents etc etc.

2019 did not crash when I tried to view, but I could never get Zoom Extents to work, either.


If i use ctrl + a in your drawing there was 215 objects, now in new drawing there is 211 objects.
v 2019 give warnings about some circles, so maybe that is the "spacedust", but it was so far away that i dont even get a selectionwindow around it when using ctrl + a in original drawing

According the the Audit Report for the three circles, they are all at the origin with 0 size.  I made all layers visible, zoomed in and tried selecting.  That did not work.  In the Selection Info panel after Select All, I right clicked on each of the Circles with an Audit Report symbol and chose Delete.  That got rid of them, but I was still unable to Zoom Extents.

Copying and Pasting worked the first time I tried (with an area of approximately ±10000 mm), but the same attempt failed when I went back to the original file and deleted the bad circles before trying to Copy and Paste.

Seems to me that there are some problems with the Audit Report function in 2019.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* July 05, 2019, 04:53:49 AM
#4
The file is a v 20 Jeff
If you open it in v 20, then try to do a SW iso view, maybe you crash also, if that is what you want :))

In v 2019 we have the zoom limit for prevent this kind of stuff to happen, and i just remembered the audit when i wrote the reply, i never open the file again in v 2019 to check it out as the problem was solved, hence the maybe it was this circles and i did not remember how many there was of them eigther ;)

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB