TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Disappearing Paper and Model space tabs
Read 2952 times
* February 21, 2019, 04:46:53 AM
I have found that when I |Window | New window the new window appears somewhere off screen or behind existing windows.

I don't recall that happening in earlier versions.

That is not such a big issue in itself but I am finding that when I then choose |Window |Tile to show all windows, the new windows do not appear to have the model or paper space tabs. When I manipulate the width of the scroll bar I can get the tabs back - well sort of. See attached.

A workaround is to manipulate the tab area until the tabs can be partly seen and then either click on each until the desired tab is displayed or right-click to display a tab menu.

My question is, does anyone else have this problem in TC2018 Pro Platinum?

Logged
TurboCAD Pro Platinum 2018 64 bit


* February 21, 2019, 05:44:56 AM
#1
Hello,

...My question is, does anyone else have this problem in TC2018 Pro Platinum?

No, but in TC2016 ProPlatinum too.

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


* February 21, 2019, 05:58:57 AM
#2
CNR

Tested in 2016 and 2018 PP, metric system
Tile and Cascade

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* February 21, 2019, 05:59:57 AM
#3
CNR in 2018 or 2016 Platinum.

When I use "Window / New Window" on a fully opened drawing window, it opens a copy on top of the current page. If the drawing window is restored down, new windows cascade in front of the original. I don't have a problem with 'tab text' disappearing or being squished.

Video card up to date?

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* February 21, 2019, 12:17:55 PM
#4
Thanks for the fast responses.

Assuming CNR = Could Not Replicate.

I'm looking at driver software now. I have an AMD FirePro W4300 card and 2 LG monitors.

Logged
TurboCAD Pro Platinum 2018 64 bit


* February 21, 2019, 12:37:43 PM
#5
Graphics drivers were out of date! Sorry for the rookie error on my part. I had assumed that the cards were now sophisticated enough to self update.

(Updated from v24.20.13026.0 to v25.20.15016.9)

Thanks John R and others. I CNR after the update.

Logged
TurboCAD Pro Platinum 2018 64 bit


* February 21, 2019, 12:42:45 PM
#6
Good to hear that it's up-n-running, properly. ;)

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* February 21, 2019, 01:02:38 PM
#7
After updating the drivers I noticed two things

1. My hot keys no longer work
2. All files now open on a grey screen requiring the user to zoom before the drawing appears (I did also occasionally notice that before the update)

I will assume these are unrelated to the original problem so will search the forum before starting new posts for each.

Reloading my workspace seemed to have solved 1. nicely (thanks John R from 2013)

re: …If it happens I have to repair my program with the disk.

Instead of doing a Repair Install, just go to "Tools / Customize—›Options" page and click on the "Default" button to reload the workspace (toolbars, menus, hotkeys, palettes) to factory defaults. If you have a custom Workspace, reload that instead.

For 2. I Had nothing selected at |Tools|Options|Load at Startup.
Ticked "Last window layout", exited with saving
Re opened the file
Set up a couple of windows, saved the multi view layout
Unticked Load at startup as above
Now get model space when opening files - all seems pretty normal now.
« Last Edit: February 21, 2019, 01:34:29 PM by tcgreg »

Logged
TurboCAD Pro Platinum 2018 64 bit


* February 21, 2019, 01:19:49 PM
#8
If hotkeys aren't working, reload the configuration that you use at "Tools / Customize—›Options" page. Select the configuration from the "Load From" list, then click on the "Load From" button. If you don't have a particular configuration, click on the "Default" button. This should bring back the hotkeys.

Do you mean the drawing Background is grey or the whole User Inerface?

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* February 21, 2019, 02:43:50 PM
#9
Hi John
I solved it already and just edited the previous post since we are getting off topic now, so you may have missed that. FYI the background was grey which is not my default colour so not sure what was happening there but I posted what I did with the initial view settings and it seems to have stopped now. Will repost here is it emerges again.

Logged
TurboCAD Pro Platinum 2018 64 bit


February 22, 2019, 01:11:38 AM
#10
After updating the drivers I noticed two things

1. My hot keys no longer work

I read that this problem was fixed, but for other people looking for a solution where that fix didn't work, it is good to know that another possible cause is the Function Lock key (on my keyboard, it is to the right of F12).  Accidentally pressing that will cause the same problem.  Again, on my keyboard, it is easy to check that the Function Lock key is active because there is an LED next to the Numeric Keypad, Caps Lock and Screen Lock LEDs.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* March 12, 2019, 03:51:38 AM
#11
Actually, the hotkey problem persisted as did the zoom issue to some extent.

Now seem to have rectified that by clearing out the built-in folder as recommended in https://forums.turbocad.com/index.php/topic,9797.0.html

Thanks again to all contributors.


Logged
TurboCAD Pro Platinum 2018 64 bit


* March 15, 2019, 05:08:19 PM
#12
Hi again,

Just updating the original post:

I have found that when I |Window | New window the new window appears somewhere off screen or behind existing windows.

I don't recall that happening in earlier versions.

That is not such a big issue in itself but I am finding that when I then choose |Window |Tile to show all windows, the new windows do not appear to have the model or paper space tabs. When I manipulate the width of the scroll bar I can get the tabs back - well sort of. See attached.

A workaround is to manipulate the tab area until the tabs can be partly seen and then either click on each until the desired tab is displayed or right-click to display a tab menu.

My question is, does anyone else have this problem in TC2018 Pro Platinum?

The problem is persisting!

I can workaround and it does not seem that this is a problem for anyone else, so my plan is to wait for a TC upgrade / patch or graphics drivers update and then take things from there.

Logged
TurboCAD Pro Platinum 2018 64 bit


* May 08, 2019, 05:56:14 AM
#13
Exactly the same issue with 2019 platinum version, did you ever find a solution?

Logged


* May 08, 2019, 06:39:33 AM
#14
Ein Mitglied im deutschen Forum hat folgendes geschrieben:
Ich habe herausgefunden, daß die verschwundenen Tabs
doch nicht verschwunden sind.
(Model/Papier)
Sie werden unten nur überdeckt!
Wenn man mit dem Mauszeiger unten an die Zeichenflächen-
begrenzung fährt, erscheint ein Doppelstrich mit Pfeil
nach oben und unten.
Hier, wenn man klickt, hält und den Mauszeiger nach unten
bewegt,erscheinen dann in minimaler Größe die vermißten Tabs!
Bin ich auch nur durch Zufall darauf gekommen....

A member of the german forum wrote the following:
I found out that the missing tabs
but have not disappeared.
(Model / paper)
They are only covered below!
If you move the mouse pointer down to the drawing area
Limitation drives, a double line with arrow appears
up and down.
Here, if you click, stops and the mouse pointer down
moves, then appear in minimal size the missing tabs!
Am I just come by chance ....


Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


* May 11, 2019, 01:51:34 PM
#15
Exactly the same issue with 2019 platinum version, did you ever find a solution?

I don't have 2019, Nor do I have a solution.  But I can replicate the problem in TC 2018, though not in TC 2017 (which works ok.).  Also it requires a specific set of circumstances to reproduce.

In my case it is linked to viewport fixed scale. If I ……

Select new from scratch (My default is metric).  Draw a line.  Create a viewport.  Switch to Paper space.  Insert viewport.   Right click viewport and choose properties. Set viewport fixed scale to say 1:4 (which is non-standard for metric). Save the file.   Close the file. Open the file, Model and Paper tabs are unavailable.   Basically the Model / Paper space tabs are drawn on a separate line to the scroll bar making them inaccessible. (turning off scroll bar doesn't work).

Once this happens the only way I can bring the tabs back is to close and reopen TC.  (Re-loading config doesn't work)

Strangely If I change the viewport fixed scale using the section palette instead of right click / properties, the problem does not occur. weird eh.

If you can reproduce the above exactly in 2019, I'd suggest reporting it to IMSI support.

   


Logged


May 15, 2019, 12:33:26 PM
#16
I also have this issue, using TC PRo 2018 :(
It happens to me  when i open a new image while having a current image loaded.

Logged
Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620
But still slow :(


* August 11, 2019, 02:05:02 PM
#17
Thanks John for this answer - helped me in Turbo Cad Pro Platinum 21 when my hotkeys stopped working!

Logged
Michael Campbell
TurboCad Pro Platinum v15.2, 21.2, 2019, Windows 10 Pro 64, AMD Ryzen 1600X, 16Gb  ram, AMD Firepro W4100 graphics


* October 25, 2019, 09:24:49 PM
#18
Just an update for maule1409 and others.  I’m still having the disappearing tabs problem.

Logged
TurboCAD Pro Platinum 2018 64 bit


* October 29, 2019, 04:47:02 AM
#19
Exactly the same issue with 2019 platinum version, did you ever find a solution?

I don't have 2019, Nor do I have a solution.  But I can replicate the problem in TC 2018, though not in TC 2017 (which works ok.).  Also it requires a specific set of circumstances to reproduce.

In my case it is linked to viewport fixed scale. If I ……

Select new from scratch (My default is metric).  Draw a line.  Create a viewport.  Switch to Paper space.  Insert viewport.   Right click viewport and choose properties. Set viewport fixed scale to say 1:4 (which is non-standard for metric). Save the file.   Close the file. Open the file, Model and Paper tabs are unavailable.   Basically the Model / Paper space tabs are drawn on a separate line to the scroll bar making them inaccessible. (turning off scroll bar doesn't work).

Once this happens the only way I can bring the tabs back is to close and reopen TC.  (Re-loading config doesn't work)

Strangely If I change the viewport fixed scale using the section palette instead of right click / properties, the problem does not occur. weird eh.

If you can reproduce the above exactly in 2019, I'd suggest reporting it to IMSI support.

   

I'm on TurboCAD 2018 Pro Platinum and this has caused the bug every time for me. There are other things that cause it, but I haven't been able to narrow it down to anything specific. I have this problem several times a day even though I rarely work with viewports.

Strangely, my boss is using the exact same version of TurboCAD on his computer with the same .tcw files and has never seen this issue. He is using Windows 7 and I am on Windows 8.1 though. Also, when I save and reopen a file after editing a viewport's fixed scale, the problem occurs, but if I restart TurboCAD and reopen the same file, I don't have the issue.

I used 2016 before this and several other older versions, but 2018 is the first I have seen this problem. I did open a support ticket as well.

Logged


* October 29, 2019, 05:25:22 AM
#20
You could try go to Tools/ Customize/ Options and increase the UI scale a bit and see if that help.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


October 29, 2019, 05:40:55 AM
#21
...
I'm on TurboCAD 2018 Pro Platinum and this has caused the bug every time for me. There are other things that cause it, but I haven't been able to narrow it down to anything specific. I have this problem several times a day even though I rarely work with viewports.

Strangely, my boss is using the exact same version of TurboCAD on his computer with the same .tcw files and has never seen this issue. He is using Windows 7 and I am on Windows 8.1 though. Also, when I save and reopen a file after editing a viewport's fixed scale, the problem occurs, but if I restart TurboCAD and reopen the same file, I don't have the issue.

I used 2016 before this and several other older versions, but 2018 is the first I have seen this problem. I did open a support ticket as well.

Have you tried setting the TurboCAD 2018 PP program executable file to run in a Compatibility Mode-- to Windows 7.
On my installation, the path to that executable file for my version-20 is C:\Program Files\IMSIDesign\TCWP20\Program\tcw20.exe.

Or my go-to suggestion:  Turn Windows' User Account Control setting all the way down-- essentially Off-- then re-start your computer.  If your company and it's IT person are okay with that.

Just a couple of things I'd try, if it were me.
« Last Edit: October 29, 2019, 07:38:31 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* October 29, 2019, 08:29:26 AM
#22
...
I'm on TurboCAD 2018 Pro Platinum and this has caused the bug every time for me. There are other things that cause it, but I haven't been able to narrow it down to anything specific. I have this problem several times a day even though I rarely work with viewports.

Strangely, my boss is using the exact same version of TurboCAD on his computer with the same .tcw files and has never seen this issue. He is using Windows 7 and I am on Windows 8.1 though. Also, when I save and reopen a file after editing a viewport's fixed scale, the problem occurs, but if I restart TurboCAD and reopen the same file, I don't have the issue.

I used 2016 before this and several other older versions, but 2018 is the first I have seen this problem. I did open a support ticket as well.

Have you tried setting the TurboCAD 2018 PP program executable file to run in a Compatibility Mode-- to Windows 7.
On my installation, the path to that executable file for my version-20 is C:\Program Files\IMSIDesign\TCWP20\Program\tcw20.exe.

Or my go-to suggestion:  Turn Windows' User Account Control setting all the way down-- essentially Off-- then re-start your computer.  If your company and it's IT person are okay with that.

Just a couple of things I'd try, if it were me.

I did try setting the compatibility mode to Windows 7 yesterday and it didn't work. I also have UAC turned off completely.

Exactly the same issue with 2019 platinum version, did you ever find a solution?

I tried to recreate this in the 2019 trial version and it seems to be fixed for me.

Logged


* October 29, 2019, 09:40:52 AM
#23
The first quick fix in v2019 when this issue came up was to increase the UI scale a bit.
Assume they fixed it, so when you install 2019 trial you got the fixed files in to your machine and that fixed the issue in v 2018 aswell.
If you get it back in v 2018, check the other persons pc and look at/ compare the icon size.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* October 29, 2019, 01:26:44 PM
#24
The first quick fix in v2019 when this issue came up was to increase the UI scale a bit.
Assume they fixed it, so when you install 2019 trial you got the fixed files in to your machine and that fixed the issue in v 2018 aswell.
If you get it back in v 2018, check the other persons pc and look at/ compare the icon size.

Torfinn

Still having the problem in 2018. I think we have the same icon sizes set, but I tried changing mine and it did not fix the problem.

Logged


* October 29, 2019, 05:28:14 PM
#25
The first quick fix in v2019 when this issue came up was to increase the UI scale a bit.
Assume they fixed it, so when you install 2019 trial you got the fixed files in to your machine and that fixed the issue in v 2018 aswell.
If you get it back in v 2018, check the other persons pc and look at/ compare the icon size.

Torfinn

Still having the problem in 2018. I think we have the same icon sizes set, but I tried changing mine and it did not fix the problem.

I'm using 2018 and having the same problem as you. I can fix the problem by saving my work, closing Turbocad and then re-opening. It gets to be a PITA after a while.
Don

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


* October 29, 2019, 05:56:36 PM
#26
I read Andy H's comment at # 15 in this tread, and can reproduce it that way, and then reastart TC after that to bring it back to normal.
Maybe you use the viewports property to make adjustment on it, i always use Selection Info palette and dont have the problem.

Torfinn

Edit;  Just remember :), in v 2018 we also can change inside Design Director, above Layer we have Space, there we can chose between Model and the different Spaces there are in the drawing, cumbersome but still better than restart TC/ drawing.
« Last Edit: October 29, 2019, 06:09:47 PM by Torfinn »

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* October 29, 2019, 08:04:47 PM
#27
I read Andy H's comment at # 15 in this tread, and can reproduce it that way, and then reastart TC after that to bring it back to normal.
Maybe you use the viewports property to make adjustment on it, i always use Selection Info palette and dont have the problem.

Torfinn

Edit;  Just remember :), in v 2018 we also can change inside Design Director, above Layer we have Space, there we can chose between Model and the different Spaces there are in the drawing, cumbersome but still better than restart TC/ drawing.

It would be a lot less cumbersome if it actually just worked. I don't if all CAD programs are the same, but with Turbocad you only seem to get 95% +- of what you pay for.

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


* October 29, 2019, 09:49:31 PM
#28
If you think about the option for switch between different P space's an M Space, it do work here, also the Selection Info Palette instead of the Property menu.
It was a bug that first turns up when test v 2019 beta if i remember correct, so it is somehow connected with v 2019 i believe, but agree, it should have been sorted out and fixed in an update of 2018.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* October 30, 2019, 05:28:33 AM
#29
I read Andy H's comment at # 15 in this tread, and can reproduce it that way, and then reastart TC after that to bring it back to normal.
Maybe you use the viewports property to make adjustment on it, i always use Selection Info palette and dont have the problem.

Torfinn

Edit;  Just remember :), in v 2018 we also can change inside Design Director, above Layer we have Space, there we can chose between Model and the different Spaces there are in the drawing, cumbersome but still better than restart TC/ drawing.

I know there are other things that cause this problem for me because I rarely use viewports. I haven't figure out what else specifically causes it but it might have to do with changing other settings through the properties box.

Logged


* October 30, 2019, 07:57:18 AM
#30
Try to use basically the Selection Info Palette's property (under the dot'ed line), sooner or later i assume you get to the correct place that affect your TC, if you cant figure out what menu you have been in to.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB