TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Little help with hatching
Read 1444 times
July 03, 2017, 08:24:02 AM
Hello,
I'm having an issue, unable to hatch desired area. I'm attaching tcw file as well as pic of desired hatching.

It is maybe because some of the polylines are not closed. If that is the case (and I'm unable to find that), is there any quick way to see if the given area/line structure is closed (other than manual search with zooming etc.)?

Thanks.

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* July 03, 2017, 09:22:48 AM
#1
In cases like this where an obvious error is not visible and Pick Point Hatching is not working, I would select the necessary objects and use the Create Hatch tool.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit


* July 03, 2017, 10:05:14 AM
#2
I did the same as John say, i made new layer and put inside everything that should not be hatched and close it.
Then i Hatch the top and next the bottom part with Create Hatch tool (Ctrl+Shift+H)
And then turn on the other layer.

The Pick Point Hatch could not work as it was a whole bunch of line/ arc's etc that was not connected.
If the profile was 1 polyline you could check if it is closed by selecting it with the Edit tool, if you got the option to close it down on the inspector bar, choose that and i guess the Pick Hatch would work.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* July 03, 2017, 11:14:08 AM
#3
What I did (using pick-point hatch)
« Last Edit: July 03, 2017, 11:16:02 AM by Andy H »

Logged


July 03, 2017, 12:03:32 PM
#4
Thank you all for great comments and suggestions. Very useful indeed.

As a novice user, I'm using lines and arcs as a measurement points to construct the drawing. As suggested, the Pick Point Hatch didn't work because I've had snapping errors (line not snapped to half-circle), and lines that I didn't remove after construction of the object - which is obviously a bad practice which I'll have in mind in future.

« Last Edit: July 03, 2017, 12:05:12 PM by tarmiricmi »

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB