TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

2017 Smesh extrude face crash
Read 2115 times
* April 17, 2017, 11:06:36 AM
I've got a repeatable Smesh crash when using extrude face (on the inspection bar - not the one on the Smesh toolbar), it crashes when the selector icon is set to 'on', doesn't crash when selector is off, + other variations can cause the extrude to work ok.

My repeatable steps are outlined in the attached, anyone else get the same results.   crash report has been sent.

Windows10, 64bit, intel I7, 16 Gig ram, GTX 660,  TC2017 Platinum 64,


Logged


* April 17, 2017, 01:14:00 PM
#1
It Works her if i make sure that "Along Faces Normal" is OF
But the Selctormode go off automatic here before the Extrude Face turn up
English system, Default config

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* April 18, 2017, 07:19:52 AM
#2

But the Selctormode go off automatic here before the Extrude Face turn up

Torfinn

Thanks for looking at this.

In previous versions the selector needed to be off for the additional icons to show up,  for me in 2017 it can be on,  I'm guessing it was altered when they introduced the delete and copy face buttons, what I've noticed is that,  for me, when buttons / icons don't show up one has to either make the change (select a button / icon on the inspection bar), before selecting the object,  or sometimes if they are not available after selecting an object, then de-select the object and reselect normally allows them to show.

That said I have no idea if the above way of working is intentional or an error just on my computer, I'm using TC 2017 build 26.3  (don't know if your using a later build).
« Last Edit: April 18, 2017, 08:19:26 AM by Andy H »

Logged


* April 18, 2017, 08:57:26 AM
#3
Yes, i have an different build, so it can be that, i never use this tool normally, so i have no ide'a about how it work earlier, i just tested this issue.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* April 18, 2017, 09:47:19 AM
#4

But the Selctormode go off automatic here before the Extrude Face turn up

Torfinn

Thanks for looking at this.

In previous versions the selector needed to be off for the additional icons to show up,  for me in 2017 it can be on,  I'm guessing it was altered when they introduced the delete and copy face buttons, what I've noticed is that,  for me, when buttons / icons don't show up one has to either make the change (select a button / icon on the inspection bar), before selecting the object,  or sometimes if they are not available after selecting an object, then de-select the object and reselect normally allows them to show.

That said I have no idea if the above way of working is intentional or an error just on my computer, I'm using TC 2017 build 26.3  (don't know if your using a later build).

Instant UE for me, Andy.
Also, the icons not showing up is "Quirky"
Sometime they appear in selector mode.
I get so many crashes with the Smesh tool, I have given up on using it a while ago.

I would contact Majo  ;D

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


* April 18, 2017, 09:51:40 AM
#5
Thanks reporting to development now.


Logged


April 18, 2017, 10:24:47 AM
#6
Here is the Error Report Dave

Edit: I am using this way for the Extrude Face SMesh: Menu->Modify->Modify 3D objects->Surface Mesh->Extrude Face (please, see the gif file in the attachment)
« Last Edit: April 18, 2017, 01:46:51 PM by Majo »

Logged
WorkPC->HP Z620 2x E5-2680v2 2,8GHz, 64GB RAM,Quadro K4000, 400GB SSD+2TB HDD, Win10 Pro 64bit
HomePC->i7-3770 CPU 3,40GHz, 16GB RAM, GeForce GTX 760, 120+60GB SSD, Win7 HP 64bit

TC Pro Plat x64
www.invent-dizajn.sk, www.facebook.com/marian.jurcak


* April 18, 2017, 10:43:48 AM
#7
And to correct myself, as i see today it was sort of wrong written.

The selectormode dont go on/ off automatic, it is the Extrude Face + Tools that go on/ off automatic, depending if the Selectormode is on or off, (for me that looks normal), and not like i see in Andy's pic, all was visible.
Dang, why do we not all speak/ write Norwegian :):)

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* April 18, 2017, 01:16:29 PM
#8
Thanks everyone for looking into this,  and thanks for the reply Dave, nice to know it will get sorted,

Logged


April 20, 2017, 05:14:14 AM
#9
I've got a repeatable Smesh crash when using extrude face (on the inspection bar - not the one on the Smesh toolbar), it crashes when the selector icon is set to 'on', doesn't crash when selector is off, + other variations can cause the extrude to work ok.

My repeatable steps are outlined in the attached, anyone else get the same results.   crash report has been sent.

Windows10, 64bit, intel I7, 16 Gig ram, GTX 660,  TC2017 Platinum 64,

Hi Andy,
Thank you so much for reporting this Bug.
We successfully reproduced the bug and assigned for development.  We will update you ASAP.
« Last Edit: April 20, 2017, 05:38:14 AM by Zunair Attif »

Logged
Thanks & Regards,
Zunair Attif
Manager QA\Support
IMSI Design
Email: zattif@imsidesign.com
Skype: zattif@imsitechnologies.com


April 20, 2017, 05:28:53 AM
#10
Thanks reporting to development now.

HI Dave,

Issue has been fixed now by development team and problem arose because the SMESH tools were available in edit tool when selector mode was on.
« Last Edit: April 20, 2017, 05:38:48 AM by Zunair Attif »

Logged
Thanks & Regards,
Zunair Attif
Manager QA\Support
IMSI Design
Email: zattif@imsidesign.com
Skype: zattif@imsitechnologies.com