TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Camera Properties - Turbocad 20.2
Read 8443 times
February 05, 2015, 09:31:45 PM
Good day All,
When i "hidden line" render my model that includes Jpeg images, those Jpeg images are visible from all sides .
I know there is a way of adjusting the camera settings.
Would someone mind telling me how.
Kindest thanks
« Last Edit: February 06, 2015, 10:38:10 AM by Up »

Logged


* February 06, 2015, 05:26:19 AM
#1
Good day All,
When i "hidden line" render my model that includes Jpeg images, those Jpeg images are visible from all sides .
I know there is a way of adjusting the camera settings.
Would someone mind telling me how.
Kindest thanks

Uncheck Non Renderable Objects.

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


February 06, 2015, 10:05:41 AM
#2
kindest thanks DonCW

I'm still doing something wrong.
I Unchecked Nonrenderable objects - still the same.
Did try a few combinations under Foreground Wireframe. 

Logged


February 06, 2015, 10:11:13 AM
#3
You might have to get really creative-- very resourceful.

If you do, attached is one workaround idea.  Note that there are 2 Viewports in Paperspace.

~Alvin

[Edit (2/6/15; 11:15 PST): Whoops, I forgot to Embed the Image (the Cam Lobe) that I used.  I embedded it, and swapped out the .tcw file.  I also attached that Image file, in case the embedment gets messed up.)
« Last Edit: February 06, 2015, 10:37:24 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


February 06, 2015, 10:27:26 AM
#4
What you're looking for Bill??? John is what many have asked for many times on these Forums:

In Hidden Line Render, you do not want NonRenderable Objects (typically, 2D Objects) to show when they should be blocked out by the 3D Objects in the Hidden Line Render.  Just like in the real world.

The only practical way that has been resolved is by using RedSDK as your Native Draw; use RedSDK Hidden Line Render, with Foreground Wireframe set to display NonRenderable Objects; and-- this is the key-- in Options/RedSDK, set the Hidden Line transparency setting to 0.

Works well, except:  The problem in your case is that it does not work with Images, I do not believe.  Though, I'd appreciate being corrected on this.

~Alvin
« Last Edit: February 06, 2015, 10:37:33 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


February 06, 2015, 10:35:31 AM
#5
Please see my edit (2/6/15; 11:15pst) in Reply #4, at the end.  ~Alvin
« Last Edit: February 06, 2015, 10:37:42 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


February 06, 2015, 10:43:00 AM
#6
thank you Alvin. Much appreciated.
I am going to try and use RedSDK as Native Draw

I wonder if these niggly bits have been sorted out in Version 21.
Will report back later.

Logged


* February 06, 2015, 11:09:43 AM
#7
kindest thanks DonCW

I'm still doing something wrong.
I Unchecked Nonrenderable objects - still the same.
Did try a few combinations under Foreground Wireframe.

If Possible, post the drawing.

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


February 06, 2015, 11:38:47 AM
#8
ok i did the switch into RedSDK.
If i use RedSDK as Native Draw then my wire frame looks quite different - very busy, i could not use it like that.
I'm not putting in my setting correctly. somewhere.
Still cannot see the JPEG images when i use "Suppress Hidden Line" even with RedSDK.
Attached is the TCT file - it should have the images included in the Zip
« Last Edit: February 06, 2015, 11:43:55 AM by Up »

Logged


February 06, 2015, 11:42:41 AM
#9
ok i did the switch into RedSDK.
If i use RedSDK as Native Draw then my wire frame looks quite different - very busy, i could not use it like that.
I'm not putting in my setting correctly. somewhere.
Still cannot see the JPEG images when i use "Suppress Hidden Line" even with RedSDK.
Attached is the TCT file - it should have the images included in the Zip

Doesn't surprise me.  As I said, I don't think this method (RedSDK; Hidden Line transparency= 0) works with Images.  I think the Images just don't display.  Their boundaries do, and display (or, more correctly, do not display) as we'd hope, but not the Images themselves.  I'm pretty sure...

For all those extraneous lines displaying in Wireframe/RedSDK, go to Options/ACIS, and ENable "Degenerative Faceting".

But, if this isn't resolving your original issue John-- and I don't believe it will-- I'd just switch back to GDI Native Draw and find a suitable workaround.
« Last Edit: February 06, 2015, 11:50:54 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


February 06, 2015, 11:49:35 AM
#10
kindest thanks Alvin, greatly appreciated.
Thing is i could do it good befor.
That was to use the "Suppress Hidden Lines" tool before and my JPEGS would appear smart and all in the correct spots.

I think that was when i used TurboCAD V18

Logged


February 06, 2015, 11:56:41 AM
#11
kindest thanks Alvin, greatly appreciated.
Thing is i could do it good befor.
That was to use the "Suppress Hidden Lines" tool before and my JPEGS would appear smart and all in the correct spots.

I think that was when i used TurboCAD V18

I don't know what to say John.  I'm not an expert-guy, so I don't know...  It's always behaved this way (the way you're not wanting it to) for me in version-11&before, version-19,20,21Pro(Trials), and my current version-19-Deluxe.
But, like I say... I'm no expert-guy.

I've never read or seen a sample on these Forums of anyone being able to successfully do what you are trying to do.  Though, I could be mistaken, forgetting, or just plain missed a post.

~Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


February 06, 2015, 12:08:54 PM
#12
ok i did the switch into RedSDK.
If i use RedSDK as Native Draw then my wire frame looks quite different - very busy, i could not use it like that.
I'm not putting in my setting correctly. somewhere.
Still cannot see the JPEG images when i use "Suppress Hidden Line" even with RedSDK.
Attached is the TCT file - it should have the images included in the Zip

By the way John,

In your screen-captures, showing the Render properties, you have Hidden Line Type/Mode set to Hidden Line/Hidden Line.

If you want the effect that I am describing (by setting RedSDK's Hidden Line transparency to 0), you have to set that Hidden Line Type and Mode to the RedSDK options.  But it still won't aid with your main issue here... getting the Images to display correctly... I don't believe.
« Last Edit: February 06, 2015, 12:11:39 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 06, 2015, 01:33:20 PM
#13
ok i did the switch into RedSDK.
If i use RedSDK as Native Draw then my wire frame looks quite different - very busy, i could not use it like that.
I'm not putting in my setting correctly. somewhere.
Still cannot see the JPEG images when i use "Suppress Hidden Line" even with RedSDK.
Attached is the TCT file - it should have the images included in the Zip

The images didn't arrive with the file, John.

Did you know that you can assign a Material to an image, and it will then render like a 3D object? Create a generic Material with Pattern = "Wrapped Image "(you can leave the "File name" window blank); Reflectance = "Constant"; all the other parameters = "None." Apply this same Material to any and all images in a drawing.

UNcheck "Nonrenderable objects" and render in Smooth OpenGL or a Quality mode.

Henry H
« Last Edit: February 06, 2015, 01:35:49 PM by Henry Hubich »

Logged


February 06, 2015, 01:38:32 PM
#14
...
The images didn't arrive with the file, John.

Did you know that you can assign a Material to an image, and it will then render like a 3D object? Create a generic Material with Pattern = "Wrapped Image "(you can leave the "File name" window blank); Reflectance = "Constant"; all the other parameters = "None." Apply this same Material to any and all images in a drawing.

UNcheck "Nonrenderable objects" and render in Smooth OpenGL or a Quality mode.

Henry H

Hidden Line Render?

_____
That's a very useful tip Henry.  One you've mentioned many times.  Problem is, since it's not something we use every day, remembering it.  Or even remembering how to recall or Search for it.
« Last Edit: February 06, 2015, 01:43:14 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 06, 2015, 01:45:16 PM
#15
...
The images didn't arrive with the file, John.

Did you know that you can assign a Material to an image, and it will then render like a 3D object? Create a generic Material with Pattern = "Wrapped Image "(you can leave the "File name" window blank); Reflectance = "Constant"; all the other parameters = "None." Apply this same Material to any and all images in a drawing.

UNcheck "Nonrenderable objects" and render in Smooth OpenGL or a Quality mode.

Henry H

Hidden Line?

In Hidden Line with "Nonrenderable objects" UNchecked, the images don't appear at all. With "Nonrenderable objects" checked, the images are visible right through any objects that might lie above them.

...BTW, I'm not really sure what result John is looking for.

Henry H

Logged


February 06, 2015, 01:57:14 PM
#16
...

...BTW, I'm not really sure what result John is looking for.

Henry H

In the original post, and throughout our discussion, John has been mentioning that he wanted Hidden Line Render.

It'd be cool if you could solve this Henry.  Any chance of utilizing your method somehow in conjunction with Native Draw= RedSDK | Options/RedSDK Hidden Line transparency= 0 | Hidden Line Render Mode/Type= RedSDK | Foreground Wireframe= Nonrenderable objects?? ?
« Last Edit: February 06, 2015, 02:01:50 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


February 06, 2015, 07:19:42 PM
#17
thank you very much.
I have attached those missing images.

When i use Native Draw GDI and check "Nonrenderable" objects in the Camera Properties then i get the desired results EXCEPT the Jpeg is visible from the rear of the cabinet. Not what i want.

Logged


* February 06, 2015, 07:44:27 PM
#18
thank you very much.
I have attached those missing images.

When i use Native Draw GDI and check "Nonrenderable" objects in the Camera Properties then i get the desired results EXCEPT the Jpeg is visible from the rear of the cabinet. Not what i want.

Still not sure what effect you're trying for, John. Here's my latest guess...

Henry H

Logged


February 06, 2015, 11:23:01 PM
#19
thank you for your patience Henry, much appreciated. 

In my Hidden Line rendering the image is visible through the solid geometry.
In the attached image one can see the 4 jpegs in the front and also the 4 jpegs at the back, meaning that in this image it is possible to see through the Hidden Line render.
Very sorry i am not sure if i am explaining this properly.
Items that should not be visible are visible ..

Logged


* February 07, 2015, 01:17:44 AM
#20
Put the different picture/ side to different Category or Grafic in Design Director, then you can turn them on/ off just like you want for the different view's

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


February 07, 2015, 07:43:35 AM
#21
Put the different picture/ side to different Category or Grafic in Design Director, then you can turn them on/ off just like you want for the different view's

Torfinn

The reason I suggested using Layers to accomplish this, rather than Graphics or Categories, is so that one could have different Views in the same Paperspace.

I've run into this in my own work.

Although, this is when using Viewports; if a Pro-user were using the Drafting Palette, it would be a different scenario and perhaps a different recommendation.

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 07, 2015, 07:45:27 AM
#22
thank you for your patience Henry, much appreciated. 

In my Hidden Line rendering the image is visible through the solid geometry.
In the attached image one can see the 4 jpegs in the front and also the 4 jpegs at the back, meaning that in this image it is possible to see through the Hidden Line render.
Very sorry i am not sure if i am explaining this properly.
Items that should not be visible are visible ..

In the most recent image I posted, John, the image is not visible through the "Hidden line render," but it is visible in the rest of the rendering. Is this not the effect you're trying to achieve?

Henry H

Logged


February 07, 2015, 07:51:27 AM
#23
...

Still not sure what effect you're trying for, John. Here's my latest guess...

Henry H



Yes.  How did you do it Henry?

If you think it'd be quicker for communicating how you did it (to me) could you post it in V19? (saving Proxy objects)

Thanks, Alvin
« Last Edit: February 07, 2015, 08:43:37 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 07, 2015, 08:01:01 AM
#24
One way is to apply a plain white color with a “constant’ reflectance and render a quality raytrace full.
Have fun placing the images or clip them.
Turn Redstuff off
Renderable objects and suppress hidden line checked.
You can also change the material and pen color.
« Last Edit: February 07, 2015, 08:26:44 AM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


February 07, 2015, 08:15:19 AM
#25
thank you Alvin , thank you Henry,
with a bit of fiddling around i have managed to hide the offending images that appear from behind the render.
( i removed the Jpegs at the back of the cabinet )
see attachment.
Thank you so much.

 

Logged


February 07, 2015, 08:35:43 AM
#26
thank you Dean that will work yes, however i cannot use white.
attached is image of the cabinets from the front and those same cabinets from the back.
notice the images are visible from the back. They should not be visible thru a render.
I use Jpegs in my modeling.

kind regards

Logged


* February 07, 2015, 08:44:52 AM
#27
One way is to apply a plain white color with a “constant’ reflectance and render a quality raytrace full.
Have fun placing the images or clip them.
Turn Redstuff off
Renderable objects and suppress hidden line checked.
You can also change the material and pen color.

That's how I did it. Object's material is "Constant" Reflectance, black, and its Pen color is white. Background is black, so the object is invisible except for its white edges. Image has a Material assignment.

Henry H

Logged


February 07, 2015, 08:51:12 AM
#28
thank you very much Henry. I am going to work at that now.

Logged


February 07, 2015, 09:50:32 AM
#29
Thanks Dean and Henry!  That was some good stuff to learn.  I just hope I can remember it when the time comes that I need it.

Attached is my doing of it.  I incorporated Henry's method of making the Images renderable, as well as their instruction on making the 3D Object's Material a "Plain" Color, with a "Constant" Reflectance.

One thing to note:  For me, to get consistent satisfactory results, I had to "bump out" the Images a smidge... so that they didn't share the same surface as the 3D Objects.   I used 1/1024".

~Alvin
« Last Edit: February 07, 2015, 02:52:55 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


February 08, 2015, 03:58:47 AM
#30
This was a team effort, thank you so much everyone for your wonderful help.
There are 4 Jpegs in this model.
Please notice the bright light at the top. That is Henry's formula.
The light was originally yellow and i change it to turquoise.

Many thanks

Logged