TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Changing materials
Read 1905 times
February 05, 2015, 10:30:41 AM
I've drawn a 3 D Part and assigned a material. Now I want to change the material but I keep getting this message:
"Material of the graphic(s) "Shingles\Shingles1" will be ignored in render, because it is overriden by materials of graphic faces. To make this material visible you could remove materials from faces."

I've searched but cannot identify how to remove the material from the faces. Am I to select them one at a time and then delete the material?
Any help will be appreciated.

Bill

Logged


* February 05, 2015, 11:09:16 AM
#1
If you're working in a Pro version: Select the object. If the Selection Info palette identifies it as a "Part," explode it one time to delete its Part Tree history; otherwise do NOT explode it. Deselect the object. Open the Materials palette. Enable the Facet Edit tool; click anyplace on the object; press Ctrl+A. (This selects all the facets on the object.) Right-click in the Materials palette and choose "Set 'None'." Click in the drawing someplace distant from the object to deselect the facets. Double-click the object to open its Properties dialog, go to the Material page, and set "None" for the Material (doesn't matter what Category happens to be showing). You have now removed all material(s) from the object and can proceed to assign whatever new material(s) you wish.

If you're working in a Deluxe version: There's no way to remove materials from faces. Your only recourse is to make a new part.

Henry H

Logged


February 05, 2015, 11:49:42 AM
#2
Henry,

I have 21 PRO.

You're the greatest! Thank You.

Bill

Logged


February 05, 2015, 01:13:27 PM
#3
One way to prevent this from happening in the first place:

In Options/Preferences..., un-check the option "Transfer material from operand".  Pro has that-- right?

Transferring the material from the operand (subtrahend) is what causes what you experienced Bill.
With this option checked, when doing a 3D Subtract, with Materials already assigned to the Objects in the operation, the face(es) that the subtrahend intersects with the minuend will take on the Material of the subtrahend.

Some time ago, I was surprised and enlightened to read Henry write that assigning Materials was one of the last steps he does in modeling.  Not the last step, but nearer the end then I originally imagined.

_____
"Thank You" to Andy H. for making me aware of this option in Options/Preferences, a few months ago.  ~Alvin
« Last Edit: February 05, 2015, 05:53:34 PM by Alvin Gregorio »

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)