TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

World Pen Thickness
Read 3436 times
* January 26, 2015, 04:52:42 AM
I am on Turbocad V19.2 Pro Platinum, and am trying to set the pen thickness by layer and have been having a few problems. I am using pen by world and geometry checked but then changed it to try and get it to use bylayer, is it possible ??.

I have edited the pen widths in turbocad explorer and added 0.13mm, 0.18mm, 0.25mm, 0.35mm, 0.5mm, 0.7mm and 1mm widths so they are available in the layer width boxes but they do not appear to stick, even quite out of the drawing and started a new drawing.

Anyone care to walk me through the steps required!.

Logged


January 26, 2015, 09:21:50 AM
#1
...
I have edited the pen widths in turbocad explorer and added 0.13mm, 0.18mm, 0.25mm, 0.35mm, 0.5mm, 0.7mm and 1mm widths so they are available in the layer width boxes but they do not appear to stick, even quite out of the drawing and started a new drawing.
...

Hi Michael.  I've created and used custom Pen Widths, assigned via TcExlporer Palette, for quite some time now.  And most Pen Properties Width value is set to "By Layer".  Should work for you.

Have you tried closing out of and re-starting TurboCAD? I'm pretty sure that's what you have to do.  [Edit:  Just tried it.  Was successful in getting the new settings to stick just by opening a new drawing.  So I don't know...]

~Alvin
« Last Edit: January 26, 2015, 09:27:37 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


January 26, 2015, 09:31:50 AM
#2
If you're still having this issue Michael, can you show us a screen-capture of your TcExplorer Palette, like mine below.

Thanks, Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 26, 2015, 01:29:31 PM
#3
Alvin, I had read a few post on the forum that suggested closing down after changing the settings and then starting a new drawing, are the settings drawing specific or do they apply to all new drawings. I only changes the millimeter units, do you have to change them all, inches etc.

Logged


January 26, 2015, 03:07:49 PM
#4
Alvin, I had read a few post on the forum that suggested closing down after changing the settings and then starting a new drawing, are the settings drawing specific or do they apply to all new drawings. I only changes the millimeter units, do you have to change them all, inches etc.

No, you don't have to change all the Space Unit types, Michael.

The settings apply to all new drawings.  The settings are universal, as they are assigned in the TcExplorer Palette Settings/Built-in(Current), and change the .ini file in your "Profiles/Built-in" folder (which of the two .ini files, I always forget; I think it's the one with the "xml" in it.). 

Maybe closing TurboCAD and re-Starting will work for your particular version.
Or maybe someone else knows if there is an issue with your particular version/build.

____
Can you share a screen-capture image of your TcExplorer Palette/Built-in(Current)/PenWidths, as I showed in my previous post, Michael.

~Alvin
« Last Edit: January 26, 2015, 03:55:31 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 26, 2015, 03:35:02 PM
#5
On my laptop at the moment Alvin, but will be back on my main desktop which I use Turbocad on in the next hour or so and will post my TC Explorer settings then.

Many Thanks for your assistance!.

Logged


* January 27, 2015, 03:11:26 PM
#6
Sorry for not getting back in touch Alvin, I have now managed to set the pen widths so that they can be used, but have found some inherent problems with having a width, namely that there are multiple snapping points at the end of the lines, so will still use world and geometry but will set a 0 line thickness and will sort the thickness out with print styles.

Many thanks for your assistance!.

Logged


January 27, 2015, 03:23:43 PM
#7
Sorry for not getting back in touch Alvin, I have now managed to set the pen widths so that they can be used, but have found some inherent problems with having a width, namely that there are multiple snapping points at the end of the lines, so will still use world and geometry but will set a 0 line thickness and will sort the thickness out with print styles.

Many thanks for your assistance!.

You're Welcome Michael.

Yeah, I don't care much for the "Geometry" option.  I use it, but seldom.  Maybe 1% of my Objects.  It does have its functional uses, though.

Glad to read you have it handled Michael.  ~Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


January 27, 2015, 04:29:20 PM
#8
Sorry for not getting back in touch Alvin, I have now managed to set the pen widths so that they can be used, but have found some inherent problems with having a width, namely that there are multiple snapping points at the end of the lines, so will still use world and geometry but will set a 0 line thickness and will sort the thickness out with print styles.

Many thanks for your assistance!.

After further thought Michael:  I don't know that using the "Geometry" option with a Pen Width Value of 0 will have the desired outcome.
From what I can tell, the "Geometry" option doesn't effect, using Print Styles, when a Pen Width Value of 0 is used.

It'd be interesting to read what it is you are trying to achieve-- "Geometry" option.
Don't feel compelled to take the time or energy to share that, if you don't feel like it Michael.

~Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 28, 2015, 02:05:29 AM
#9
Alvin, the only reason that I want that option is for the square corners, most of my engineering work these days is for artwork prints but the corners have a radius which is not what I am after.

Logged


January 28, 2015, 06:12:47 AM
#10
Alvin, the only reason that I want that option is for the square corners, most of my engineering work these days is for artwork prints but the corners have a radius which is not what I am after.

Yes, that is the rub of it, isn't it.  We want those square corners, but dang it, we often don't want vertices that we accidentally snap to.

Gotcha

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)