TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Self Intersecting Sweeps
Read 6243 times
* May 20, 2009, 08:22:43 PM
It seems that any time you do a sweep along an inside curve you get a self intersecting error -- unless you select rigid.

Is there any way to avoid this?

Problem -- need non-rigid sweep along sigmoid ("S") curve. ???

-- Here is a sample file. I created for this and comes up with a second error. Try to sweep the yellow along the black. Says
1) It does not intersect the profile path -- looks to me like it does.
2) Self intersecting

[attachment deleted by admin]
« Last Edit: May 20, 2009, 08:45:55 PM by bigjimslade »

Logged


May 20, 2009, 10:57:45 PM
#1
I took a look at your file. It looks like it should self-intersect but a closer inspection reveals that the curve is far from smooth and so the sweep probably does self-intersect. I replaced your curve with a smooth one and performed the sweep with no problems.

In the attachment, the red curve is mine.

[attachment deleted by admin]

Logged
Hardware: 2.67GHz Core I7-920, 18GB 1333 DDR3, Nvidia Gforce GT 220
OS: 64 Bit Windows 10 Home
Software: TC 2018.25.0.41.0 (64)
Setup: UI: Classic, Editing History: Off, Use Choice: Off, Native Draw: GDI


* May 22, 2009, 10:09:49 PM
#2
The curve here is generated by TC itself from an insert intersection.

Logged


* May 25, 2009, 07:31:03 PM
#3
Enable the curve frame and look for reverse curvature, where the frame crosses the curve, which causes the selfintersection.  The pic shows the inversions, the red curve has had some control points deleted, causing some small changes in profile.  It will sweep.

[attachment deleted by admin]
« Last Edit: May 25, 2009, 08:25:18 PM by murray dickinson »

Logged


* May 25, 2009, 10:23:31 PM
#4
Enable the curve frame and look for reverse curvature, where the frame crosses the curve, which causes the selfintersection.  The pic shows the inversions, the red curve has had some control points deleted, causing some small changes in profile.  It will sweep.

Beautiful obsevation.

John R.


Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* May 31, 2009, 09:43:35 AM
#5
Interesting in that the curve in question was created using INSERT->INTERSECTION.

Logged


* June 11, 2009, 04:51:13 PM
#6
This is a valuable discussion for me.  I don't know about "enable curve frame".  What is it and how do you do it? 

Logged


* June 11, 2009, 08:09:26 PM
#7
re: about "enable curve frame".  What is it and how do you do it?

In the Properties dialog for Curve, on the Curve page, checkmark "Show Frame".
In Selection Info, check "Show Frame" in the Curve section.

As you draw your curve, it places a polyline between the points.

As stated in Help:
Show Frame: If checked, a polyline frame will be displayed
connecting the curve's control points. This provides visual
feedback about how the curve is drawn.


John R.


Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* June 12, 2009, 09:00:00 AM
#8
Thanks for the elucidation.  Of course, properties makes sense.  I was looking for some other global setting.

It appears that sweep works for curves which are not monotonic.  I tried sweeping along beziers that curved in two directions, the curve crossed the frame, and it worked.

Is crossing the frame the actual problem or is it the tightness of the curve relative to the size of the swept profile?

Logged