TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Moving Objects in Ortho mode
Read 7144 times
* June 20, 2014, 06:41:56 PM
When an object is selected if you hover to the right of the reference point the 4 arrows shows and if you pick it there you can move the object horizontally keeping the same y position. Is there a way to do this vertically in the drawing space? Have searched all over and have not found a way to do this.

Logged


* June 20, 2014, 07:40:55 PM
#1
When an object is selected if you hover to the right of the reference point the 4 arrows shows and if you pick it there you can move the object horizontally keeping the same y position. Is there a way to do this vertically in the drawing space? Have searched all over and have not found a way to do this.

It works that way for the X, Y, and Z axes, but you may have to change your viewpoint in order to get the 4-way arrow.

Henry H

Logged


* June 20, 2014, 08:12:36 PM
#2
Try the Front or Back, Left or Right view to get the selection to move in the Z direction. In a Isometric or Dimetric view, the selection will only use X & Y.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* June 20, 2014, 08:35:30 PM
#3
Try the Front or Back, Left or Right view to get the selection to move in the Z direction. In a Isometric or Dimetric view, the selection will only use X & Y.

In my installation, Z is available in isometric views.

Henry H

Logged


June 20, 2014, 08:40:39 PM
#4
Try the Front or Back, Left or Right view to get the selection to move in the Z direction. In a Isometric or Dimetric view, the selection will only use X & Y.

In my installation, Z is available in isometric views.

Henry H

Same here (version-19.2-Deluxe).

Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


June 20, 2014, 08:46:13 PM
#5
When an object is selected if you hover to the right of the reference point the 4 arrows shows and if you pick it there you can move the object horizontally keeping the same y position. Is there a way to do this vertically in the drawing space? Have searched all over and have not found a way to do this.

Are you working in 2D or 3D?
By "vertically" are you referring to up-and-down as viewed on your screen, in the "normal" World Plan View?... or up-and-down as would be in the real-world (the World Coordinate System's Z-Axis)?

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* June 20, 2014, 09:07:27 PM
#6
I have Ortho Mode active and the Step Angle set at 90. When I pick up the 3D object it only goes in 2 directions; X or Y. The Z coordinate field is available to input something, but the selection doesn't move in a Z direction until I'm in one of the aforementioned views.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


June 20, 2014, 09:35:53 PM
#7
I have Ortho Mode active and the Step Angle set at 90. When I pick up the 3D object it only goes in 2 directions; X or Y. The Z coordinate field is available to input something, but the selection doesn't move in a Z direction until I'm in one of the aforementioned views.

"Ortho mode active"... that's the difference.

Likewise, in Isometric or Dimetric Views, with Ortho mode active, I cannot move in the Z direction.  I assume Henry will report the same.

----
Still waiting on a response from lcone, whether he/she is working in 2D or 3D, and referring to "vertical" as moving in the (World UCS) Z direction or Y direction.
« Last Edit: June 20, 2014, 09:37:35 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* June 21, 2014, 03:00:58 AM
#8
When an object is selected if you hover to the right of the reference point the 4 arrows shows and if you pick it there you can move the object horizontally keeping the same y position. Is there a way to do this vertically in the drawing space? Have searched all over and have not found a way to do this.

Are you working in 2D or 3D?
By "vertically" are you referring to up-and-down as viewed on your screen, in the "normal" World Plan View?... or up-and-down as would be in the real-world (the World Coordinate System's Z-Axis)?

Working in 2D. Also using TC deluxe 21.

Logged


* June 21, 2014, 04:32:21 AM
#9
You can constrain your movement to along any of the x, y and z axes only by picking up the object by clicking on the axis line, not on the reference point.  As the respondents are telling you, you'll have to be looking at a view that lets you see the axis line, in any Ortho view you'll only see two of three, so z isn't accessible by mouse/cursor in 2d plan view.
« Last Edit: June 21, 2014, 04:39:13 AM by murray dickinson »

Logged


June 21, 2014, 07:46:30 AM
#10
You can constrain your movement to along any of the x, y and z axes only by picking up the object by clicking on the axis line, not on the reference point. ...

I absolutely did not know that.  Thanks Murray!  -Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


June 21, 2014, 10:02:01 AM
#11

Working in 2D. Also using TC deluxe 21.

Okay.  I see what's going on:

You are working in 2D.  Plain ol' World Plan view, on the plain ol' World Workplane (World Coordinate System; World UCS).
You are using the Selector in 2D Selector Mode.

As Murray just taught us, if you move your cursor a bit to the right of an Object's Reference Point, you are now "grabbing" the X-axis, not the Reference Point, for moving.  You are thereby limited to moving in the X-direction; the Object maintains its Y-coordinate.

A way to "lock" your movements (when working in 2D) is to use the Ortho mode* (see here), as Henry was describing.  There are a few ways of getting the "Ortho Mode" active; I'm going to leave it to you research the alternate ways of activating it, or let someones else describe them to you.

But here's the key:  Instead of moving your cursor a little to the right of the Object's Reference Point, hover right on top of the Reference Point and click when the "4 arrows" icon pops up .  The difference here is that instead of being able to move the Object in only the X-direction-- as is the case when you click on the X-axis-- you can move the Object basically anywhere you wish.
However:  If you have the "Ortho mode" active, you can only move the Object at an angle as defined in your current Drawing space's "Step Angle" setting-- for most Users/Drawings, that is 0°, 90°, 180°, and 270°.  I say "most" because that is the default, and most people just leave it there... I'm pretty sure...

-----
Alternatively, you could switch your Selector Mode to 3D Selector Mode and click on the Y-axis to limit your movements to being in the Y-direction.  However, working with 2D Objects in a Drawings one wishes to remain 2D can cause issues when using the Selector in 3D Selector Mode.  At the very least, TurboCAD will keep popping up a warning regarding changing the Object's Workplane; and if a User is more of a novice, I don't think it's a good idea to check the "Don't show this message again" option for these particular warnings-- I never check this option for this warning.

--Alvin


*Ortho Mode (from the TurboCAD Wiki site):

Ortho Snap
Icon: Image Image
Menu: Modes / Snaps / Ortho
Hotkey: Shift+O
Alias: ortho
  When in use, the cursor can only move horizontally or vertically.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* June 23, 2014, 12:43:17 AM
#12
With further extensive experimentation, I have found the quick solution: with the object selected, if you rotate the object 90 deg. via the inspector bar, the axis line between the reference point and the rotation handle rotates with the object (changes it to a vertical axis line (as referring to the screen vertical/horizontal positioning)) and this allows you to pick the object just above the reference point and you can then move the object in the Y direction without affecting the X position, you then (with the object still selected) can change the rotation back to zero in the inspector bar, thus returning the object back to its original orientation. I thank you all for your consideration regarding this problem!  :)

Logged


* June 23, 2014, 06:32:01 AM
#13
wouldnt it be easier to hold the shift key down?

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* June 23, 2014, 10:26:56 AM
#14
Nikki,

Do not know what you mean by "holding the shift key down"? I see that you are a TC Platinum 20 user; I am using TC Deluxe 21 and some of the features available in the Pro and Platinum versions are not available in Deluxe; ex. Constraints as mentioned in another reply. When I hold down the shift key, whether before or after, the object is selected, all that does is not allow the 4 way arrow to appear and thus the selected object cannot be picked.

Logged


* June 23, 2014, 10:39:42 AM
#15
The Shift key work in DL 21 also, select the object you want to move, or after set a point of a line i e, then press and hold the shift key down, move your mouse in a direction and you will see that the object or line will follow your Ortho mode.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* June 23, 2014, 12:08:32 PM
#16
Torfinn,  I have attempted your suggestion w/holding down the shift key after object  selected,. before selected, with Drawing Aids Ortho Mode checked and un-checked, but when the shift key is held down nothing happens when cursor is moved. I am obviously doing all of this in the "select/edit" mode. Is there something I am missing?

Logged


* June 23, 2014, 12:33:37 PM
#17
Select object and start the movement with your mouse in the direction you want, press shift and it should straiten? up to the nearest ortho direction,
after left click and place the object in the new place, release the shift, esc or click outside area and the movement is finished

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* June 23, 2014, 02:23:07 PM
#18
GOT IT!  THANKS

Logged


* June 25, 2014, 01:59:26 AM
#19
I take it the capital letters mean Yes Nikki, holding the shift key down would be easier .


Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* June 25, 2014, 07:40:33 AM
#20
Yes Nikki, holding the shift key down would be easier!

Thanks

Logged


June 25, 2014, 08:16:34 AM
#21
Holding the Shift-key down while moving an Object restricts the movement to Ortho.
____
Add that to the list of novice-level functions that I did not know.

Being that my mouse is in my right-hand, I have a Shift-key on my extreme-left-of-keyboard, and that I move in Ortho a lot, I hope to incorporate this as a habit and make good use of it.

Thanks you guys!  -Alvin

[follow-up question removed; I had a duhhh moment ]
« Last Edit: June 25, 2014, 08:32:36 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* June 25, 2014, 08:34:00 AM
#22
I'm not sure, but i believe it's a marker for selecting next = + or in the case where you have selected some object's alredy and the have the shift key down unselect = -

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


June 25, 2014, 08:52:30 AM
#23
I'm not sure, but i believe it's a marker for selecting next = + or in the case where you have selected some object's alredy and the have the shift key down unselect = -

Torfinn

Yeah, I removed that question from my previous Post, Torfinn.  I had a "duh" moment.  With only one Object in my little "experiment"-Drawing (and my morning-coffee not yet having fully kicked in) I was thrown off by the ± when holding the Shift-key.

Thanks for the Reply Torfinn.  -Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)