TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Ideal Settings
Read 11105 times
October 07, 2009, 07:09:08 PM
I was hoping that someone with Animation Lab experience would be willing to tell me/us what some ideal settings would be for the program. To create a fluid and continuous looping scenario as in revolving one object around another.

Consider an object moving 360° around a stationary object.

How many positions and frames in between?

Ideal Frame Rate?

The attached images show what I used in the GIF.

[attachment deleted by admin]


October 07, 2009, 07:49:17 PM
#1
Hi Don, I posted some of my preferred settings here
http://forums.turbocad.com/index.php/topic,662.new.html
I normally try to keep positional changes to some even division of 360°

Logged
Julian

TC18 / 38.5 Platinum, AL5. XP, Core2 Duo E6750 OC'd 3.0Ghz, Render test: 3mins 3sec.


October 08, 2009, 04:45:44 AM
#2
I start at 24 frames/sec and 6º per frame. Make sure the last frame is not the same as the first one.

Logged
Hardware: 2.67GHz Core I7-920, 18GB 1333 DDR3, Nvidia Gforce GT 220
OS: 64 Bit Windows 10 Home
Software: TC 2018.25.0.41.0 (64)
Setup: UI: Classic, Editing History: Off, Use Choice: Off, Native Draw: GDI


October 08, 2009, 09:20:04 AM
#3
Thanks Julian and Winston. Much appreciated.


October 08, 2009, 02:57:55 PM
#4
Hi Don,

Normally I use 25 frames/sec,
but if I send animations on the web I use 10 frames/sec.
This about the length of the file.
Also it depends I use .avi or .gif as output.

This means that the movement of an object is less smoothly with 10 frames/sec.

It also depends what you want,
example of real time mechanical animation:
you want to move object A in a distance of 250 mm,
with a resolution (movement) of 10 mm,
and this must be done in 0.5 sec.

Then you need (250 mm / (10 mm / image)) = 25 frames in 0.5 sec = 50 frames/sec.
So, you need to enter 25 frames,
and the settings in AnimationLab on 50 frames/sec.


I also output the drawings in .bmp,
for me, these are longer as file, but better to import in other graphic programs for editing.

Lots of fun,
Marc
« Last Edit: October 08, 2009, 03:15:48 PM by marc_256 »

Logged
greetings from belgium (Pajottenland)
WIN 8.1/10 - x64
- TC 9 --> TC 16.2 / 52.0 pro Platinum
- AnimationLab 4.4 - MontageCenter 1.0
- CAM plug-in for v 16


October 08, 2009, 08:20:13 PM
#5
Here is a video of the Tri-Lobe Helical Gear Blower posted on YouTube: http://www.youtube.com/watch?v=UjK0qcwrZYI


October 09, 2009, 05:00:07 AM
#6
I suggest a format and location where it can loop. Then you can show just one revolution with a lot more frames for the same or less size.

Logged
Hardware: 2.67GHz Core I7-920, 18GB 1333 DDR3, Nvidia Gforce GT 220
OS: 64 Bit Windows 10 Home
Software: TC 2018.25.0.41.0 (64)
Setup: UI: Classic, Editing History: Off, Use Choice: Off, Native Draw: GDI


October 09, 2009, 05:18:20 AM
#7
I suggest a format and location where it can loop. Then you can show just one revolution with a lot more frames for the same or less size.

In actuality it is quite short - the length comes from a screen capture. Only player I could find that didn't have a detectable lag at loop was the Window Classic Media Player, so I just ran it for a minute, while screen capturing with Camtasia.

What players do you use?


October 09, 2009, 05:37:11 AM
#8
Windows Media Player 11.
I think your animation needs more frames.

Logged
Hardware: 2.67GHz Core I7-920, 18GB 1333 DDR3, Nvidia Gforce GT 220
OS: 64 Bit Windows 10 Home
Software: TC 2018.25.0.41.0 (64)
Setup: UI: Classic, Editing History: Off, Use Choice: Off, Native Draw: GDI


October 09, 2009, 05:56:01 AM
#9
Windows Media Player 11.
I think your animation needs more frames.

Might need more frames, but it isn't going to happen because after trying to make the animation a few times and running out of memory I cut it by half the original amount. If TurboCAD would release the memory after each frame gets rendered then there would be no issue, but each rendered frame added to the memory use and right at 2GB any remaining frames rendered blank. I even rendered small. That size on you tube is the actual size I rendered.

This whole animation business - I really don't get. If the help files for animation lab were even remotely helpful, then maybe I would find things that would help me make better animations, but they are pathetic and almost no help at all, so I bumble along feeling frustrated as h...ll.


October 09, 2009, 06:06:29 AM
#10
I did my 120-frame v8 engine with 2GB...let's see your movie settings.

Logged
Hardware: 2.67GHz Core I7-920, 18GB 1333 DDR3, Nvidia Gforce GT 220
OS: 64 Bit Windows 10 Home
Software: TC 2018.25.0.41.0 (64)
Setup: UI: Classic, Editing History: Off, Use Choice: Off, Native Draw: GDI


October 09, 2009, 06:23:16 AM
#11
I did my 120-frame v8 engine with 2GB...let's see your movie settings.

Thanks for looking. I could get 56 frames with the same illustrated settings (60 frames though). I did the final with the attached settings.

[attachment deleted by admin]


October 09, 2009, 12:31:15 PM
#12
Windows Media Player 11.
I think your animation needs more frames.

Might need more frames, but it isn't going to happen because after trying to make the animation a few times and running out of memory I cut it by half the original amount. If TurboCAD would release the memory after each frame gets rendered then there would be no issue, but each rendered frame added to the memory use and right at 2GB any remaining frames rendered blank. I even rendered small. That size on you tube is the actual size I rendered.

This whole animation business - I really don't get. If the help files for animation lab were even remotely helpful, then maybe I would find things that would help me make better animations, but they are pathetic and almost no help at all, so I bumble along feeling frustrated as h...ll.

Hi Don,

not sure if this will be any help, but . . .

You appear to be using Montage Center (Centre!) to generate an AVI animation.  I have a feeling, which has not yet been confirmed, that it produces the old AVI type 1.0 file, which is limited to <2Gb.

So, a way around this limitation is to use another animation programme to construct your movie from the TC images, if you are getting near this limit.

I have noticed that high quality images, sometimes produce better movies, when the frame rate is lowered.  For example 16fps.  Players can really struggle with large frame rates.

Lastly, but I am sure you have already noticed, AnimationLab is zero-based, so your frame count is one less than that required (i.e. 0-15 for 16 frames, and smooth loops).

Hope this helps cut the "h..ll" out of your animations!


Regards Tim


P.S. You might find this little utility programme useful . . .

http://www.inmatrix.com/download/avifrate110.zip

« Last Edit: October 09, 2009, 12:56:32 PM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.


October 09, 2009, 01:56:26 PM
#13
I really can't understand why you're hitting memory limits. It's a very simple model to animate. Compared to your Height x Width x No of Frames, my chess board revolve is 10 times bigger and had no problems whatsoever.

Perhaps try using BMP frames, I'm guessing there's a buffer problem caused by each frame being saved first as BMP then internally converted to JPG.

Logged
Julian

TC18 / 38.5 Platinum, AL5. XP, Core2 Duo E6750 OC'd 3.0Ghz, Render test: 3mins 3sec.