TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

2D or 3D Mode Indicator
Read 1684 times
* July 10, 2019, 09:57:48 PM
I apologise up front if this is a question that has an obvious answer.

Is there an easy way to determine whether you are in 2D or 3D mode?  I am aware of the 2D/3D toggle but would really appreciate seeing which mode I am in via a clear coloured icon/button.  I do all my work in 2D but will move to 3D eventually and some issues I experience tell me I am in 3D (how I got there i do not know but probably being a hamfisted user... :) )

TC2019 Pro on PC running Win 10 Pro 64 bit.

Logged
TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.


* July 11, 2019, 12:03:14 AM
#1

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


July 13, 2019, 08:20:08 AM
#2
Hi PatM,

Attached below is the way I determine whether I'm in 2D or 3D mode.  To simplify things I always work in 3D mode.

Hope this helps.

Chachin..

Logged
TurboCAD Pro Platinum 2015.
Live debt-free.


* July 13, 2019, 09:23:58 AM
#3
Thats because you have RedSDK and your Native Draw is set to RedSDK, in GDI you will not be able to Select the Conseptual.
The selector will still have 3 arms in 3D and 1 in 2D

It's not necessarily a good ide'a to allways be in 3D mode, if you Draw 2D Objects i.e.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* July 14, 2019, 04:43:07 PM
#4
Thanks for all the feedback guys, but I still have problems quickly identifying what mode I am in.

Is there a way I can generate my own button or icon to clearly show 2D or 3D?

One of the reasons I want to do this is that I receive the 'alert' attached which tells me that selecting the object will change the workplane.  I have world plane selected, and as you can see from the attached Icon bar the only option in the adjacent icon is 'auto workplane by face'.  To me, this is indicating that the work plane keeps changing?  This may be the cause of another issue I am having with offsets raised in the problems forum?

Appreciate any feedback/suggestions as to how I should have this setup as I ONLY work in 2D at the moment.

cheers

Pat
« Last Edit: July 15, 2019, 06:06:51 PM by PatM »

Logged
TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.


* July 15, 2019, 06:05:04 PM
#5
Sorry guys could not find a way to add the files to the previous post.
cheers

Pat

Logged
TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.


* July 15, 2019, 08:05:55 PM
#6
Just click on the "Options" button up on rigth side of the post you want to change and Select "Modify" then you can add pics if you want or change txt etc etc, aslong you are the one who did write it, else you can only select "Quote"

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* July 15, 2019, 08:13:58 PM
#7
Many thanks Torfinn; noted for the future.

cheers

Pat

Logged
TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.


* July 15, 2019, 08:36:27 PM
#8
Hi all, I have managed to resolve 2.5 of three issues I have posted in this and the Problems forum; many thanks.

I still have one issue remaining and would still really like to see visually via an icon whether I am in 2D mode, but that is probably not possible.

Related, but probably harder to do, is whether I can force/lock the programme to stay in Worldplane  and toggle it off if I ever change to 3D mode?  I had an issue caused by an imported object retaining some of its 3D properties, which was changing the workplane on me and causing some of my issues.

cheers

Pat
« Last Edit: July 15, 2019, 11:05:30 PM by PatM »

Logged
TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.


July 20, 2019, 06:45:17 AM
#9
Hi Pat, Torfinn,

I changed my Native Draw settings to GDI (Not RedSDK; no conceptual selector) to take the screenshots attached below and I still think the easiest way to tell whether I'm in 2D or 3D is via the 2D/3D selector icon as well as the 2D or X,Y, Z coordinate system shown when an item is selected. 

Thanks to your clarification Torfinn, I will try to do all my sketching in 2D mode from now on to see if it saves me from having to place my items on the current Workplane every time I move a 2D object.

Disclaimer:  I'm no TurboCAD expert, just trying to help... which ironically helps me learn the software better myself through other people's comments and responses.

Logged
TurboCAD Pro Platinum 2015.
Live debt-free.


* July 20, 2019, 07:23:13 AM
#10
Yes, as the z difference dont need to be big before TC see it like objects are on different workplanes, 0,00001 mm will be different workplane from 0,00000, and that can very easy happen if you are i 3D mode when draw 2D objects.
You can set the selector to "2D/3D Depending" inside it's property and TC will remember it for you.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* July 20, 2019, 05:07:20 PM
#11
Thanks guys, appreciate the feedback, and I also have learned quite a bit :)

cheers

Pat

Logged
TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.