TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Scale is a mess
Read 11976 times
* August 14, 2012, 10:24:04 AM
I'm new to TurboCad 19 and having trouble understanding how scale works w/in the program. I've searched previous posts and the user guides but I still don't know what I am doing. Here is what's going on:

I imported some .DWG floor plans that are scaled for Arch C printing (18" x 24") and 1/4" = 1'. When I work with them the dimensional tool is inaccurate and displays the length of the drawing (in inches) vs. the distance of a wall that should be in feet. I checked the page setup utility and it shows the following values:

Printer Paper = letter size, landscape
Drawing Sheet SIze = 13.522" x 16.131", landscape
Model Space Printing Scale = 1" = 1' (full size)

I changed the drawing sheet size to Arch C and tried various setting on the Model Space (1/4" = 1", fir to size..) but the dimensional tool continues to measure inches instead of feet. I've also set "SPace Units" under "Format" to 1/4" = 1". I've even tried changing the paper size to Arch C.

I apologize in advance for not understanding what must be a basic function of the program. Thanks, Jim

Logged


* August 14, 2012, 07:42:17 PM
#1
try this
in dimension mode
right click, click on properties, go to units/tolerance, check the append units  change units to ft

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* August 15, 2012, 07:31:36 AM
#2
Thanks for the help, but unfortunately the scale is still wrong.

Logged


* August 15, 2012, 08:23:22 AM
#3
Is the problem the size of what is printed or with the numeric info that is printed. If it is the image size, there are two scaling factors that control what gets printed. First is the scale factor of the viewport. Second is the scale factor from viewport to paper in the printer. I suggest that the second be set to 1:1 and not changed. The viewport scale is controlled when the paperspace is active on the screen. Select the viewport, and properties. I usually select 'fixed' and select the desired factor.
For the printed numeric dimensions on an existing drawing, I think they can only be changed by selecting each dimension and using the properties to change the units and precision. Changing the properties of the dimension tool only affects newly created dimensions.

 
« Last Edit: August 15, 2012, 08:33:18 AM by bytewise »

Logged


* August 15, 2012, 08:43:21 AM
#4
I'm new to TurboCad 19 and having trouble understanding how scale works w/in the program. I've searched previous posts and the user guides but I still don't know what I am doing. Here is what's going on:

I imported some .DWG floor plans that are scaled for Arch C printing (18" x 24") and 1/4" = 1'. When I work with them the dimensional tool is inaccurate and displays the length of the drawing (in inches) vs. the distance of a wall that should be in feet. I checked the page setup utility and it shows the following values:

Printer Paper = letter size, landscape
Drawing Sheet SIze = 13.522" x 16.131", landscape
Model Space Printing Scale = 1" = 1' (full size)

I changed the drawing sheet size to Arch C and tried various setting on the Model Space (1/4" = 1", fir to size..) but the dimensional tool continues to measure inches instead of feet. I've also set "SPace Units" under "Format" to 1/4" = 1". I've even tried changing the paper size to Arch C.

I apologize in advance for not understanding what must be a basic function of the program. Thanks, Jim

http://forums.turbocad.com/index.php/topic,9650.0.html
Have a look at the link. It may help.

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


August 15, 2012, 08:53:57 AM
#5
I'm new to TurboCad 19 and having trouble understanding how scale works w/in the program. I've searched previous posts and the user guides but I still don't know what I am doing. Here is what's going on:

I imported some .DWG floor plans that are scaled for Arch C printing (18" x 24") and 1/4" = 1'. When I work with them the dimensional tool is inaccurate and displays the length of the drawing (in inches) vs. the distance of a wall that should be in feet. I checked the page setup utility and it shows the following values:

Printer Paper = letter size, landscape
Drawing Sheet SIze = 13.522" x 16.131", landscape
Model Space Printing Scale = 1" = 1' (full size)

I changed the drawing sheet size to Arch C and tried various setting on the Model Space (1/4" = 1", fir to size..) but the dimensional tool continues to measure inches instead of feet. I've also set "SPace Units" under "Format" to 1/4" = 1". I've even tried changing the paper size to Arch C.

I apologize in advance for not understanding what must be a basic function of the program. Thanks, Jim

*EDIT:  After re-reading Jim's original Post on this Topic, and the later Posts from the more knowledgeable and experienced Users, I question the veracity and "applicableness" of my original Reply below- particularly in reference to what I wrote regarding AutoCAD users and how they are taught to draw.  -Alvin (8/15/12 10:54 PDT)

Hi Jim,

Your 4th paragraph, regarding "drawing sheet size", etc. has nothing to do with it.  From what little I know about AutoCAD (from looking over AutoCAD Architectural 2D user's shoulders, asking them questions; and also from opening AutoCAD originated 2D drawings in TurboCAD), many if not most of them draw in what we call in TurboCAD Model Space; then they just plot to the printer from there.  I don't think most of them use Viewports in Paperspace like we do.

We in TurboCAD are taught to draw everything in Model Space at full-scale (1"=1"), then to Insert Viewports into Paperspace, and Scaling the Views there.

Your Dimensions are coming out correct for how the original AutoCAD drawing was drawn: ¼"=1'.

----
The easiest way to Scale your drawing is (in Model Space) to Edit|Select All (or hold down the Ctrl key and type "A"), being sure every Layer is Turned On and not Locked; then in the Inspector Bar in the Scale X and Scale Y field type "48".  That will enlarge everything in your drawing to Full Size.  (alternatively, you can have the Keep Aspect Ratio activated, and type "48" in either the Scale X or Scale Y fields.)

  *A Caveat:  Some Objects or Entities may not scale-- such as Groups.  And you'll have to "manually" change those entities with a little work and effort.

-----
Alternatively:  If you are just looking to have the Dimensions be correct, you set your Dimensions|Properties|Units/Tolerance|Scale to 48.  That will make the adustments for you.  It just multiplies what it's measuring by 48 (¼" is 1/48th of 1'... or.... 12" [1'] is 48 times ¼").

Give those/that a try and report back.

-Alvin

*EDIT:  After re-reading Jim's original Post on this Topic, and the later Posts from the more knowledgeable and experienced Users, I question the veracity and "applicableness" of my original Reply above- particularly in reference to what I wrote regarding AutoCAD users and how they are taught to draw.  -Alvin (8/15/12 10:54 PDT)
« Last Edit: August 17, 2012, 06:40:55 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 15, 2012, 08:59:34 AM
#6
I'm new to TurboCad 19 and having trouble understanding how scale works w/in the program. I've searched previous posts and the user guides but I still don't know what I am doing. Here is what's going on:

I imported some .DWG floor plans that are scaled for Arch C printing (18" x 24") and 1/4" = 1'. When I work with them the dimensional tool is inaccurate and displays the length of the drawing (in inches) vs. the distance of a wall that should be in feet. I checked the page setup utility and it shows the following values:

Printer Paper = letter size, landscape
Drawing Sheet SIze = 13.522" x 16.131", landscape
Model Space Printing Scale = 1" = 1' (full size)

I changed the drawing sheet size to Arch C and tried various setting on the Model Space (1/4" = 1", fir to size..) but the dimensional tool continues to measure inches instead of feet. I've also set "SPace Units" under "Format" to 1/4" = 1". I've even tried changing the paper size to Arch C.

I apologize in advance for not understanding what must be a basic function of the program. Thanks, Jim

Hi Jim,

Your 4th paragraph, regarding "drawing sheet size", etc. has nothing to do with it.  From what little I know about AutoCAD (from looking over AutoCAD Architectural 2D user's shoulders, asking them questions; and also from opening AutoCAD originated 2D drawings in TurboCAD), many if not most of them draw in what we call in TurboCAD Model Space; then they just plot to the printer from there.  I don't think most of them use Viewports in Paperspace like we do.

We in TurboCAD are taught to draw everything in Model Space at full-scale (1"=1"), then to Insert Viewports into Paperspace, and Scaling the Views there.

Your Dimensions are coming out correct for how the original AutoCAD drawing was drawn: ¼"=1'.

----
The easiest way Scale your drawing is (in Model Space) to Edit|Select All (or hold down the Ctrl key and type "A") [/b] (be sure every Layer is Turned On and not Locked), then in the Inspector Bar in the Scale X and Scale Y field type "48".  That will enlarge everything in your drawing to Full Size.  (alternatively, you can have the Keep Aspect Ratio activated, and type "48" in either the Scale X or Scale Y fields.)

  *A Caveat:  Some Objects or Entities may not scale-- such as Groups.  And you'll have to "manually" change those entities with a little work and effort.

-----
Alternatively:  If you are just looking to have the Dimensions be correct, you set your Dimensions|Properties|Units/Tolerance|Scale to 48.  That will make the adustments for you.  It just multiplies what it's measuring by 48 (¼" is 1/48th of 1'... or.... 12" [1'] is 48 times ¼".

Give those/that a try and report back.

-Alvin

AutoCAD users are no different... unless they are clueless.. been taught wrong, and are doing it wrong.  ;)

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


August 15, 2012, 09:07:07 AM
#7

AutoCAD users are no different... unless they are clueless.. been taught wrong, and are doing it wrong.  ;)


I can see that (what Greg T posted above) being the case.  As it says in my "signature line" I have no formal CAD training, so I don't know how they officially teach it.  I do know from observation and experience, however, that (okay, some) AutoCAD trained Architectural 2D draftsman do draw in that ¼"=1' Scale as I stated in my just previous post.

Anyway... just give it a try-- that/those suggestions I posted just previously.

-Alvin
« Last Edit: August 15, 2012, 10:09:12 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 15, 2012, 10:36:27 AM
#8
Hi Jim,

As you can see from other posts, dimensioning involves a number of things  :)

I will stick with what I do in Model Space. That is where your imported dwg file should be located.

After you have made 'changes' in model space, you create a Viewport and open that viewport in Paper Space (which will have different scaling options, mainly because you are laying out Paper Spaces that are scaled to fit the paper size). I do all my line work / dims etc in model space, paper space is only for printing.

==========================================

But for Model space, I just import the dwg.

To get items you Draw in model space to show up in feet and inches...

 Go To >Options (on top)> Space Units > change Units in Workspace to > Architectural

To get dimensions in feet and inches and sized properly...

1 Select an existing dimension in the dwg > right click > Properties > check the Font Height (and Style)

In the attached you can see the Font Height is 10". So I then select the Dimension Tool and adjust.

2 Select Dimension tool > right click > Properties >Format > change Dimension Size Scale ( I made mine 40 , the plan was at 1/4" scale and text test was 10 inches , so 4 x 10 = 40. I didn't change the font itself.)

That's it. I didn't adjust the model space to any 1/4" scale. I didn't change anything in the Dimension tool except it's 'size', no value changes.
You can see from the 'sample new dim' jpg, that all matches well (except of course the font in New Times not Cadsoft).

If for some reason your dimension scaling itself is still off you may find the Dim Properties > Units/ Tolerance works but you should not have to do that. Or at least I never have had to.

Jack
« Last Edit: August 15, 2012, 10:50:47 AM by Jack Zimmer »

Logged


August 15, 2012, 11:10:41 AM
#9
Jim,

If you are still following, interested, and want help with this issue that you originally posted in this Topic, you should attach and upload the .tcw file (regular ol' TurboCAD file).

As you can see from the Replies above, there are a lot of possiblities of what could be the issue.  But, it is definitely an easy "fix".  Everyone just needs to be able to take a look at what's going on.

Just Reply back, and click "Additional Options" in the Editor window, and Attach....

Okay.... I'm out, until we see that file.  Take care -Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 15, 2012, 12:04:25 PM
#10

AutoCAD users are no different... unless they are clueless.. been taught wrong, and are doing it wrong.  ;)


I can see that (what Greg T posted above) being the case.  As it says in my "signature line" I have no formal CAD training, so I don't know how they officially teach it.  I do know from observation and experience, however, that (okay, some) AutoCAD trained Architectural 2D draftsman do draw in that ¼"=1' Scale as I stated in my just previous post.

Anyway... just give it a try-- that/those suggestions I posted just previously.

-Alvin

Back when I taught AutoCAD... everything was done in MS... I can't even remember there being a PS. Everything was drawn full scale... a title block was inserted at a scale to fit around the drawing... 1:4, 1:8... etc... and the drawing was then  printed at the scale to which the title block was inserted.

Old school... just showing my age.  :D

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* August 15, 2012, 05:47:03 PM
#11
I was taught AC somewhere around R12, but I do recall PS, viewports and all.  Reason for it was that ISO standards (I assume similar ANSI ones) define different line weights for different outputs ie A4 sheets use .3mm, .5mm and .7mm, A3 uses .5mm, .7mm & .9mm, A2 uses .7mm etc etc.  The line weights date from pencil-and-board, then pen-plotters with drafting pens (anyone else remember trying to keep those unclogged?), and the standard was supposed to ensure that something drawn at A2 looks more-or-less the same as a Xerox-enlarged A4 or A3 sheet.  Being able to view electronic drawings makes a lot of it redundant pedantry, but ACAD had pretty good utility for that sort of stuff, but it was all tied into the printer settings as well.  I remember having to assign one file per sheet size for TC V5, maybe V6 too, because there was only one paper space, but using system printers was easier, if memory serves.

Logged


* August 15, 2012, 08:37:30 PM
#12
I think autocad 10 never had paperspace modelspace. In Acad 14 there is paperspace model space.
Lots of people never changed their system of drawing

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* August 16, 2012, 02:37:09 AM
#13
I was taught AC somewhere around R12, but I do recall PS, viewports and all.  Reason for it was that ISO standards (I assume similar ANSI ones) define different line weights for different outputs ie A4 sheets use .3mm, .5mm and .7mm, A3 uses .5mm, .7mm & .9mm, A2 uses .7mm etc etc.  The line weights date from pencil-and-board, then pen-plotters with drafting pens (anyone else remember trying to keep those unclogged?), and the standard was supposed to ensure that something drawn at A2 looks more-or-less the same as a Xerox-enlarged A4 or A3 sheet.  Being able to view electronic drawings makes a lot of it redundant pedantry, but ACAD had pretty good utility for that sort of stuff, but it was all tied into the printer settings as well.  I remember having to assign one file per sheet size for TC V5, maybe V6 too, because there was only one paper space, but using system printers was easier, if memory serves.

I learned AutoCAD in version 1.2 back in the 80'... started teaching with R9 I believe it was. I know there wasn't a PS when I started using it... but can't remember exactly when they added it.... as I never used PS in AutoCAD... even in 2004.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* August 16, 2012, 07:10:19 PM
#14
Hi Everybody!

I can't thank all of you enough for the great advice. FYI, Alvin nailed the problem right on the head (does that qualify as a pun?). When I changed the  X,Y fields in Model Space to a value of 48 the scale was corrected and the dimension tool measured correctly, etc.

I have a lot to learn. Thanks again! Jim

Logged


August 16, 2012, 07:27:50 PM
#15
Hi Everybody!

I can't thank all of you enough for the great advice. FYI, Alvin nailed the problem right on the head (does that qualify as a pun?). When I changed the  X,Y fields in Model Space to a value of 48 the scale was corrected and the dimension tool measured correctly, etc.

I have a lot to learn. Thanks again! Jim

Glad to hear that you got it figured out, Jim.  Just out of curiosity (because there's a chance that it's still not exactly right) when you select an object- let's say a Wall- down there in the Inspector Bar, are the Values (length in X and Y) correct, or is there any chance that they are 48 times too large?

----Just out of curiosity and to make sure that the remedy was the correct remedy- because there is a possibility that the "fix" that I recommended and you applied only seems to have solved the issue, but really didn't.  If that's the case, the remedy is this one other thing (that we could go over with you if needed.) :-[

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 16, 2012, 08:57:52 PM
#16
Hi Alvin,

I only figured it out thanks to you. Regarding the X, Y measurements of an object, they are correct although they display in inches which can be annoying at this scale.

Thanks again, Jim

Logged


August 16, 2012, 09:16:46 PM
#17
Hi Alvin,

I only figured it out thanks to you. Regarding the X, Y measurements of an object, they are correct although they display in inches which can be annoying at this scale.

Thanks again, Jim

Well, good to read, Jim that the measurements of an object- as displayed in the Inspector Bar when Selected are correct.  Seems like the remedy I suggested previously worked- in your particular case; there were other possibilities as to what the issue- and remedy- was.

----
Regarding "they display in inches" (from your post, quoted above):  Be sure that in Options|Drawing Setup|Space Units you have Units in Workspace|Format set to "Architectural".  See the screen-capture below- that's how I have mine set up to have it display as wanted.  I have Precision set to "4", to produce precision to the 1/16", because, come on.... who can build a house or other building to anything more precise?

Having architectural drawings showing in only inches (") is no good; let's get that fixed.

-Alvin

(note: you will see in my screen-capture that I do not have "Convert materials after alteration" checked; I'm not exactly clear on what that option does, or if I want it checked or not.)
« Last Edit: August 18, 2012, 04:46:41 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 19, 2012, 01:12:05 PM
#18
Thanks Alvin! Is there a way to globally change the font for dimensions? I have a lot of dimensions on this doc and do not look forward to modifying their properties one at a time. I've changed it in Style Manager, but it did not change the existing dimensions.

Logged


August 19, 2012, 01:35:35 PM
#19
Thanks Alvin! Is there a way to globally change the font for dimensions? I have a lot of dimensions on this doc and do not look forward to modifying their properties one at a time. I've changed it in Style Manager, but it did not change the existing dimensions.

Hi Jim,

Alvin's Disclaimer:  Though I am experienced in version 11.2 (especially in regards to 2D, Architectural stuff- I can do 3D well enough, but not rendering [i.e.: Materials and Lighting]), I am just now working with version 19 (Pro Platinum).  It's not that much different, really, as far as I thus far deciphered (I'm sure I'll get arguement to that).  The reason I mention that is:  This whole Styles thing- Walls, Dimensions, Doors, Windows, etc.- is completely new to me (but not something that is all that difficult to figure out).  

Anyway, to answer your question (quoted above): Yes!  Just go to Edit|Select By|Entity Type and choose all the Dimensions options (holding down the Shift or Control key while "clicking", you can select multiple selections).

All your Dimensions of every type (mostly, you'll have Dimensions: Linear, if not only that type) will be Selected.  While they are selected, right-click on the screen, and click Properties and navigate to the Format window.  There you will see the option for Text Height.  Enter whatever you want them all to be; myself, when drawing in Model Space at full-scale, and knowing that- via Viewports in Paper Space I'm going to be actually printing at ¼"=1' scale (the standard for house drawings), I set my Text Height at 6"- that results in Text that is legible without being too large.

Note: Alternatively, if you didn't like the size of any of the settings- Arrowhead size, Text size, etc.- in that Format window you could just choose Dimension Size Scale and type in a "multiplier" that would adjust everything about the Dimension larger or smaller. (if you are really new, and just learning, I wouldn't do it that way- not yet.)

Post back as soon as- and if- you need further help.

-Alvin
« Last Edit: August 19, 2012, 03:27:58 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 19, 2012, 01:49:51 PM
#20
Thanks Alvin! Is there a way to globally change the font for dimensions? I have a lot of dimensions on this doc and do not look forward to modifying their properties one at a time. I've changed it in Style Manager, but it did not change the existing dimensions.

With your drawing open Press Ctrl+T to 'Select by Entity Type'. Click on the Dimension/Linear/Leader/etc. to highlight all dim's of that type, go to properties and change the font.  Linear dimension will probably be the majority of most dimension entries.

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


* August 24, 2012, 07:00:37 PM
#21
Many thank again! That tip saved me a lot of work.

I'm having a new issue and it should probably be a new topic. I insert an image file into the document and embed it using Image Manager. I then click "Apply" and save the file. It all works great in Turbocad but when I export to DWG or DFX the image is lost and in its place is the actual path to a .tmp file. I do mean that the image is replaced with text representing the path on my computer: c:\user\AppData\Local\Temp\.....tmp

I've searched the forum for an answer but no luck. I have tried the following formats: jpeg, gif, bmp and tried saving in every version of AC going back to 2000. The image is shown as embedded in Image Manager.

Any ideas? Thanks, Jim 

Logged