TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

newbe needind help 3d subtract not working
Read 2801 times
* July 11, 2012, 07:17:16 AM
hello new here maybe u guys can help... trying to 3d sub but it just stop working the red part and some of the green wont 3d sub no mater what i do i tryed redrawing it . not sure how to fix this help please. thanks in advance  for any advice you can give me

Logged


* July 11, 2012, 10:15:04 AM
#1
Hi and welcome

Can I ask what version you are using (I assume v ? deluxe)

with regrads you drawing the degeneration error can occur as TC is not able to calculate how the object should look, mostly this can be solved by having the subtract part slightly above the surface of the object being subtracted from, in your case the red item is correct and stands proud, however an earlier subtraction doesn't appear to have been proud, and now causes a problem - see slice1 below.

Also some of the bends within the previous subtract are incorrect - see problem below, this is causing a problem when trying to get the old subtractions correct, being honest the base object may need re-making ensuring each subtraction is correct before carrying on tho the next one., ## edit if you can live with making a new profile and extrude very slightly larger than the existing one the object can be made correct, or it may be possible to adlust the surface folds using 'node edit' mode to manually move the individual nodes to smoothe out the bends and then subtract a profile the same size to correct any errors (sorry its not easy to explain) ## end edit

hope that makes sense

Andy
« Last Edit: July 11, 2012, 10:51:49 AM by Andy H »

Logged


* July 12, 2012, 07:43:27 AM
#2
deluxe14.2 thanks but i have already tried to fix it that way. is their a better way of making the red pice? the way i made it was a 2d profile and a rail sweep it does not seam to come out clean. thanks agian i will keep working on it.

Logged


* July 13, 2012, 12:05:07 AM
#3
Sorry for delay in replying,

its difficult for me to comment with certainty as the only deluxe I've got is v16, so v14 may not show the same problems as I see in v16, but I don't think the red item is the problem, for example the groove leading to the red object I filled in with a box (thus eliminating the groove), I then added a new groove with smoother corners and fully formed end, the red item then subtracted without any problem.

If your v14 showe the same affect as i see in the two pics above, I'd suggest filling in the offending grooves and recutting them taking care to get the bends as smooth as possible, the pic below is what I see in v16 when sliced where the red object will be subtracted, and shows the previous groove isn't fully formed and has torn a hole in the side and I think this is what is causing the problem.

#edit# obviously if you try filling and recutting the grooves, do so on a copy of the file (save-as) so you retain your original, added pic of new groove (filled in using extruded polyline and the recut the groove), shows the red object has subtracted without problem, had to also re-subtract the long hole as filing in the groove also filled in part of the hole.  #end edit#

Andy  
« Last Edit: July 13, 2012, 01:57:47 AM by Andy H »

Logged


* July 13, 2012, 08:49:42 AM
#4
thanks for the help. but everytime i redraw it and try to subtract it i keep getting acis solid ie degrnerated...
i got a trial verson of 19pro but it seams to be harder to work with. u must ba a master with this program
thought i was on a roll until this problom thanks for the help i will keep trying

Logged


* July 13, 2012, 10:43:05 AM
#5
HI

Master - me - he he, no I'm not a master just been using it for a few years, if you could post the v19 file your getting the error with I can have a look at that,  if you post reply, select additional options and attach file.


Logged