TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Wine Glass
Read 2661 times
March 11, 2012, 04:34:45 PM
This should have been a simple drawing and render.
I drew it up to try out the different pre-sets in Softbox.
All was going well until I started rendering the model.

Memory overload, unhand-led exception, again and again.

The thing is that I don't think the problem is with Softbox.
I realised in all this that at least the last four or five models(before installing Softbox) that I have tried to render have all had the same problems to a point.

Running out of memory is not unusual for me but none of my recent models have been that complex.

Maybe it is something blatantly obvious that I'm over looking.
If anyone has any suggestions as to how I can sort this out I will be most appreciative.

I have posted the one render that I managed to get out of this model.
I have also added the TC18 file.

Many thanks in advance.
Dave
« Last Edit: March 12, 2012, 10:07:53 AM by Dave C »

Logged
Dave C
TC Pro V14.2 - TC 21 Platinum 64 Bit Build 22.3
Intel i-4770K 3.5GHz
120GB ssd 2TB hd
16GB memory
64bit Windows 7 Pro

www.ipernity.com/fizzyfitz


March 11, 2012, 05:02:49 PM
#1
Dave,

Are you trying to use Advanced Rendering "Clear Sky".......

If so, this will crash TC I have found, something I have mentioned in a post and Brad Easterday knows that the use of Soft shadows in his settings cause these out of memory problems......

Copy the luminance and try turning the shadows on some of the settings to hard...... also try reducing the number of samples which also gobble up memory...

Logged
Daz…

V2019 Plat 64bit, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.


* March 11, 2012, 11:01:42 PM
#2
Thanks Dave a lot fun to work with.
« Last Edit: March 12, 2012, 10:54:49 AM by wd »

Logged
Even a mistake may turn out to be the one thing necessary to a worthwhile achievement Henry Ford
If I have ever made any valuable discoveries it has been owing more to patient attention than to any other talent Isaac Newton
I have not failed Ive just found 10,000 ways that won't work Thomas Edison


March 12, 2012, 10:06:11 AM
#3
Are you trying to use Advanced Rendering "Clear Sky".......

If so, this will crash TC I have found, something I have mentioned in a post and Brad Easterday knows that the use of Soft shadows in his settings cause these out of memory problems......

Copy the luminance and try turning the shadows on some of the settings to hard...... also try reducing the number of samples which also gobble up memory...

Cheers Darrel,
Shame really because clear sky always gives a good render.
As for the rest.
Roll on 64bit.


Glad you liked it wd

Logged
Dave C
TC Pro V14.2 - TC 21 Platinum 64 Bit Build 22.3
Intel i-4770K 3.5GHz
120GB ssd 2TB hd
16GB memory
64bit Windows 7 Pro

www.ipernity.com/fizzyfitz


March 12, 2012, 06:18:16 PM
#4
Dave, I gave your file a try, but didn't get any OOM errors. I'm currently running a 32bit machine. Sometimes I wonder if 64bit machines have more trouble with OOMs running 32bit TurboCAD. The attached image is the resulting render.

I know the background and cloth are a bit lame, but this was just a test.  :) I changed up the cubical map a bit to help brighten up the glass. When using a cubical map from Softbox and rendering glass or surfaces with mirror like finishes it's a good idea to set the "Reflected shader" and "Refracted shader" to "Mixed" and use "Plain" and "Environment" as sub-shaders. With that setup you can mix in something other than a black background for reflections. I used white which helps lighten up the glass while still reflecting the studio lights. You can open up the RSE to see those changes.

You should be able to render the wine glass as is with Softbox installed on a 64bit machine. The attached file uses "Draft No Shadows" for Luminance. It'll render quickly for testing that way.

**Edit**
This is a Raytrace Full render.

Logged
BradE [ dean3Design ]
Core i7-3930K CPU @ 4.20GHz, 32GB 1333 DDR3, FirePro V5900
TC 21 Platinum (64-Bit) Running on Win7 Pro SP1


March 13, 2012, 12:20:44 AM
#5
Thanks Brad.
I still think part of the problem is with my machine though.

Last night I rebooted in safe mode to stop a lot of the background services and processes.
The task manager was showing a memory usage of around 1.5 gb of memory, usually my machine is running at over 3gb.

Running like this I was able to render at presentation level luminance in softbox with broad lighting plus fill, advanced daylight setting.
While rendering the image the memory usage didn't go above 2gb.
Only problem, I couldn't get into png settings to save the rendered image.

Need to sort out the start up services I guess.
Too much memory swallowed up in the background.
Raising the priority of TC in taskmanager seems to help a bit too.

Logged
Dave C
TC Pro V14.2 - TC 21 Platinum 64 Bit Build 22.3
Intel i-4770K 3.5GHz
120GB ssd 2TB hd
16GB memory
64bit Windows 7 Pro

www.ipernity.com/fizzyfitz