TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Remember to do a search before you ask a question!!!

Material Set not kept
Read 2653 times
* August 08, 2009, 11:58:29 PM

Material will not be kept on Save, exit and Load.

All the sides is set at "Paint Band - Brown Paint" But with a re-load it is gone. ( Block A - C )
Even if I set Block A at any different Material by "Set Material" it will not completely adjust but keeps the "Cement Pave - Paint Band" Setting when re-loaded
It just comes back to the current material with the "Cement Pave - Paint Band"

Why is it that the Material setting that is applied will not "stick" ?

[attachment deleted by admin]


* August 09, 2009, 01:13:17 AM

Just checked rest of dwg

All Material just was selected went crazy - it sets aon facets what ever TC wants - looks like it - even pattern on solids.

This is a Wall of Solids - It was "Cut" to suit the roof and previously had the same colour as the vertical walls as by "Set Material"
Suddenly it changes it to actually a "Patterned Facet" on the angled side. The Inside of the roof is a Solid color and not even patterned.

Why did this happen - a setting somewhere I do not know of ?

Another Simple Example

A. Block = Set Material
B. Set Drag on Facet & Save
C. Open Again and Material is gone.

What went wrong now ?

[attachment deleted by admin]
« Last Edit: August 09, 2009, 02:27:15 AM by triplex »


* August 09, 2009, 06:56:10 AM
re: Why is it that the Material setting that is applied will not "stick" ?

It may be a BUG.

If you use the Facet Editing tool, you can assign a material for the facet in the Properties dialog. The assigned material was still there when the drawing was reopened.

Another way would be to Explode your Part once so it becomes an ACISSolid, then drag-n-drop to the facet. Of course this will destroy the Part Tree info.

John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit

* August 09, 2009, 07:20:10 AM

TX again !

It is not a BUG - it is a H1N1 BUG. Heck of an effort to explode and then apply textures. No other way of overcoming this one ?

BUT - how come is it that all worked till this point and now starts with this BUG ?

Even now if I start a new file it have this BUG - can not understand it.

Will it help if I re- install ?

But where is the UI settings I have applied being in the File structure - I would like to save it and just copy it back.

This is a messy one - the worst of what I have seen of V16 - it is such a smooth release and now this.

The other one is the Push / Pull function - in tight corners it just bombs out - I sent a file to RIP where after such a bomb out the file just starts but give a CLOSE message with the fault report.

That is 2 x BUGS so far.


Re-installed Still the same.
But still a smooth TC till now - still impressed

« Last Edit: August 09, 2009, 08:19:58 AM by triplex »


* August 10, 2009, 03:42:40 PM
Just an update - RIP replied.

The reason for the Material problem is because the materials were set before a boalean subtract was done.
You have to select all facets, then set it to none and re-select in a problem like this.
I was a bit too fast to say it was a BUG. - it is not, just the way of workings.


* August 11, 2009, 10:03:42 AM
I'm glad Rip got it cleared up for you.

The best I could tell you would be to take two aspirins and call me in the morning. :-)))

John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit

* August 12, 2009, 11:28:33 AM

Yep - as I get to on this forum, you will want me to take 2 aspirins - but I stay up through the night to get to you with questions - I must ask as much as possible otherwise ther is no sleep - last night I stayed till 4.00 AM - You are the pro's and some things just baffles me.

But to the point - the material matter still get it shaken up - I send a file to RIP of a simple extrude that does it here.

To all - tx for the patience and help.