TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Problems with resetting tools
Read 1718 times
* April 26, 2011, 01:52:53 PM
Is anyone having a problem with tools getting "stuck" in V18? TCAD has always been quirkly because it doesn't end a function with ESC as is common in most programs. However, in past versions I found that if I clicked the selection button it would reset any tool.

This isn't always happening with TCAD V18. For example, I just spent about 15 minutes trying to make the Stretch tool work on a 2D rectangle. I had started as usual by clicking the Selection button and then clicking the Stretch button. Instead of seeing the crossing selector, a menu came up asking me to select a line, polygon and "None". This made no sense. I went to the User Manual to see if I was doing something wrong, but no, I should be seeing a crossing window. Where was the crossing window? If I selected one of the objects, it just moved the object instead of stretching. Finally I selected "none" and then I could get a crossing window but it still wouldn't stretch. I tried the whole procedure over and over several times, each time clicking the selection tool to reset it so that I could start over fresh. Finally, I looked at my tool icons and realized that "Line" was selected instead of Stretch or Select. This had been the command I was using prior to starting my struggle with the Stretch button. Apparently TCAD had been stuck on "Line"all this time instead of resetting. I started clicking other buttons to get it to go somewhere else and finally it got so I could click on Stretch and it would behave properly.

This isn't the first time this kind of thing has happened, although it usually only required me to go back once or twice to the Selection button.

Anybody have an idea what's happening or is having a similar problem?

Logged


* April 26, 2011, 02:44:39 PM
#1
Indeed that tool does act flaky at times.With 2d objects instead of selecting a mid point. What works some times is select the vertex and its snap activated and have your ortho mode on it will work little better.I can get it to stretch in both left and right directions on simple rectangle.The tool didn't give that much hassle in older versions.There has been few posting with concerns on its functionally.Maybe it can be user friendly in upcoming updates!

Logged
Even a mistake may turn out to be the one thing necessary to a worthwhile achievement Henry Ford
If I have ever made any valuable discoveries it has been owing more to patient attention than to any other talent Isaac Newton
I have not failed Ive just found 10,000 ways that won't work Thomas Edison


* April 26, 2011, 07:10:05 PM
#2
Yes, resetting tools is quite awkward with V18, I am also having great difficulty in customising my user interface, for example, when I customise my palletes, I can't get "ALIGN TO TOP" to be included within the "ALIGN" set, I have had so many more issues. I wonder if the V18 is a preliminary. Sometimes snap turns off or on by itself and so on. V17 did not have any of these issues. I have uninstalledd the app and reinstalled, I am having a hard time customising the UI, can anyone help please.

Logged


* April 27, 2011, 02:17:39 PM
#3
Well, if we're getting back to the bad old days before they had Russians rewrite the code, there will be 2 or 3 updated versions of this before they get the worst wonks out.

Logged


* April 29, 2011, 12:07:07 PM
#4
Yes, resetting tools is quite awkward with V18, I am also having great difficulty in customising my user interface, for example, when I customise my palletes, I can't get "ALIGN TO TOP" to be included within the "ALIGN" set, I have had so many more issues. I wonder if the V18 is a preliminary. Sometimes snap turns off or on by itself and so on. V17 did not have any of these issues. I have uninstalledd the app and reinstalled, I am having a hard time customising the UI, can anyone help please.

"Align to Top" was left out of the "Align" tools in the "Default" workspace. You can call up the toolbar, then go to the Commands page and look up the tool at the "Format / Align" category. Drag-n-drop it into the toolbar. The tool should now appear in the Tools palette. Save your changes to your custom Workspace.
When building a new Workspace, I would use the "1024x768pro" configuration as a basis; the "Default" configuration needs a lot of help.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


* May 03, 2011, 05:47:22 PM
#5
Thank you, this helped resolve my issue and you are right, the default menu does need a lot of help. Unfortunatley saving it this way has overwritten my previously customised UI, the good side to this is that I can start again with all my tools running. Thanks again.

Logged