TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Extruding
Read 2059 times
* December 26, 2010, 10:30:53 AM
I am doing some projects that have arcs and cylinders that I am wanting to extrude. When I extrude them the arcs are not smooth they are a series of straight edges and not a smooth arc. I have tried to use the 3D cylinder but it is the same. My extrudes are small enough that the arc appears as 3 flat edges. I only view these in hidden line render.
  Myron TC17.2Pro

Logged


December 26, 2010, 10:46:00 AM
#1
Set your ASICS Faceter mode to quality instead of draft

Logged
TurboCAD user since v3
 TurboCAD on flickr || My twitter ||


* December 26, 2010, 10:51:56 AM
#2
If you're just doing a surface object, select the object, bring up properties, and in the TC surface options increase the number of approximation lines.

Logged
TCW Pro 14.2
TC Deluxe 16.2 Build 53.2


* December 26, 2010, 10:56:14 AM
#3
Along with Kmartins advice.... turn off Degenerative Faceting.
« Last Edit: December 26, 2010, 02:40:13 PM by Don »

Logged


* December 26, 2010, 03:38:39 PM
#4
I have tried your advice and the object still appears as 3 flat spots. I am making some symbols for garage doors that have 6" arch tops. The frame sides and top are 2" wide and 6" deep. It is for a 16'x7' garage door. The finished frame looks like 3-4' flat spots. Is this the best I can expect from an ACIS solid representation.
  Myron

Logged


* December 26, 2010, 04:46:18 PM
#5
Why don't you upload your file so the gurus here can look at it?

Logged
TCW Pro 14.2
TC Deluxe 16.2 Build 53.2


* December 27, 2010, 09:24:13 AM
#6
I have attached a couple of examples of the symbols. The Degenerative faceting is unchecked and faceter mode is set to draft.
  Myron

Logged


* December 27, 2010, 10:39:05 AM
#7
I have attached a couple of examples of the symbols. The Degenerative faceting is unchecked and faceter mode is set to draft.
  Myron

You have two ways (at least) to smooth out those facets:

1) Redraw the profiles, using Splines instead of arcs for the curves. See "Arcs vs Splines.jpg," attached herewith.

2) Use "Custom" Faceter Mode. See "Quality vs Custom.jpg." You may have to delete the extrusion and then Undo the deletion in order for the change in Faceter Mode to take effect -- or you might even have to delete the extrusion and then re-create it. When fiddling with "Custom," change only one of the variables and leave the other two at their default values.

Henry H

Logged


* December 30, 2010, 06:11:11 PM
#8
Thanks for the help, I will give them a try.
  Myron

Logged