TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Avoiding crashes with large renders
Read 3939 times
* May 30, 2009, 08:17:00 PM
I have a model that GFPs if I render it. The model was built from components in separate files. I can render the objects in the separate files.

I thought that I would create a view I wanted to make. Make one component at a time visible. Render. Then reassemble in photoshot.

GPFs. It seems to take about the same amount of time to crash and uses the same amount of memory as with everything visible.

Any ideas how to get around this?


Logged


* May 30, 2009, 08:54:19 PM
#1
Try this: When the stuff you do not want to render is tucked away on hidden layers, press Ctrl+A to select what's visible -- THEN render. Press Esc to deselect it after the screen renders. I think this will prevent Genie from processing the items on the hidden layers.

Henry H

Logged


* June 03, 2009, 12:44:20 PM
#2
Good idea....but did not work. Still crasheth.

Logged


* June 03, 2009, 06:53:47 PM
#3
I tried saving the file multiple times in the desired view, then deleting everything except enough to render the file.

Too much of a PITA. The views get screwed up and do not match.

Logged


* June 03, 2009, 09:02:26 PM
#4
Here's another idea, which I've used once or twice: Render only the stuff most distant from the camera; take a screenshot, then paste it into a photo editor and save it as a .jpg. Back in TCad, create and set a new Environment using "Image" Background, with the aforementioned .jpg; render another set of objects closer to the camera against this background. If there are still more objects to be rendered, take another screenshot and make another new Environment with it, and render the next set of objects. Be sure not to move the camera during this entire process.

Henry H

Logged


* June 03, 2009, 10:02:33 PM
#5
re: Be sure not to move the camera during this entire process.

How about a Named View to return to, in case the view gets moved for whatever reason?

John R.


Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* June 04, 2009, 11:24:42 AM
#6
re: Be sure not to move the camera during this entire process.

How about a Named View to return to, in case the view gets moved for whatever reason?

John R.



SADS. Of course!

Henry H

Logged


* June 07, 2009, 11:32:34 PM
#7
This just a nightmare. Click on render button, while doing so. image scrolls. Switch to my named view. The image comes up all black. Go back to to wireframe. Manage to get a render without shifting. Try saving as a JPG. "Failed to save".

Simply ridiculous.

Logged


June 08, 2009, 03:52:14 AM
#8
I don't know if this will help.

I found a while back that if you break the drawing down into as many layers as possible it will sometimes render and save the image without crashing.

Not a guaranteed cure though.

Regards

Dave
« Last Edit: June 08, 2009, 03:53:59 AM by Troubled »

Logged
Dave C
TC Pro V14.2 - TC 21 Platinum 64 Bit Build 22.3
Intel i-4770K 3.5GHz
120GB ssd 2TB hd
16GB memory
64bit Windows 7 Pro

www.ipernity.com/fizzyfitz