TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Sweep - solid edge - profile inversion
Read 802 times
* November 15, 2019, 04:17:10 AM
I attach a copy of the file with which I am having problems.

I have constructed an arcuate sweep with a triangular cross section.  I
need to form a layer (septre membrane} closely overlying two surfaces of the triangular
sweep (called a septre for these purposes).  To that end  I have formed
a sweep membrane template, a "V" shaped region at one end of the
sceptre.  When I seek to sweep the template along an arcuate edge of the
sceptre I get an inverted V shape, not at all what I require.  It does
not matter which edge I seek to sweep along I get the same inside out
shape every time.

I have tried deleting the built in folder to no avail.  I have otherwise
rebooted and updated the OS and "repaired" Turbocad.

I am running Windows 10 Pro version 1903 OS18362.476 on a Lenovo E540 with
Intel core i5 4200M CPU and 16Gb RAM.  Turbocad is pro platinum 2019 version 26 build 37.4

Logged


* November 15, 2019, 08:07:09 AM
#1
Is Attached what you want to achive ?
I did exlode your Acis so i could get the "circle" to follow, made a 3 pont circle and trim it, guess i could have used a 3 point arc aswell, moved the arc to M on the triangle and sweep work like a charm when i use the arc as a path.
You can use section tool also to get the profile, but i dont need the rest of the solid so … :)
Red is Path, Blue is membrane

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


November 16, 2019, 04:07:46 AM
#2
I have noticed that the orientation of the swept object has an effect on the result.  Try selecting it and rotating it 90° in one of the axes before the sweeo to see how that changes your results.  You may have to undo and try with another axis.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1