TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Rail Sweep not working correctly
Read 1543 times
* August 27, 2019, 07:43:25 AM
Greetings to all,

First things first. My configuration is as follows:
TC Pro Platinum 2018 64 bit
PC with AMD Phenom II X6 1090T Processor 3.20 GHz
Windows 10 64-bit OS with 20 GB installed memory

I'm having trouble with the Rail Sweep function.
Issues:
I have a cylinder that I'm trying to create cavities to hold wires for wire management on my home built CNC machine. There is more to the part than what is in the attached file. I just sent the parts that I'm having trouble with.

1. The first time I used the rail sweep (RS) it worked as I expected it to. However, the following times the sweep is shifted by the radius of the circle I'm trying sweep. In other words, I have a large circle, the sweep path, and a smaller circle, the entity to sweep. When the sweep is completed the sweep is shifted to the left of the path, by the width of the smaller circle. Don't understand why the sweep no longer follows the sweep path.

2. I need an opening on the top of the sweep to "press" the wires through. The wires will then be held in place with the friction necessary to press them through the opening. I wanted to use a rectangle and sweep the same path but the sweep is not completed. Hopefully, this will make a little more sense when you look at the file.

The cylinder will cut in half the long way and thus allowing the wires to be managed by the part. The part will be used to direct wires from the stepper motors and limit sensors from the Z-Axis into the drag chain.

Thanks for any help you can offer me.

Regards,

Rod

Logged
Rod

TurboCAD Pro Platinum V21, 2018
Windows 10 Professional 64-bit Operating System
Dual Monitors
AMD Phenom II X6 1090T processor 3.20 GHz
20.00 GB installed memory
1 Terabyte of  storage


* August 27, 2019, 08:26:29 AM
#1
Have you try'd to use Sweep instead of Rail Sweep, it's more easy to Control

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* August 27, 2019, 09:54:11 AM
#2
Torfinn,

I had not tried Sweep. I just tried it and it worked perfectly. Thanks!!

Rod

Logged
Rod

TurboCAD Pro Platinum V21, 2018
Windows 10 Professional 64-bit Operating System
Dual Monitors
AMD Phenom II X6 1090T processor 3.20 GHz
20.00 GB installed memory
1 Terabyte of  storage


* August 27, 2019, 10:00:20 AM
#3
Have you considered using the Revolve tool and spinning the Rectangle along an axis that runs in the middle of those objects? You should place the 2D objects on the same plane, as they're all on different workplanes.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit