TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Remember to do a search before you ask a question!!!

Why is Macro Recorder not working?
Read 1742 times
June 30, 2019, 05:40:17 AM
I tried the Macro Recorder (again).  The few times I've tried it before, I was obviously asking too much of it, but this was comparatively simple.

I imported a PDF conversion of a Gerber file (for printed circuit board layout) that had the holes, pads and traces.  I wanted to get rid of everything but the holes.  The Select by Similar function worked fine (could be improved, but that's another post), but took 4 key strokes to maneuver through the menu hierarchy to the function and to press the <Delete> key after they were selected.  Seems simple enough to record a macro to do that, right?

However, when I did that and played it back, the selected object (the 'reference' to finding all the similar objects) just changed to remove its fill.  The other, similar, objects did not select and were not deleted.

I tried recording this macro two ways, keyboard and mouse.  Each failed.

Any advice on what I'm doing wrong?


TC Pro Platinum 2020, 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1