TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


clip Raster Image
Read 2023 times
May 27, 2019, 06:17:48 AM
A problem I have found with a tool I have not used for a while.  I imported an image and drew a Spline by control points on it and closed it.  II clicked the Clip tool and Status Bar said to select the Image and I did by clicking the edge.  The spline disappeared  so no clipping.

So I trawled these pages and low and behold I asked the same question in 2012 and the answer then was to explode the spline once and that worked then.

It did not today.  Any body an idea what changed?

Logged
regards
Colin Reid
TC2018 Pro Platinum 64 bit  + LW plugin on Win10 desktop and  Quad Intel i7 with 32GB RAM + 128GB  SSD and 2TB partitioned hard disk, NVidia 2GB video


* May 27, 2019, 06:32:19 AM
#1
It works here, draw a closed shape with Spline by Control point, esc to exit tool, explode to polyline, Select Clip tool, Select pic and then the polyline.
The polyline get hide by the pic so i need to remember about where the polyline was to click on it.

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 27, 2019, 06:48:52 PM
#2
I couldn't make it work either, at first. The trick, as Torfinn sez, is to explode the Spline into a Polyline.

Henry H

Logged


* May 27, 2019, 08:13:40 PM
#3
You can use a Spline to clip a Viewport, but not an Image.
Use a polyline or circle/ellipse to clip an Image.
« Last Edit: May 27, 2019, 08:20:21 PM by John R »

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


May 28, 2019, 06:04:19 AM
#4
Thanks all as the combination of Henry and Torfinn got it right but hiding the cut line when the Clip Raster is selected is obviously the new and bloody irritating "improvement". 

Logged
regards
Colin Reid
TC2018 Pro Platinum 64 bit  + LW plugin on Win10 desktop and  Quad Intel i7 with 32GB RAM + 128GB  SSD and 2TB partitioned hard disk, NVidia 2GB video


* May 28, 2019, 09:42:04 AM
#5
Thanks all as the combination of Henry and Torfinn got it right but hiding the cut line when the Clip Raster is selected is obviously the new and bloody irritating "improvement".

True, but try adjusting the Image Transparency so the polyline is visible >

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


* May 28, 2019, 12:12:15 PM
#6
Thanks all as the combination of Henry and Torfinn got it right but hiding the cut line when the Clip Raster is selected is obviously the new and bloody irritating "improvement".

True, but try adjusting the Image Transparency so the polyline is visible >

How? I tried that and couldn't make it work.

Henry H

Logged


* May 28, 2019, 12:18:22 PM
#7
Set the transparancy to 50 pluss % and the polyline will show, cumbersome, but do work.
And then set it back to 0 % afterwards i assume.
Luckily my short time memory still work :))

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 28, 2019, 01:41:27 PM
#8
Set the transparancy to 50 pluss % and the polyline will show, cumbersome, but do work.
And then set it back to 0 % afterwards i assume.
Luckily my short time memory still work :))

Torfinn

How do you set the transparency?

Aha! In the Selection Info palette.

Henry H
« Last Edit: May 28, 2019, 01:44:42 PM by Henry Hubich »

Logged


* May 28, 2019, 01:47:14 PM
#9
In the pic's Property

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB