TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Can't find Part Tree v11 Professional - With Picture
Read 1745 times
* May 25, 2019, 07:35:08 AM
Hello,
TurboCAD v11 Professional

Can't find Part Tree.   Looked under ACIS and everywhere else I could think of.   Almost seems it wasn't installed.
Can someone tell me how to Activate / Find it?

The User Guide says go to  MENU: View / Part Tree Palette........but it is not there
When I click on Selection Info, it seems to pop up on the extreme Right but no parts are ever added and all the options are grayed out.   Maybe I haven't activated something.  Here's what my toolbar looks like.   No option to activate part Tree?



Thanks much
« Last Edit: May 25, 2019, 08:00:21 AM by CapricornOne »

Logged
TurboCAD v11 Professional


* May 25, 2019, 08:01:05 AM
#1
In my v11 pro installation, it is available in the view menu along with all the other palettes.  in V11 it is a separate palette to the selection info palette. which may seem odd if one is used to a more modern version of TC.  It could also be a bit temperamental in older versions.

It only shows Items when there is some valid History.  (it won't show 2D).   For example if one adds two boxes, then select the result, the history will show up.   However, if one carries out an operation which destroys the history (explode, facet edit etc.). nothing will show up except the name of the object..
« Last Edit: May 25, 2019, 08:04:06 AM by Andy H »

Logged


* May 25, 2019, 08:14:35 AM
#2
Image added from my v11 installation.   if Nothing shows in the palette after doing a simple Boolean, check if the part tree is activated before any Boolean is carried out.

Logged


* May 25, 2019, 09:43:39 AM
#3
Andy,
Thank you VERY much for taking to the time to post that.

I'm thinking my installation may not have installed correctly now because I do not even have the Icon to Activate the part Tree as you do.  Also, in your image at the top, your image shows the Part Tree in the list, on my install there is no listing for the Part Tree.

I'm wondering if there's an option to include it during install and maybe I failed to select yes to that option?

Logged
TurboCAD v11 Professional


* May 25, 2019, 10:50:33 AM
#4
Do you have the SDK stuff on the menu bar.

In older versions, when installing. One used to get an option for Full install, or compact install. (or some words like that).  If I remember correctly, if the full install was not done, the SDK stuff was not installed. But I don't know what other things were left out.   I always did a full install.  I just checked windows Xp, Win 7 and Win 10. all show the part tree palette.

Maybe time for a clean install.

Logged


* May 25, 2019, 01:22:53 PM
#5
Do you have the SDK stuff on the menu bar.

In older versions, when installing. One used to get an option for Full install, or compact install. (or some words like that).  If I remember correctly, if the full install was not done, the SDK stuff was not installed. But I don't know what other things were left out.   I always did a full install.  I just checked windows Xp, Win 7 and Win 10. all show the part tree palette.

Maybe time for a clean install.

Hello again Andy,
I "think" I may have figured out what's wrong. 
I'm installing v11 Pro on windows10.
It seems windows10 does not want to install certain options even though they are selected in the Install dialog.
On Windows 7 it seems to work fine.

I may play around with the Administrative rights and Compatibility.
But it may be that I need a Windows 7 machine to get the tool pallette to work.

Oddly, other than that, everything else seems to work (No SDK), but I can design drawings just fine.

Logged
TurboCAD v11 Professional


* May 25, 2019, 01:45:23 PM
#6
After trying compatibility modes and giving Administrative rights, it seems v11 cannot use the Parts Tools or SDK under Windows10

Logged
TurboCAD v11 Professional


* May 25, 2019, 02:59:31 PM
#7
Possibly a specific windows 10 version.  I'm still using windows 10 version 1803. (it never got updated 1809). The TC v11 used was 11.0,  I didn't try patching it.  As I only put in on a while ago to check and old bit of vba 

Logged