TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Scale of drawing change dramatically with when I just bump the mouse
Read 457 times
* May 03, 2019, 10:42:14 AM
I have TC Deluxe 2018 64bit. I operate on a Win 10 machine. My keyboard is a Logitech G910 and my mouse is a Logitech G502.

When I have a drawing open and working on it sometimes I have to pick up the mouse and move it to where I can get back on my mouse pad to continue working.  The problem is that sometimes when I set the mouse back down the scale will change DRAMATICALLY.  I am not touching any buttons or the wheel of the mouse. It seems that even just bumping the mouse (not touching the wheel or buttons) will cause the scale to zoom out from say 1"=1" to 1" = 1000'. I then must, carefully, locate my drawing and zoom in so I can get back to work. Any slight jarring of the mouse can cause this to happen. Just setting the mouse down can cause this to happen.

I have done the following.
1. Deleted and reinstalled current mouse driver.
2. Checked every setting I can find concerning the mouse
3. Started a complete new drawing with all default values
4. Searched internet for any possible solutions.

Any ideas of what is going on and how to fix it.

Logged


May 03, 2019, 11:36:25 AM
#1
Hi,

    firstly, welcome to the forum.
    I would suggest trying a new/different mouse, before doing anything else.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.476) 64-bit


May 03, 2019, 04:45:31 PM
#2
I have the exact same problem with my mouse (Logitech MX Master) when the wheel is free-spinning.  I can stop that from happening by engaging the Click Stop function on the wheel.  It is possible to set this to be automatically engaged when the TurboCAD window is active on the Logitech products; you may have the same ability with your mouse.


Jeff
« Last Edit: May 05, 2019, 01:55:10 PM by Jeffin90620 »

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* May 03, 2019, 05:31:42 PM
#3
Hi, I am NO power user but have experienced these issues which I think are more Win10/Mouse combo than a TC issue.  I use a Logitech MX Master mouse which I upgraded to having experienced similar issues with my earlier 'intellimouse'.   I find, that no matter what I do the mouse is far too sensitive for scrolling, zooming etc in many programs.  No matter what mouse setting I use it is the same - I found this all started when Microsoft (in their infinite wisdom that their way is always best) introduced those auto maximise feature where the window snaps to full screen mode when you approach the edges -yes, I know it can be turned off but the issues seem to have started with those 'enhancements' to Windows Operating System (OS).  I find that in some programs simply hovering the mouse (optical read) is enough to make the panning and scrolling go nuts.  I am finding that this happens to a greater degree in MS products such as MS Excel, Word etc where the mouse just seems to take on a mind of its own at times.

I don't think changing the mouse will make that much of a difference, but still may be worth exploring.  However, if you have a similar level of control of the mouse as Logitech provides, I would try the setting it up for specific programs as Jeff has suggested.

There is however a 'device' control section at the bottom of the Tools-Workspace-customise - dialog box.  In this you can add (sometimes auto added depending on the device) other input devices and set some basic control over what some of the controls do - I have set mine to zoom in /out with the wheel and use the keyboard keys to scroll up/down ad across.  I would try that area first to see if it helps to change the behaviour of the mouse, but again (if it is an optical read type mouse your are using) than the real issue is probably in the driver or OS - I have not been able to determine which yet but my leanings are to the OS.

good luck

Pat
« Last Edit: May 03, 2019, 05:38:43 PM by PatM »

Logged
TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.


* May 05, 2019, 12:40:49 PM
#4
Thank you Jeffin90620. The free wheel was the problem.  I never noticed when I changed it.  There is a little button just behind the scroll wheel that changes it from click to free wheel.


Thanks again.

Logged