TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Adding Sound Example 2
Read 524 times
April 22, 2019, 09:28:35 AM
Adding sound to TurboCAD animations can be a bit hit and miss, as the help file
is limited in this respect.  So, using trivial examples, here are a few pointers
which might help.

Adding sound, using AnimationLab, is achieved using the Key Frames Editor only.

1.  A sound file, in .WAV format, is attached to a keyframe of an actor, using
Key Frame Properties (double-click on a keyframe to open, select Ctrl+F or left-
click on Switch to Scenario Script Editor Mode button, and hold).

2.  The actor may be stationary, moving or invisible.  DO NOT use the Key Frame
Editor in combination with the Scenario Script Editor Commands (for the same
actor).



        Example 2

Open file Box-1.tcw (attached).

The box is simply animated, using the Key Frame Editor, from frame 0(zero) to
frame 59 (60 in all), along a straight path.

Each circle actor, Circle sound-2 and Circle sound-3, are linear copies of
Circle sound-1.

Using duplicates of one actor, it is possible to use differing .WAV files
initially (attached).  This simplifies moving of the individual sounds along the
time-line, until you are happy with the final arrangement.  It is more reliable,
sound-wise, to NOT overlap each sound (see attached).

If you have ticked Save sound scene as WAV file:  which is under AnimationLab
Options/Sounds, and unticked Delete added sound file, found under AnimationLab
Options/Movie, you should then have one .WAV file, with all your separate sound
files combined into one continuous whole, after running through the animation
Scenario.  This can be used to replace the multiple WAV files, for the final
rendering of your animation (see Adding Sound Example 3).  The choice is yours.
« Last Edit: April 23, 2019, 11:36:38 PM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.418) 64-bit


April 24, 2019, 04:00:24 PM
#1
I'm positive that the first sound is the Star Trek door sound.  ;)


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


April 24, 2019, 11:28:44 PM
#2
Jeff,

    well spotted.  I guess, a clue might be in the name.  :)

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.418) 64-bit


April 25, 2019, 05:19:48 AM
#3
What I meant was, the three sounds in the file were listed in an incorrect order.  The Star Trek door sound was first, not second.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


April 25, 2019, 06:47:55 AM
#4
Jeff,

    yes, you are correct. 
    But, the point of this stage, is that you can put them in any order you like. 
    So, you can mix and match the play order to suit your needs, regardless of the numbering or name chosen.

I hope this helps.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.418) 64-bit


* April 25, 2019, 07:52:03 AM
#5
Thanks for the example Tim. 

What is strange, is that it works fine on my computer.  It is strange because your original Disco one didn't work for me.  And I'm guessing you used the same settings for both, so I just tried the Disco again.  And it worked.   Either Windows 10 updated itself again and repaired something it had previously broken in another update.  or I have a conflict with another program.  Ah well.  At least I know my TC and AL are not broken. 

Logged


April 25, 2019, 08:35:58 AM
#6
Andy,

the only real differences are that the Disco sound file needs the Sound Type to be selected as Point, rather than Ambient, which works for the other sound types. 
Don't ask me why, I just use what works.

The coding in AniLab could be improved, but it works well enough, once you get the hang of it.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro 1903 (Build 18362.418) 64-bit