TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

All posts discussing pricing or where to buy TurboCAD will be deleted.

TurboCad 2018 Plat Insert Thread3D and Parametric HexBolt do not work
Read 665 times
* March 23, 2019, 09:38:26 PM
This has been an ongoing problem with this tool since Version 16 and has still not been resolved. Very disappointed!
Have tried all the suggestion on the forum to no avail.
Does anyone have a work around?
Also the Parametric HexBolt symbols give the following error: Regen error: Active X component can't create object.
Does anyone experience the same problem or know of a solution?


* March 24, 2019, 12:42:30 AM
Just tried the Thread3D and it worked OK for me, that said I tend to use the Thread tool (The 3D objects one not the SDK/Add-on).  I also tried the parametric symbols (both 2d and 3dwhich also worked OK. 

Obviously I don't know what you have already tried, so.  This is just  guess, but. I am wondering if its a permission thing.  Some ActiveX stuff can be blocked by Windows, if not in Admin mode.  so wondered if you are running as Admin, or if you have multiple users set to a slightly restricted UAC (user account control).   Have you tired running TC in Admin mode (set in MS windows),  or tried re-installing the symbols as Admin.   

I have no idea if the above will make any difference, as I am the sole computer user and automatically set as Admin, even though I don't install TC etc. as Amin.



* March 24, 2019, 03:44:50 AM
Thanks Andy,

Your suggestion re: Administrator Login has worked for the Active X problem. Many thanks for that. Unfortunately I still have the problem with the Thread 3D tool (Disappearing object).