TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Autosaves and backups
Read 5765 times
* November 08, 2009, 10:30:19 AM
I have worked my way  almost all the way through Don Cheke's Helical Tri-Lobe Blower tutorial when Turbocad crashed. Sadly I had not kept any deliberate backups, relying on the autosave on Options - Program Setup being ticked and set to save every 10 minutes. I located a directory on C:\Turbocad 16\Autosaves, but it was completely empty. The main directory (I have used C:\Projects\Tutorials\Blower) has a file dated and timed about 10 minutes before it crashed, but it contains exactly what I saved on Friday Evening.

Questions are:

Is there any hope for backups anywhere else?
How have I gone wrong in setting up autosaving?
If autosaving is fragile is there any other good policy than remembering to save with different names every half hour?
« Last Edit: November 08, 2009, 10:33:36 AM by snowman »

Logged


* November 08, 2009, 10:51:28 AM
#1
Found it, Turbocad had another copy which I had to use the command prompt to find (dir autosave.* /as) as Windows search only found the one I mentioned earlier.

Whew

Logged


* November 08, 2009, 11:35:35 AM
#2
FWIW,  when I'm working through these tutorials I've made it a habit to 'Save As ' every few pages and simply call the file name whatever the page # is.
The Helical Blower was saved with 32 separate file names.

Don.

Logged


* February 24, 2010, 06:50:28 AM
#3
I am running with Turbo Cad 15.2 on Windows Vista. I recently updated to the latest version (15.2). It appears  autosave stopped writing files to the C:\Users\dg.....\Documents\TurboCAD 15\AutoSave. It appears this stopped about the time I updated (based on the file modification date). I cannot find any posting to indicate a fix/work around for this problem. Searched for "autosave" did not find any other dir.  I have attempted to change the "Save drawing every" from the default to 1 minute, no change.

Any help would be greatly appreciated.

Update:
I am monitoring the Autosave dir, it is still empty, however on one occasion the file name appeared for a second and then disappeared.
« Last Edit: February 24, 2010, 02:42:53 PM by dgossman »

Logged


February 24, 2010, 05:33:55 PM
#4
Go into Program Setup under Options and check where TC has defined AutoSave under File Locations.  You can double-click on "AutoSave Files", then check the actual path under "Look In:" in the popup.

Jeff


Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* February 27, 2010, 07:55:29 AM
#5
Thanks for the update.

The auto back ups are not at the location specified in "Options-Auto saves".

TurboCad attempts to save (becomes busy every few minutes), but the autosave file does not appear.

I run my system 24hours per day, with TurboCad active all the time, still no autosave files. A search by file name yields nothing. Earlier I moved the old files (prior to the latest update) to different directory, those files show up on the search, but no new autosave files.

Logged


February 27, 2010, 02:26:22 PM
#6
Use Windows Search to find all files created on your computer in the last day.  Be sure to select the options for hidden files and folders and that you are searching all the hard disks in your system (that will be one of the selection options).

I wonder if you have a computer that has separate login accounts (a named, non-administrative account and the default "Administrator").  If so, log in as Administrator and do the search from there.

Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* February 27, 2010, 03:41:10 PM
#7
First Point: I did a search of entire disk, looking at all files created today, on the system disk (C:, only disk on the system) no autosave files. I tried with a date of known autosave files and found them.

Second point: The login account is user and adminstrator.

Thanks for the assistance.

Logged