TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Turbocad V16 Deluxe onto Windows 10 COmputer
Read 599 times
* February 14, 2019, 10:47:05 AM
Apologies if this is not the right forum. I have searched the forums.

I have loaded Turbocad V16 De Luxe onto my Windows 10 computer. It runs fine on  my old computer under Windows 7 . The desktop is clunky and the drawing very pixilated is there anything I can look to do to improve things in the short time. I don't want to upgrade at this moment.

I feel it may be a driver issue

Thanks for looking.

David

Logged
User of Turbocad for more than 10 years. Currently using V16.2 De Luxe. Build 53.2 on Vista, Windows 7 and Windows 10 computers. (One at a time).


* February 14, 2019, 11:42:18 AM
#1
I assume you mean v16 and not 2016.   I have v16 deluxe running on windows 10, though with the odd problem,  I set it to run with compatibility as XP sp3.   Right click the TC icon, or find the tcw16.exe in program files x86 - imsidesign - tcw16 - Program folder, and change the compatibility.  To be honest, I cannot remember why I set it this way to begin with,  there must have been some sort of problem but I cannot remember what.

No guarantees but worth a try.

Logged


* February 14, 2019, 12:08:53 PM
#2
Thanks Andy.
Yes V16 De Luxe. I' very new to Win 10, is there an option to run in XP mode within Win 10? I thought it had been done away with after Win 7. Would be useful if the option is there. I have an even older program that I need to run.
.
I will have a look.
« Last Edit: February 14, 2019, 12:24:45 PM by David869 »

Logged
User of Turbocad for more than 10 years. Currently using V16.2 De Luxe. Build 53.2 on Vista, Windows 7 and Windows 10 computers. (One at a time).


* February 14, 2019, 12:37:35 PM
#3
I think it depends on the program.

if its a 64 bit program then xp mode won't be available, but a 32 bit program like v16 should show xp mode.  that said you could always try windows 7 mode compatibility.  (after right clicking the icon, choose properties, then compatibility).

Logged