TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Draw a simple pipe
Read 751 times
January 21, 2019, 07:50:20 PM
I needed to draw a 12" piece of 1.75 diameter pipe with 1/16" wall. Extrude, sweep do not make a pipe. How using TurboCAD do you draw a pipe with wall thickness, a pipe that has sides but when viewed from the end you can see thru?
   

Logged
TurboCad V12~V201x Platinum Pro Edition + CAM Plug-In +  Surface Modeling + Survey Coordinates RedSDK
Production: W10 Pro V 1903 16GB NVIDIA Quadro


* January 21, 2019, 08:10:19 PM
#1
Draw two concentric circles; 1.75 & 1.625. Activate the Simple Extrude tool and the "Use Compound Profile". Hold the "Shift" key and select both circles and extrude.

Another option to try is extrude just the 1.75 circle, then select the extrusion and go to the Selection Info palette and give the "Offset" option a 1/16" setting. It will offset into the extrusion. Sweep and Rigid Sweep also has an Offset setting.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* January 21, 2019, 08:24:20 PM
#2
A 3rd option is to use the "Shell" tool. Select the solid 'pipe', then highlight both ends of the pipe and Finish. Good for when you have several pipes welded together.
EDIT: Here's a 3D PDF of the picture.
« Last Edit: January 21, 2019, 08:53:44 PM by John R »

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


February 07, 2019, 10:41:14 PM
#3
Draw two concentric circles; 1.75 & 1.625. Activate the Simple Extrude tool and the "Use Compound Profile". Hold the "Shift" key and select both circles and extrude.

Another option to try is extrude just the 1.75 circle, then select the extrusion and go to the Selection Info palette and give the "Offset" option a 1/16" setting. It will offset into the extrusion. Sweep and Rigid Sweep also has an Offset setting.
I keep turning on Auto use compound profile....

Then I was getting a wireframe warning message that is not in the warning message pallet. I looked around but couldn't find 'wireframe' settings

Logged
TurboCad V12~V201x Platinum Pro Edition + CAM Plug-In +  Surface Modeling + Survey Coordinates RedSDK
Production: W10 Pro V 1903 16GB NVIDIA Quadro


February 08, 2019, 12:46:28 AM
#4
Kevin,

    to remove this warning dialogue, untick option to display Nonrenderable objects (see attachment).

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.