TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Changed to HP6975 printer now can't print a View. Print options not functional
Read 1622 times
* April 18, 2018, 11:10:13 AM
I recently switched to a HP6975 printer, and when I hit "print' a different printer screen appears which does not have the View selections, , so I cannot select a view, so I cannot print a View. I can print the whole worksheet on an 8 1/2 X 11 sheet, but I want to print the detail parts on individual sheets , and I cannot. This occurs both on Turbocad deluxe 2017 and Turbocad deluxe 2015 ( which I have used for years and had worked OK until my old HP all-in-one printer broke, and I got this new printer).
In addition, the Print Options screen is no longer dark background as it was prior to this new printer, and the Page setup, Full Preview and Print Queue buttons do not operate. There is a portion of the Number of copies block sitting at the top edge of the Full Preview buttons. It appears that Turbocad is not compatible with this new printer.

any suggestions?

I just updated my HP software, and checked the action on my TCAD Deluxe 2015, and it still does not allow me to select a View in the Print screen.

I can post a screen grab of the new print options screen if someone can tell me how.


« Last Edit: April 18, 2018, 12:54:14 PM by powderbrake »

Logged
Jerry E.


* April 19, 2018, 03:28:51 AM
#1
I have a similar issue with my HP printer - it works in the 32 bit version though.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


May 09, 2018, 05:27:44 PM
#2
I recently switched to a HP6975 printer, and when I hit "print' a different printer screen appears which does not have the View selections, , so I cannot select a view, so I cannot print a View...

any suggestions?

My suggestion is to load the free PDF Printer Driver CutePDF.  Print to it as your default device, then print the PDFs to a physical printer as needed.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* July 04, 2018, 07:48:58 AM
#3
Printing via CutePDF is a good workaround, but I was hoping for a real resolution of the issue.  For years I have used an older version (V16) of TurboCad 2D designer and printed my work out on an HP7500A wide-format printer without issue, usually by selecting a Named View when the print dialog box came up.  Easy as pie.

Unfortunately, the 7500A gave up after about 8 years (go figure), so I recently bought an HP7720 wide-format as a replacement.  Install went off without a hitch.  But when I try to print any of my existing (or newly created) TurboCad files, there are no views (Named, Current or otherwise) available for print, even though they are all available for modelspace or paperspace.  Just a blank “down arrow” box.  I downloaded and installed the TurboCad 2D Designer 2018 version (32-bit) trial version, but that made no difference.

Anyone have any idea what the issue is and how to remedy?

Tom

Logged


* July 04, 2018, 05:03:55 PM
#4

Anyone have any idea what the issue is and how to remedy?

Sounds like a HP software issue .... Compatibility of what ever Windows version you have.

You could try the following ...
Download the print driver of a different manufacturers printer >>> IE Cannon / Brother / etc
Select it as your Default printer.
Set up the page >> and see if all the "there are views (Named, Current or otherwise) available for print"

If it is successful >> Either Email HP support ... or dump the HP & buy the printer that works.

Cheers
Mike




Logged


* July 05, 2018, 09:06:56 AM
#5
Sounds like a HP software issue .... Compatibility of what ever Windows version you have.

Sorry for including a reference to my OS (it's Win 10 home)

I'll try an "other brand" driver install in the next day or so and see what results.  I'll report back.  Thanks.

Tom

Logged


* February 18, 2019, 02:17:17 PM
#6
Well it's been about six months since my last entry and I thought I would add some progress on this issue of previously created views no longer appearing after I replaced my old HP7500A wide-format with the newer HP7720 wide format.  The technical support folks at TurboCAD were attentive, but were unable to fully resolve the issue.  Similar to what one of the earlier posters suggested, TCad Support only got me to the point where views were available so long as I first printed to a virtual printer as a pdf and then sent that file out to the wide-format printer.  Enough for a work-around in a pinch, but not a real solution.  But that's not the end of the story.

Late last year I bought a small (used) i5 desktop to replace my antiquated dual core.  The new machine already had a clean install of W10-64 Pro when I received it.  My usual custom and practice when I get a new machine is to do clean installs of the programs I intend to continue using, migrate/transfer all of my user/data files, make sure everything plays nice and then swap out the old desktop with the replacement unit.  This time I decided to do nothing more than install my wireless network adapter, install the HP7720 wide-format printer, install TurboCAD  (yes, that would be Ver 16) and then transfer over my CAD files.  I pulled up one of my old files and, voila, there were all of the Named Views and output to the HP7720 worked just like it was supposed to. 

Long story short, everything now works great and views are no longer a problem.  If I was to guess what the culprit was, I would be inclined to say it was the new HP driver installed over the old Win10 (it was Win10-32 Home upgraded from Win 7), but I have nothing to back that up other than the printer install went a lot smoother on the replacement i5 than it did when I first installed it on the old machine.  Good luck!

Tom
 
   

Logged


* March 15, 2019, 07:33:41 PM
#7
I have the same issue with my 7740. I was also printing to a PDF printer but that is kind of annoying. I found printfab printer drivers. I can now print directly to my 7740. Now, printfab is not free but its color control features were interesting to me for other apps. My printer was not listed in its supported printers list but I found one that works as expected.

It does have some oddities in it's print tray selection ( if you have multiple trays ) but auto select works fine. The other issue is no scanner support for MFP devices, but that was also an easy work around. I set up another device as 7740_scanner using the HP driver. This for me has been the best solution. It also solved the same print problem with another software I use.

There is a 30 day trial if you want to try it.

I'm have no association with this company, just want to pass on a possible solution I found.

Logged