TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

From Bad to Worse - Now Lost the Co-ordinates / Grid / Rulers
Read 1168 times
* November 16, 2018, 02:00:01 PM

I don't know what the heck is happening - I've lost the Inspector Bar access, and now effectively lost the Origin, Co-ordinate control, Grid and Rulers. They are still on the screen, but all now mutually out of step so meaningless.

I've tried regaining control via the assorted settings cited in the Manual, but none did anything.

The co-ordinate origin no longer matches the grid, I am not convinced the little co-ordinate indicator symbol still means anything;  the rulers no longer match the grid, it is no longer possible to align objects to any of these. They were ALL working until now!

I realise I should not have tried to create a 3D drawing, as that must be what's screwed everything up. While working on that, I found the "Delta X, Y or Z" entries created moves along the wrong axis direction arrows, in various 3D views. 

Even on a new 2D drawing to which I'd copied the primary image, when I tried to copy its end elevation to a set point on the grid, it moved to a strange location not the typed-in co-ordinates, the Rulers or Grid numbers, and seemed to acting in a vague 3D mode.

I have been through all the relevant Set-up Options but cannot find anything to repair the damage.  Anyone any ideas please? Without them, and the Inspector Bar access, the programme is useless even for 2D, and I may as well give up and delete it from the computer!


On TC Deluxe 19: hobby use.

November 16, 2018, 02:17:23 PM
When things are mucked up this much, I exit TurboCAD, find the instructions to delete the Built-In Folder (http://forums.turbocad.com/index.php/topic,9797.0.html) and re-start TurboCAD, then set my preferences.


TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1

* November 16, 2018, 05:48:42 PM

Hi Nigel,
There are thousands of combinations of commands within TC to master, with each giving a different reaction & variation of a result.

Below is a Link to a Tutorial that is designed for Deluxe V16 ... comes complete with PDF manual (just print it)


Even just for the purpose of reading the manual ... this will give you a excellent insight to the workings of TurboCad



* November 17, 2018, 08:36:48 AM
Thank you both.

It's beginning to look as if re-installing TurboCAD (from the CD I purchased) will be the only answer.

I tried to find that path to Built-in Folder, but its either just does not exist on my WIN 7 system, or is so well hidden that the file lists do not show them. It's not helped by the system having about 4 folders called "user" or similar, some being apparently duplicated links to the same sub-folders!

What worries me is that the problem is deeply embedded beyond my computer-admin knowledge. That link to the relevant instructions opens a discussion about "Common Problems..." which shows that people with far greater IT skill than mine, struggle with it but need that depth of skill to be able to cure the problem.

TurboCAD was working fine, then suddenly played up for no clear reason.

I'll try searching again from further along the directory tree quoted....


On TC Deluxe 19: hobby use.

* November 17, 2018, 08:53:33 AM
Just tried. No luck.

If that Built-In folder is there at all, the computer could not find it.


On TC Deluxe 19: hobby use.

* November 17, 2018, 09:20:50 AM
It's nomally a Hidden folder, but you can change your windows settings to show it, the most common place for is;
C:\Users\YOUR USERNAME\AppData\Roaming\IMSIDesign\TurboCAD your version\your edition\Data\Profiles
I dont have TC on default place, so for me it is;
D:\Users\Torfinn\AppData\Roaming\IMSIDesign\TurboCAD 2018\Professional x64\Data\Profiles in example

If you right click on the windows symbol down on your left corner and select Run and type in %appdata% and hit enter it will take you to the "Roaming" folder, and then you follow it from there to the Built-in.

TC should be closed when you do this, and what you delete is your personal settings in TC, so next time you open TC it will be with factory settings.


V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB

* November 17, 2018, 12:37:25 PM
Just tried. No luck.

If that Built-In folder is there at all, the computer could not find it.

My recommendation is to forget about that folder. A better procedure, IMO, is to close TCad and then run the TCad installer again, with the "Repair" option enabled. This removes the  "Built-in" folder (among other things) and it's easier than a full uninstall/reinstall. (That folder will be automatically rebuilt the first time you run TCad after repairing.) The possibility remains that "Repair" won't do the job and a full reinstall just might be necessary anyway -- but do try "Repair" first.

Henry H


* November 17, 2018, 04:47:22 PM
Thank you Henry!

Actually, I think I might have found the problem's source - that 3D version. Not something throwing TurboCAD as a whole out, but one drawing throwing its own layout by something embedded in it? Perhaps??? Drawings I'd made some time ago seem fine, though I had to try several before finding ones drawn in Model Space.

I'll explain in more detail what I had done....

 The drawing is of a new version of that two-throw crankshaft I put on the gallery, closer to the real one I wish to make. 2D only, the long elevation and one end elevation. So far so good, at for a workshop drawing once properly dimensioned, then I did this to it:

  Turned the main elevation into a Group, for copying into other drawings including the GA.

  Tried to make a 3D version by Line Thickness (so unexpected, odd results for parts), slowly and painfully building it as a column of cylinders moved arithmetically to their respective "heights". So far the 4 webs were all circular. Then Selected the whole "volume" and rotated it about one axis from vertical to horizontal.

   Still OK so far, I think. Returned to 2D view, modified one end web to the typica balanced shape, on the end elevation.

   Is this is where it started to go haywire? Managed to make that  end elev. into a Polyline - a struggle, the various lines and arcs just did not want to meet - then tried to turn it into an Extrusion. This on the same sheet as everything else - could that have thrown the co-ordinates out?

It was after this that nothing worked. I learnt long ago that if something goes wrong in TurboCAD gives no clue what or where!

So could the 3D version have implanted its own, rather random, co-ordinates; embedded so firmly they cannot be altered?

It seems my first, best action is to look at older drawimngs. Yes, they are still as they should be.

So, start a New drawing on a New file... I'll pause here and perform a quick test, the basics of the end elevation and central spine (a long rectangle) of the shaft, all neatly on the X-axis with the end elev. on (0,0).

Yes - new file, new name. Closed and re-opened, bears this out - all neatly where I wanted them, with the Grid and Rulers in line. 

What I need to know, is what exactly I did wrong, to give some hope of not repeating the mistake, perhaps with a much more complicated drawing.



On TC Deluxe 19: hobby use.

* November 29, 2018, 11:18:12 AM
Finally found the problem - thankyou all.
It all lay in one drawing and its two varied copies.

After re-loading the entire programme and still having trouble, a "changing workplanes" message on a supposedly 2D drawing and its copies, finally gave a hint...

The Manual is very uninformative but suggested the right direction: I had tried to start a 3D version by extrusion, but it failed. I thought I'd cleared them, but the three variants still held lingering 3D fragments on random co-ordinates, throwing work-planes everywhere.

I scrapped the 3 drawings and started again, now in 2D only... though still have not established how you are meant to make closed shapes like rectangles snap together. (I assume it's possible, but I found nothing to help me, though am not helped by the Snaps section being all jumbled up with about Layers.)

Still, the re-loading did let in an Up-date, and I was able to revise the tool-bars. I thought I'd lost the Copy In Place tool, to my annoyance as I use it a lot, but it's actually moved home and changed name and sign!   


On TC Deluxe 19: hobby use.