TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.

Help with Dimensioning please
Read 859 times
* October 08, 2018, 03:55:22 PM
Hi Turbo people,

I am currently using 2016 Deluxe on  Windows 7 platform and I am working on updating some plans which I first started back in 2011 with a previous TCad version. My problem is that although I am working in metric when I start doing dimensioning it reads the dimension  in inches. I have tried to change the Units section in their properties to millimeters as I would like it but the measurement figures change, I can change it to any style and the dimension figures change. e.g. I  dimension a section of the plan and I will get a reading of 3156 inches which I know is actually 3156mm's and is what I had drawn. If I then set it  the Units to my desired mm's then the reading changes to 80162.55 mm?!! & so on. It is doing my head in and I would appreciate it if you people out there, can advise what is going wrong and how to correct this?

yours frustrated. :-\


* October 08, 2018, 06:20:16 PM
I will get a reading of 3156 inches which I know is actually 3156mm's and is what I had drawn. If I then set it  the Units to my desired mm's then the reading changes to 80162.55 mm?!!

yours frustrated. :-\

Dear frustraded

 3156mm x 25.4 = 80162.55 mm (calculator actually answers 80162.4 mm)

So the key issue is a setting of 25.4mm = 1 inch.

In your case .... The drawing is being measured by a scale value of x25.4  ..... or ..... The actual Model Space is set to a Drawing scale of 25.4

Select the "Orthogonal" dimension tool / RM Click / Properties / Units,Tolerances
At the top >> Append Units << un-tick.

Is there a setting of 25.4 << Change that?

Look at all settings, Compare to how they should look / set-up, when using a Normal Metric Drawing.

Did the drawing go through a DWG conversion? .... This could could explain the "inch" issue ... as DWG is Imperial by default.
Re check settings via Options / Space - Units

Sometimes its easier to just create a New Blank File from Page Setup Wizard .... Using the Top line only >> EDIT / Select all / Copy >>> Then in the blank new file "Paste".
Save the New file .... and see how it goes.



* October 09, 2018, 02:28:18 AM
when you change the unit via options space units there is a checkbox at the bottom of the dialogue box
"convert units after alteration" make sure it is unchecked when you change the units.
This stops the sizes from scaling up as they are already correct.
If you had drawn in feet and inches and then wanted to convert the units but keep the size  you would check that and the sizes would change to be correct (ie 1foot by 1 foot would convert to 304mm by 304mm). - I hope that makes sense.

If you have saved the drawing and the units are all wrong, the easiest (for me) is to calculate how much  the dimensions are incorrect by  (the size you want  divided by the size it measures) , then selecting all and scaling in the x and y  and z by that figure.

If the dimensions are still not right but you can see, when you select something that the drawing is correct check the properties of the dimensions.
 You could also post the drawing if it is easier.
« Last Edit: October 09, 2018, 08:10:54 AM by nikkipollard »

TC20 platinum
TC 2015 platinum
TC 2017 with lightworks

* October 11, 2018, 08:38:30 PM
Greetings Mike and Niki,

and a great big thank you to both for your very helpful responses and suggestions. The plans look great and the dimensioning is spot on. Thanks again and muchas gracias to you both. yours un-frustrated now.  :)