TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.

Why can I not move TurboCAD files to a new location/folder on my computer?
Read 956 times
* May 20, 2018, 08:48:26 PM
I have recently purchased TurboCAD 2017 and have run the upgrade to 2018.
The actual program seems to be running fine however I have tried to move a couple of the training drawings I've done to another folder on my PC and they won't move and can not be copied and pasted elsewhere in my computer.
I assume this has to do with permissions? I have tried going into the file properties and changing security items but that doesn't work either.
As there are 4 drawings I am having the same issue with I assume it is a setting/permission within TurboCAD I need to change for when I save drawings. Can anyone please shed some light on this?
I have tried looking through the user guide and can't find answers there either.

Also - do I have to right click on the TurboCAD icon and choose 'Run as administrator' every time I run this program? Or is there a way for me to be the administrator full time?

I apologise if these are silly questions, I have just started my own CAD Services business and at my last job where I learned this program it was V19 and I never had to set anything up - just ran a template that was always there for me. So am struggling with setting dimensions and print sheets to scale as well etc  :(
Any help is very welcome thank you!


* May 20, 2018, 10:47:50 PM
I dont know about the 4 drawing's but if you can open them, will it not bee possible to Save As with a different name in another location.

You only need to run as admin 1 time.

If you have some drawings back from v 19 and your setting's is like you want, open in v 2018 and save as Template (.tct) in your Template folder, then delet everything inside there that you dont want to have and save again, then use that Template next time when you draw something, just rember to save as a .tcw in correct location first time after you saved something as a .tct


V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB

May 21, 2018, 02:36:32 AM
Would you please list the entire folder tree that points to where you are trying to save the files?

I am inclined to believe that it is, indeed, about permissions, especially if you are trying to save under C:\Documents and Settings or C:\Users.  If that is the case, then you can do it by running TurboCAD in Administrator mode.


TC Pro Platinum 2020, 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1

* May 21, 2018, 08:01:29 PM
Hi There,

Thank you so much for your replies, I have done as you suggested and opened and save files in preferred location and it worked.
I will also give the opening of my old V19 template a go too.
Thanks again for your help - very much appreciated!

Kind regards