TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.

"Not enough space on drive c:\ to extract this package"
Read 2279 times
* May 10, 2018, 05:23:56 PM
Hello Cadders,

Yesterday I bought TurboCad 2018, downloaded and extracted the files, but when I run "TurboCAD_2018_23.5_x64.exe" I get the above error popup.  I'm guessing it isn't a TurboCad problem, rather a windows (7 Home Premium) one, but hoped someone from this community might have had the same problem and knows of a solution.  There is over 1TB of space on my C: drive.

I have tried running as Administrator, using a different User Account, cleaned up the TEMP & TMP folders, restarted the computer a few times, with no luck to date.  Next I'll think of another large program to try to install to see if that works, looking for clues.

Any solutions you know of?

Best wishes,



May 11, 2018, 12:35:22 AM
When I installed, I double-clicked on the setup.exe program.  Do you see that?  Can you show the folder contents that you used for installation?

Also, open Windows Explorer and right-click on the C: drive (under Desktop / Computer), then click on Properties to show the Used Space and Free Space values.  If the value is really too small, then click on the Windows Start Button and enter the term "Disk Cleanup".  When you find and run that app, you will see something like the attached image; pick the suggested folders and see what you can recover.


TC Pro Platinum 2020, 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1

* May 11, 2018, 07:13:48 AM
Thanks Jeff. I did have over 1TB free space on the C: drive.  But I've also done a bit of clean-up since whilst I was looking :)

Today I decided to see if installing the Symbols would work, and it did.  I used setup.exe as per usual. Pls see pic of Directory.  So the install system seems to be working.

When I unzipped the download, I got the structure in the other picture.  There was only "TurboCAD_2018_23.5_x64.exe" to run.  That didn't surprise me 'cos that's how I installed "TurboCAD_Pro_2017_26.3_x64-2.exe".

So I thought I'd get a new download via the link in my confirmation email  today with the same link and serial number that I used first, but got an error "Invalid serial number entered!"

I think I'll have to contact the supplier tomorrow.  I have to say, most times I have no probs at all with TC installs.  I did have a Win Update a couple of days before this!

Leigh  :)


* May 13, 2018, 08:43:13 AM
Hi, Leigh.  Here is a link to a thread in which I had the same problem a couple of years ago.  Hope it helps.



Platinum - V21, 2017 (w/LightWorks), 2018
Deluxe - V17, V18, V19, V20

Intel Core i7 CPU @ 3.40GHz, 16GB Ram
Windows 10 Home  64-Bit

* May 20, 2018, 04:54:03 PM
Hi folks;
I had a very similar experience with my TC2018 Expert upgrade recently.  After trying all possible and recommended solutions (run as admin; disable AV program etc) I was about to give up. I then remembered receiving a WIN10 Update a few days before.  Then a few days ago I got the WIN10 April2018 Update and hey presto all started working with the install again.
It appears MS locks aside a huge chunk of your drive, and makes a roll-back copy of your current WIN10 (also a huge file) in preparation for the update, then installs the WIN10 Update before releasing the drive space.
I use a 64bit system and had nearly 1TB  of free space reported but until the update was completed it would not let me upgrade/update TC.
May not be the problem for all but worth keeping an eye on for others if you encounter a similar problem.

TC2019 Pro
Beginner (with much to learn) mainly period ship plans and fittings, wood toy plans.