TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Turbocad 2017 unstable
Read 1108 times
* May 06, 2018, 02:25:43 AM
I have been using Turbocad Platinum/Pro since the year 2000 and have regularly upgraded with my last upgrade being from 2015 version to the 2017 version. There have always been some bugs in it but I have been able to work around them and have had satisfactory use from it on a Windows  7 machine. I thought some of the bugs may have been because I am still running Win 7(64).
I installed the 2017 version on my Win7 machine first and after a few re installs I finally got the program to recognise my library files ( I had to uninstall all previous versions of Turbocad for the install to work properly).
The program worked OK except for the plan view workplane occationally, without warning, going from top view to bottom view and also with the pallets on auto hide, when the pallet withdrew it left remnants of the pallet behind. REDsdk still had to be turned off for standard drawings as it was in the 2015 version.
I then installed 2017 on a fairly new Win10 laptop (I7 /16 GIG machine with graphics card). The config file for the setup did not work properly and some of the pop up menus had to be re populated. Interesting to note that the standard top view icon was now blue (instead of the usual orange). Now instead of the Win10 version being more stable it had problems where named views would change, the show workplane on the other views (front say) failed to work and also named cameras when opened in design director would change their positions when the attach icon was pressed. After a few new installs the problems persisted. When contacting Turbocad Support they seemed to indicate that my problems were in REDsdk which was now no longer in any Turbocad version and that they would not provide support to these problems. As I have only just recently purchased the upgrade I asked for my money back from the software supplier and they offered me a free upgrade to Turbocad 2018 which I accepted. I then uninstalled Turbocad from my Win 10 machine and it seemed to have corrupted Win10 and other programs failed to run resulting in me having to spend days reinstalling a new version of Win10. Turbocad won't be installed on that machine in a hurry!
Now back to my Win7 version, I have just been playing with the edit tool to try and see if I can connect individual joined lines into a closed object (after much reading, research and trying cannot seem to do it). After having played with the edit tool for some time today I find now the snap to grid function only stays on for one click and then disappears again making drawing virtually impossible. Restarting the computer did not solve this problem. Look like another re installation is required.
I have had more problems with Turbocad 2017 than in the previous 18 years combined. Perhaps spending some time to test the program (perhaps even make it testable) rather than adding new features would be in order.
As you can imagine I am not pleased at having spent AU$500 of my hard earned cash to purchase an upgrade which has given me so far just grief and resulting now in a program that is unusable. I hope that 2018 will be a more stable program otherwise I will insist for my money back and my 2015 version .


* May 06, 2018, 05:32:34 AM
Wow, you do seem to have had a few problems,  with regards not providing support,  Obviously I don't know what they said, but they do still support RedSDK, and indeed in 2018 it is a 'paid for' plug-in, or at least it will be when they get round to marketing it.

Some things, like the palettes thing, do sound like a graphic card issue, but I'd only expect it to really be a problem in RedSDK mode, assuming RedSDK is using you graphics card and not any motherboard graphics,  (options menu - native draw - show video system information).

I have not got 2018, but in theory, without RedSDK TC should be stable,   that said I've used RedSDK in v2015 v2016 and v2017, and have not found it to be too unstable, though our systems are completely different, (mine is a windows 10 desktop, old gtx 660 graphics card).

Hope 2018 performs much better for you.


May 06, 2018, 05:47:03 AM
Sorry to hear you are having problems with TC installations...

I do not think this is all down to TurboCAD otherwise they would have far more unhappy customers and testers.

You comment on this "When contacting Turbocad Support they seemed to indicate that my problems were in REDsdk which was now no longer in any Turbocad version and that they would not provide support to these problems."

This is news to me and I am sure a few others that use RedSDK for many of our professional work. Maybe someone from IMSI could chime in to clarify what is meant by this please?

I also have , like many users have, quite a few TC versions installed on my laptop and never had to uninstall these for new versions. Even running them at the same time is not a problem for me.

TC2017 runs well on my machine so I am not sure why you are having so many problems with it?

All versions are tested and I use it professionally to design kitchens and bedrooms so to say we is not tested is incorrect. I personally spend hours during my work hours and in my own time testing, reporting issues and bugs.

If it was that bad then I could not and would not use the software.


V2020 & V2019 Plat 64bit + REDsdk Plugin, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.

* May 06, 2018, 07:05:10 AM
I am having a few problems with 2017 Pro Platinum myself.

The 'workplane by three points' often will not 'take' on the first couple of tries.

I have stopped trying to get RedSDK working on this machine.  It is a laptop and probably around 5 years old. 
RedSDK not working isn't an issue for me since I do not use 'rendering' of any sort for my drawings.

I have several versions of TC installed on this unit and have had no issues because of it.

I have used TC since 2001 (approx), I think that may have been version 9?
IMHO, there has always been some flakey issue with every version.

I just had a 'support' issue.  I emailed in the evening, got an acknowledgement the next day, a resolution in the afternoon.
It wasn't a big issue, but they were quick in response.


May 06, 2018, 02:24:44 PM
Ive been using TurboCAD 2017PP since its release and found it very stable, what I did find early on was that the graphics driver did give me issues. Using an older Nvidia driver did cause screen gremlins and once identified the problems where overcome. Cant blame tcw alone as the operating system and drivers may and in many cases do cause problems or a combination do affect the balance. I still notice that occasionally  I cant select the reference point on the 1st try if I go to copy or move and object, it seems as if Im just too quick to pick the object for the screen driver.  Also had issues with the virus protection interfering as well and an update here fixed that as well.

Sometimes the best advice comes from the experienced forum members here as weve all had problems somewhere that collectively solved complex issues. Darrell Durose is right if there where serious issues then those issues would be seen by m9re testers and other forum posters.

Please list your computer specs, installed software and virus protection and other info so that we can help to solve issues.

Willo47 based on your problems that you state, for all those issues to come from one install would never be missed by the testers. I suspect imho that something else is causing your problems or contributing to them. Post as much info as you can and or post the offending tcw file.

TCW V21, 2015-2020 PP, Animation Lab V5.2 & Redsdk enabled, LightWorks rendering mostly. Ender 3 3D printer.

* May 06, 2018, 09:13:39 PM
Hi to all who replied,
If I only had problems with one install then I could believe that the problem be with my machine.
The problems I had with my Win10 machine was the most concerning as this was a nearly new computor (6 months) and was used for my music computer with basically only a Digital Audio Workstation installed (which works flawlessly on the computer). It is unlikely that my Windows10 system was corrupted. I don't even surf the web on this machine!
I did have REDsdk turned on throughout my tests however the problems that I had with named views and named cameras changing and show workplanes not showing on secondary views did not sound like a REDsdk problem as I assume it is the render engine only. Re the support comment that REDsdk no longer being supported: I did notify my software supplier and they were surprised and were going to take it up with IMSIdesign.
Thanks for the offer for assistance. At this stage my Win7 install on my desktop is sufficiently stable in its present form to be used so I can get on with my work.
Re the snap with magnetic view only visible for one click then dissapearing. That was finger trouble as I inadvertently turned snap off on the inspector bar. Problem is that I am so on edge with the problems that I had (especially having to reinstall Win10 on my laptop after an uninstall of Turbocad 2017 seemed to corrupt the system) that I am now what you might call a bit shell shocked and jump quickly to conclusions.
Since I am getting a Turbocad 2018 upgrade which will come out shortly I will wait to install this in my Win7 machine to see how it performs before taking up any issues re the above.
In summary wrote the post as I had to let off some steam about my frustrating experience with the Turbocad 2017 . I have not have had  problem with all of my previous version updates over the past 18 years.
Thanks again