TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

All posts discussing pricing or where to buy TurboCAD will be deleted.

Exception Access Violation in DBAPI16.dll
Read 1921 times
* April 07, 2018, 10:06:59 AM
Hello All,

I'm running Turbocad 16 deluxe on Windows 7 64 bit. Or rather I'm not. It's been working perfectly well for the last two years, I came to use it today after not using it for a couple of months and the program will not start up. It begins to, then I get a pop-up saying that an "Unhandled Exception (crash) has occurred in the program". When I look at the details it tells me that "Tcw16.exe caused an EXCEPTION_ACCESS_VIOLATION in module DBAPI16.dll at 0023:0613CE, TableGetpropertyInfo()+0212byte(s)".

I have uninstalled and re-installed from my installation disk. I have uninstalled and re-installed from a download in the File Library on this Forum, I have re-booted and re-installed again - but still the same thing happens.

Does anyone have any idea what I can do to solve the problem?




* April 07, 2018, 02:37:51 PM
When you uninstalled TC, did you do a 'full' removal or just use windows,  sometimes things are left behind.

Three things come to mind,  either something gone screwy in the registry, or, Windows has sent out an update which messed things up, like a recent windows 10 update that crashed quite a few computers (though I understand your using windows 7).

Or, you need to do an almost 'full' uninstall (without registry stuff).  Uninstall TC, go to This Post, to where it says 'clean install'. 

But - also go to Documents (or My Documents) - TurboCAD 16, copy everything in there (AutoSaves, backups etc.) into a new folder somewhere on the computer so you have a copy of everything, then delete the whole folder TurboCAD 16 folder,  if TC re-installs OK, you could copy things back if necessary.

Try a re-install,  There have been reports of UAC (windows user account) settings messing things up. but I'd try the above first as I haven't personally had any problem with UAC. 


* April 07, 2018, 04:15:09 PM
Hello Andy,

Thanks for your input. I just did everything you suggested - and then I ran CCleaner and did a registry clean up too. Turbocad re-installed easily but it still does exactly the same when I try to run the program.

Any other ideas? Anyone?



* April 07, 2018, 06:40:54 PM
I'm wondering if DBAPI16.dll is a Windows file.

Henry H


* April 08, 2018, 03:34:15 AM
Sorry it didn't help John.   I just did a search on the forum, and came across a few posts, I doesn't seem like there is one specific cure, but two people in the same thread suggest a new file may be required from IMSI support, though these posts are from 2010 so I don't know how relevant they are in 2018.

The posts are in this thread, from bschwarz and iainmilligan

All I can suggest is to contact support detailing what you have already tried, and mentioning the above thread just in case it still applies, if you manage get it sorted could you post back here, as it may help people in the future.

IMSI Support 


* April 08, 2018, 05:56:46 AM
Hi John,

I did a quick search and came across an article about the origin of DBAPI16.dll.


I don't recommend downloading any fixes from third party advertisers, just read the article all the way down to the bottom.



TurboCAD 2018 Pro Platinum 64-bit (V25 build 49)

Processor   Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz, 3701 Mhz, 4 Core(s), 8 Logical Processor(s)

Graphics   NVIDIA GeForce GTX 750 Ti
Windows 10 Pro Version 10.0.17134 Build 17134

TurboCAD 2016 Pro Platinum 64-bit (build 57.2)
Lightwoks Plug-

* April 08, 2018, 10:05:02 AM
Hello Andy, Yes I saw those threads too so I've started a ticket with customer support directing them to it and asking if the file they supplied before would work for me.

Hi Steve, I tried the command prompt thing suggested there but it just says that "dbapi16.dll failed to load". I'm going to wait for the reply from customer support before I try manually editing my registry.

Thanks guys.


* April 08, 2018, 10:53:24 AM
You could try the Built-in route or more correct delete the full DL 16 folder in there.

C:\Users\User\AppData\Roaming\IMSIDesign\TurboCAD 16 (or similar to this),
appdata is often a Hidden folder but type %appdata% in windows "RUN" section will bring you to the Roaming folder
and you go from there.
C:\Users\User\Documents........DL 16

Then you will get as close to a clean install that is possible, normally you dont need to un/ re install at all i have been told few days ago.
But be aware, there are maybe some thing you want to save outside TC in there, as cfg's, Template and drawings, symbols etc etc.


V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB

* April 08, 2018, 11:14:02 AM
Hello Torfinn,

Thanks, but I've tried that already. I copied the drawing that I wanted to keep to a different location and deleted the folder at the same time as the uninstall. Sadly, it made no difference...



May 10, 2018, 06:39:19 AM
... so I've started a ticket with customer support directing them to it and asking if the file they supplied before would work for me.

I think it exceedingly unlikely that you will get any significant customer support for a version that is 9 years old (except for the forum users, of course).

DBAPI16.dll is not a general Windows file, it is only used with TurboCAD V16 (the numeric portion iterates with the version number). 

I would suggest completely uninstalling the program (I don't think cleaning the Registry is necessary, but CCleaner wouldn't hurt) and re-installing in Administrator mode.

Last week, I ran a complete system check using Windows Defender and it found 40+ problems that were not found with the quick check.  I have two backup drives, so there were more than 100 million files to check and it took a few days (I was sick and not using my computer anyway), but when it was finished, Hibernate and Sleep mode worked again, so there is the possibility that you have something interfering with TurboCAD.

Alternatively, you might try running a repair of your Windows installation if you have the installation disk.

Keep in mind that Defender returned at least one false positive.  YMMV, and you may want to use a different anti-virus.


TC Pro Platinum 2020, 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1